summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-05-01 10:44:39 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-05-01 10:44:39 +0000
commitf591032a8fcb07801a27b6aeb324250f6215a626 (patch)
tree60b9fb615a3b40c4482f4fbb92a169dd88d6c6e8
parentDon't depend on test-unit-2 at runtime. (diff)
downloadgentoo-2-f591032a8fcb07801a27b6aeb324250f6215a626.tar.gz
gentoo-2-f591032a8fcb07801a27b6aeb324250f6215a626.tar.bz2
gentoo-2-f591032a8fcb07801a27b6aeb324250f6215a626.zip
Version bump for series two, it still causes problems but is needed for some cases.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
-rw-r--r--dev-ruby/test-unit/ChangeLog9
-rw-r--r--dev-ruby/test-unit/test-unit-2.0.5.ebuild37
-rw-r--r--dev-ruby/test-unit/test-unit-2.0.7.ebuild (renamed from dev-ruby/test-unit/test-unit-2.0.6.ebuild)2
3 files changed, 9 insertions, 39 deletions
diff --git a/dev-ruby/test-unit/ChangeLog b/dev-ruby/test-unit/ChangeLog
index 3a6e4f1b23ae..f69ff9f0001f 100644
--- a/dev-ruby/test-unit/ChangeLog
+++ b/dev-ruby/test-unit/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/test-unit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.15 2010/01/14 23:48:10 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.16 2010/05/01 10:44:39 flameeyes Exp $
+
+*test-unit-2.0.7 (01 May 2010)
+
+ 01 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ -test-unit-2.0.5.ebuild, -test-unit-2.0.6.ebuild, +test-unit-2.0.7.ebuild:
+ Version bump for series two, it still causes problems but is needed for
+ some cases.
*test-unit-1.2.3 (14 Jan 2010)
diff --git a/dev-ruby/test-unit/test-unit-2.0.5.ebuild b/dev-ruby/test-unit/test-unit-2.0.5.ebuild
deleted file mode 100644
index 1d7078b6039c..000000000000
--- a/dev-ruby/test-unit/test-unit-2.0.5.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-2.0.5.ebuild,v 1.4 2010/01/14 23:48:10 flameeyes Exp $
-
-EAPI=2
-# One test fails on jruby, might be a jruby bug
-# When enabled on ruby18 it breaks too many things, so don't enable it for that just yet
-USE_RUBY="ruby19"
-
-# Don't enable docs yet since this requires hoe
-RUBY_FAKEGEM_TASK_DOC="" # doc
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="TODO README.txt History.txt"
-
-inherit ruby-fakegem
-
-#ruby_add_bdepend doc dev-ruby/hoe
-
-DESCRIPTION="An improved version of the Test::Unit framework from Ruby 1.8"
-HOMEPAGE="http://test-unit.rubyforge.org/"
-SRC_URI="mirror://rubyforge/${PN}/${P}.tgz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS=""
-IUSE=""
-
-each_ruby_test() {
- # the rake audit using dev-ruby/zentest currently fails, and we
- # just need to call the testsuite directly.
- # rake audit || die "rake audit failed"
- local rubyflags
-
- [[ $(basename ${RUBY}) == jruby ]] && rubyflags="-X+O"
-
- ${RUBY} ${rubyflags} test/run-test.rb || die "testsuite failed"
-}
diff --git a/dev-ruby/test-unit/test-unit-2.0.6.ebuild b/dev-ruby/test-unit/test-unit-2.0.7.ebuild
index 391c0306f6f9..524b8ab1aab1 100644
--- a/dev-ruby/test-unit/test-unit-2.0.6.ebuild
+++ b/dev-ruby/test-unit/test-unit-2.0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-2.0.6.ebuild,v 1.2 2010/01/14 23:48:10 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-2.0.7.ebuild,v 1.1 2010/05/01 10:44:39 flameeyes Exp $
EAPI=2
# One test fails on jruby, might be a jruby bug