summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-02-22 23:56:43 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-02-22 23:56:43 +0000
commitfe1a05b982af543b62f9f1bb4fc2eae43062146e (patch)
treeb8637ba8d15d55ce56ea9f53cd3de1d48a10822f
parentVersion bump. (diff)
downloadgentoo-2-fe1a05b982af543b62f9f1bb4fc2eae43062146e.tar.gz
gentoo-2-fe1a05b982af543b62f9f1bb4fc2eae43062146e.tar.bz2
gentoo-2-fe1a05b982af543b62f9f1bb4fc2eae43062146e.zip
Version bump.
(Portage version: 2.2.0_alpha88/cvs/Linux x86_64)
-rw-r--r--dev-ruby/mongoid/ChangeLog8
-rw-r--r--dev-ruby/mongoid/files/mongoid-2.4.5-gentoo.patch31
-rw-r--r--dev-ruby/mongoid/mongoid-2.4.5.ebuild77
3 files changed, 115 insertions, 1 deletions
diff --git a/dev-ruby/mongoid/ChangeLog b/dev-ruby/mongoid/ChangeLog
index 4e847576dcf4..1bda9dabcbb2 100644
--- a/dev-ruby/mongoid/ChangeLog
+++ b/dev-ruby/mongoid/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/mongoid
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mongoid/ChangeLog,v 1.6 2012/02/13 18:37:19 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mongoid/ChangeLog,v 1.7 2012/02/22 23:56:43 flameeyes Exp $
+
+*mongoid-2.4.5 (22 Feb 2012)
+
+ 22 Feb 2012; Diego E. Pettenò <flameeyes@gentoo.org>
+ +files/mongoid-2.4.5-gentoo.patch, +mongoid-2.4.5.ebuild:
+ Version bump.
*mongoid-2.4.4 (13 Feb 2012)
diff --git a/dev-ruby/mongoid/files/mongoid-2.4.5-gentoo.patch b/dev-ruby/mongoid/files/mongoid-2.4.5-gentoo.patch
new file mode 100644
index 000000000000..96b067815e3a
--- /dev/null
+++ b/dev-ruby/mongoid/files/mongoid-2.4.5-gentoo.patch
@@ -0,0 +1,31 @@
+From 78742c815c15a2fd839705e9cd832479a5729f3b Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Diego=20Elio=20Petten=C3=B2?= <flameeyes@flameeyes.eu>
+Date: Mon, 23 Jan 2012 02:10:41 +0100
+Subject: [PATCH] Add one missing replacement of localhost vs envvar
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+
+Signed-off-by: Diego Elio Pettenò <flameeyes@flameeyes.eu>
+---
+ .../mongoid/config/replset_database_spec.rb | 3 ++-
+ 1 files changed, 2 insertions(+), 1 deletions(-)
+
+diff --git a/spec/functional/mongoid/config/replset_database_spec.rb b/spec/functional/mongoid/config/replset_database_spec.rb
+index 6f24971..e295422 100644
+--- a/spec/functional/mongoid/config/replset_database_spec.rb
++++ b/spec/functional/mongoid/config/replset_database_spec.rb
+@@ -32,7 +32,8 @@ describe Mongoid::Config::ReplsetDatabase do
+
+ it "does not modify the options in place" do
+ options["test"]["hosts"].should eq(
+- [["localhost", 27017], ["localhost", 27017]]
++ [[ENV["MONGOID_SPEC_HOST"], ENV["MONGOID_SPEC_PORT"].to_i],
++ [ENV["MONGOID_SPEC_HOST"], ENV["MONGOID_SPEC_PORT"].to_i]]
+ )
+ end
+ end
+--
+1.7.8.4
+
diff --git a/dev-ruby/mongoid/mongoid-2.4.5.ebuild b/dev-ruby/mongoid/mongoid-2.4.5.ebuild
new file mode 100644
index 000000000000..5837e9b0ef47
--- /dev/null
+++ b/dev-ruby/mongoid/mongoid-2.4.5.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mongoid/mongoid-2.4.5.ebuild,v 1.1 2012/02/22 23:56:43 flameeyes Exp $
+
+EAPI=4
+USE_RUBY="ruby18"
+
+#RUBY_FAKEGEM_TASK_DOC=""
+# functional testing crashes Ruby from within Portage, but works
+# outside of it, needs to be investigated thoroughly, but at least
+# unit testing works.
+RUBY_FAKEGEM_TASK_TEST="spec:unit spec:functional"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+GITHUB_USER="${PN}"
+GITHUB_PROJECT="${PN}"
+RUBY_S="${GITHUB_USER}-${GITHUB_PROJECT}-*"
+
+inherit ruby-fakegem
+
+DESCRIPTION="ODM (Object Document Mapper) Framework for MongoDB"
+HOMEPAGE="http://mongoid.org/"
+SRC_URI="https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}/tarball/v${PV} -> ${GITHUB_PROJECT}-${PV}.tar.gz"
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_rdepend "
+ >=dev-ruby/activemodel-3.1
+ >=dev-ruby/mongo-1.6
+ >=dev-ruby/tzinfo-0.3.22
+"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/ammeter
+ dev-ruby/mocha
+ dev-ruby/rdoc
+ dev-ruby/rspec
+ dev-util/watchr
+ )"
+
+DEPEND+=" test? ( dev-db/mongodb )"
+
+all_ruby_prepare() {
+ # remove references to bundler, as the gemfile does not add anything
+ # we need to care about.
+ sed -i -e '/[bB]undler/d' Rakefile || die
+ # remove the Gemfile as well or it'll try to load it during testing
+ rm Gemfile || die
+
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+each_ruby_test() {
+ mkdir "${T}/mongodb_$(basename $RUBY)"
+ mongod --port 27017 --dbpath "${T}/mongodb_$(basename $RUBY)" \
+ --noprealloc --noauth --nohttpinterface --nounixsocket --nojournal \
+ --bind_ip 127.255.255.254 &
+ mongod_pid=$!
+ failed=0
+
+ sleep 2
+
+ export MONGOID_SPEC_HOST="127.255.255.254"
+ export MONGOID_SPEC_PORT="27017"
+
+ ${RUBY} -S rake ${RUBY_FAKEGEM_TASK_TEST} || failed=1
+ kill "${mongod_pid}"
+
+ [[ "${failed}" == "1" ]] && die "tests failed"
+}