summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2008-09-19 00:06:56 +0000
committerWilliam Hubbs <williamh@gentoo.org>2008-09-19 00:06:56 +0000
commitb515ed8835ff2af7ecf0dc9f342ef0aff40d465b (patch)
tree9ac8cd98cc8a62f12c934aed2365732056ab747d /app-accessibility/espeak
parentPreparing qt4-build.eclass for qt-4.4.2 (diff)
downloadgentoo-2-b515ed8835ff2af7ecf0dc9f342ef0aff40d465b.tar.gz
gentoo-2-b515ed8835ff2af7ecf0dc9f342ef0aff40d465b.tar.bz2
gentoo-2-b515ed8835ff2af7ecf0dc9f342ef0aff40d465b.zip
version bump
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo-r1 i686)
Diffstat (limited to 'app-accessibility/espeak')
-rw-r--r--app-accessibility/espeak/ChangeLog7
-rw-r--r--app-accessibility/espeak/espeak-1.39.ebuild79
2 files changed, 85 insertions, 1 deletions
diff --git a/app-accessibility/espeak/ChangeLog b/app-accessibility/espeak/ChangeLog
index 038dde7273f4..ddbcd2ef5cb1 100644
--- a/app-accessibility/espeak/ChangeLog
+++ b/app-accessibility/espeak/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-accessibility/espeak
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/ChangeLog,v 1.54 2008/08/30 22:17:16 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/ChangeLog,v 1.55 2008/09/19 00:06:56 williamh Exp $
+
+*espeak-1.39 (19 Sep 2008)
+
+ 19 Sep 2008; William Hubbs <williamh@gentoo.org> +espeak-1.39.ebuild:
+ version bump.
*espeak-1.38 (30 Aug 2008)
diff --git a/app-accessibility/espeak/espeak-1.39.ebuild b/app-accessibility/espeak/espeak-1.39.ebuild
new file mode 100644
index 000000000000..5854fda629f8
--- /dev/null
+++ b/app-accessibility/espeak/espeak-1.39.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/espeak-1.39.ebuild,v 1.1 2008/09/19 00:06:56 williamh Exp $
+
+inherit eutils
+
+MY_P="${P}-source"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
+DESCRIPTION="Speech synthesizer for English and other languages"
+HOMEPAGE="http://espeak.sourceforge.net/"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="portaudio pulseaudio"
+DEPEND="portaudio? ( >=media-libs/portaudio-18.1-r5 )
+ pulseaudio? ( media-sound/pulseaudio )
+ app-arch/unzip"
+
+S=${WORKDIR}/${MY_P}
+
+get_audio() {
+ local MY_AUDIO
+
+ MY_AUDIO=none
+ if use portaudio; then
+ MY_AUDIO=portaudio
+ elif use pulseaudio; then
+ MY_AUDIO=pulseaudio
+ fi
+ echo ${MY_AUDIO}
+}
+
+pkg_setup() {
+ if ! use portaudio && ! use pulseaudio; then
+ ewarn
+ ewarn Since portaudio and pulseaudio are not in your use flags,
+ ewarn espeak will only bbe able to create wav files.
+ ewarn If this is not what you want, press ctrl-c and put either
+ ewarn portaudio or pulseaudio in your use flags.
+ ebeep
+ epause 10
+ elif use portaudio && use pulseaudio; then
+ die "You must choose either portaudio or pulseaudio, but not both."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ # portaudio.h is by default the same as portaudio18.h, but use the version
+ # 19 API if available
+ if use portaudio; then
+ if has_version "=media-libs/portaudio-19*" ; then
+ mv -f "${S}/src/portaudio19.h" "${S}/src/portaudio.h"
+ fi
+ fi
+}
+
+src_compile() {
+ cd src
+ emake AUDIO="$(get_audio)" CXXFLAGS="${CXXFLAGS}" all || die "Compilation failed"
+
+ einfo "Fixing byte order of phoneme data files"
+ cd "${S}/platforms/big_endian"
+ make
+ ./espeak-phoneme-data "${S}/espeak-data"
+ cp -f phondata phonindex phontab "${S}/espeak-data"
+}
+
+src_install() {
+ cd src
+ make DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)" AUDIO="$(get_audio)" install || die "Installation failed"
+
+ cd ..
+ insinto /usr/share/espeak-data
+ doins -r dictsource
+ dodoc ChangeLog ReadMe
+ dohtml -r docs/*
+}