summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2010-01-25 00:47:18 +0000
committerWilliam Hubbs <williamh@gentoo.org>2010-01-25 00:47:18 +0000
commit52080ba769e7f9650975055c6fa87d0b9dfedae7 (patch)
tree1a1d49024116abeededfc4541b68ba28d90336f9 /app-accessibility/speakup
parentAdd ldap and tokyocabinet USE flags. (diff)
downloadgentoo-2-52080ba769e7f9650975055c6fa87d0b9dfedae7.tar.gz
gentoo-2-52080ba769e7f9650975055c6fa87d0b9dfedae7.tar.bz2
gentoo-2-52080ba769e7f9650975055c6fa87d0b9dfedae7.zip
version bump
(Portage version: 2.2_rc61/cvs/Linux i686)
Diffstat (limited to 'app-accessibility/speakup')
-rw-r--r--app-accessibility/speakup/ChangeLog9
-rw-r--r--app-accessibility/speakup/speakup-3.1.4.ebuild76
2 files changed, 83 insertions, 2 deletions
diff --git a/app-accessibility/speakup/ChangeLog b/app-accessibility/speakup/ChangeLog
index 5b1041eec07c..6df78f09a98f 100644
--- a/app-accessibility/speakup/ChangeLog
+++ b/app-accessibility/speakup/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-accessibility/speakup
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speakup/ChangeLog,v 1.38 2009/12/03 20:43:20 williamh Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speakup/ChangeLog,v 1.39 2010/01/25 00:47:18 williamh Exp $
+
+*speakup-3.1.4 (25 Jan 2010)
+
+ 25 Jan 2010; William Hubbs <williamh@gentoo.org> +speakup-3.1.4.ebuild:
+ version bump
03 Dec 2009; William Hubbs <williamh@gentoo.org> speakup-9999.ebuild:
synced live ebuild with 3.1.1-r1
diff --git a/app-accessibility/speakup/speakup-3.1.4.ebuild b/app-accessibility/speakup/speakup-3.1.4.ebuild
new file mode 100644
index 000000000000..efd7733c7562
--- /dev/null
+++ b/app-accessibility/speakup/speakup-3.1.4.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speakup/speakup-3.1.4.ebuild,v 1.1 2010/01/25 00:47:18 williamh Exp $
+
+EAPI="2"
+
+inherit linux-mod
+
+DESCRIPTION="The speakup linux kernel based screen reader."
+HOMEPAGE="http://linux-speakup.org"
+SRC_URI="ftp://linux-speakup.org/pub/speakup/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="modules"
+
+MODULE_NAMES="speakup(${PN}:\"${S}\"/src)
+ speakup_acntpc(${PN}:\"${S}\"/src)
+ speakup_acntsa(${PN}:\"${S}\"/src)
+ speakup_apollo(${PN}:\"${S}\"/src)
+ speakup_audptr(${PN}:\"${S}\"/src)
+ speakup_bns(${PN}:\"${S}\"/src)
+ speakup_decext(${PN}:\"${S}\"/src)
+ speakup_decpc(${PN}:\"${S}\"/src)
+ speakup_dectlk(${PN}:\"${S}\"/src)
+ speakup_dtlk(${PN}:\"${S}\"/src)
+ speakup_dummy(${PN}:\"${S}\"/src)
+ speakup_keypc(${PN}:\"${S}\"/src)
+ speakup_ltlk(${PN}:\"${S}\"/src)
+ speakup_soft(${PN}:\"${S}\"/src)
+ speakup_spkout(${PN}:\"${S}\"/src)
+ speakup_txprt(${PN}:\"${S}\"/src)"
+BUILD_PARAMS="KERNELDIR=${KERNEL_DIR}"
+BUILD_TARGETS="clean all"
+
+src_prepare() {
+ use modules && cmd=die || cmd=ewarn
+ case ${KV_EXTRA} in
+ *gentoo)
+ if kernel_is lt 2 6 25; then
+ $cmd "Speakup requires at least gentoo-sources-2.6.25"
+ fi
+ ;;
+ *)
+ if kernel_is lt 2 6 26; then
+ $cmd "Speakup requires at least kernel version 2.6.26"
+ fi
+ ;;
+ esac
+}
+
+src_compile() {
+ use modules && linux-mod_src_compile
+}
+
+src_install() {
+ use modules && linux-mod_src_install
+ dobin tools/speakupconf
+ dosbin tools/talkwith
+ dodoc Bugs.txt README To-Do doc/DefaultKeyAssignments doc/spkguide.txt
+ newdoc tools/README README.tools
+}
+
+pkg_postinst() {
+ use modules && linux-mod_pkg_postinst
+
+ elog "You must set up the speech synthesizer driver to be loaded"
+ elog "automatically in order for your system to start speaking"
+ elog "when it is booted."
+ if has_version "<sys-apps/baselayout-2"; then
+ elog "this is done via /etc/modules.autoload.d/kernel-2.6"
+ else
+ elog "This is done via /etc/conf.d/modules."
+ fi
+}