summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2008-08-30 22:17:16 +0000
committerWilliam Hubbs <williamh@gentoo.org>2008-08-30 22:17:16 +0000
commit3c26b86d975812e302c8eae7c9751d44332a3704 (patch)
tree6cf3f5d3e23087ca484f6ab67078d06bebe521d7 /app-accessibility
parentworkaround conflict of USE=hal and usb. As per bug #236209 thanks to Sander ... (diff)
downloadgentoo-2-3c26b86d975812e302c8eae7c9751d44332a3704.tar.gz
gentoo-2-3c26b86d975812e302c8eae7c9751d44332a3704.tar.bz2
gentoo-2-3c26b86d975812e302c8eae7c9751d44332a3704.zip
version bump
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo-r1 i686)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/espeak/ChangeLog7
-rw-r--r--app-accessibility/espeak/espeak-1.38.ebuild79
2 files changed, 85 insertions, 1 deletions
diff --git a/app-accessibility/espeak/ChangeLog b/app-accessibility/espeak/ChangeLog
index c036f90a7852..038dde7273f4 100644
--- a/app-accessibility/espeak/ChangeLog
+++ b/app-accessibility/espeak/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-accessibility/espeak
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/ChangeLog,v 1.53 2008/08/09 20:35:13 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/ChangeLog,v 1.54 2008/08/30 22:17:16 williamh Exp $
+
+*espeak-1.38 (30 Aug 2008)
+
+ 30 Aug 2008; William Hubbs <williamh@gentoo.org> +espeak-1.38.ebuild:
+ version bump
09 Aug 2008; Tobias Klausmann <klausman@gentoo.org> espeak-1.37-r1.ebuild:
Stable on alpha, bug #233112
diff --git a/app-accessibility/espeak/espeak-1.38.ebuild b/app-accessibility/espeak/espeak-1.38.ebuild
new file mode 100644
index 000000000000..8241e99e04ff
--- /dev/null
+++ b/app-accessibility/espeak/espeak-1.38.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeak/espeak-1.38.ebuild,v 1.1 2008/08/30 22:17:16 williamh Exp $
+
+inherit eutils
+
+MY_P="${P}-source"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
+DESCRIPTION="Speech synthesizer for English and other languages"
+HOMEPAGE="http://espeak.sourceforge.net/"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="portaudio pulseaudio"
+DEPEND="portaudio? ( >=media-libs/portaudio-18.1-r5 )
+ pulseaudio? ( media-sound/pulseaudio )
+ app-arch/unzip"
+
+S=${WORKDIR}/${MY_P}
+
+get_audio() {
+ local MY_AUDIO
+
+ MY_AUDIO=none
+ if use portaudio; then
+ MY_AUDIO=portaudio
+ elif use pulseaudio; then
+ MY_AUDIO=pulseaudio
+ fi
+ echo ${MY_AUDIO}
+}
+
+pkg_setup() {
+ if ! use portaudio && ! use pulseaudio; then
+ ewarn
+ ewarn Since portaudio and pulseaudio are not in your use flags,
+ ewarn espeak will only bbe able to create wav files.
+ ewarn If this is not what you want, press ctrl-c and put either
+ ewarn portaudio or pulseaudio in your use flags.
+ ebeep
+ epause 10
+ elif use portaudio && use pulseaudio; then
+ die "You must choose either portaudio or pulseaudio, but not both."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+
+ # portaudio.h is by default the same as portaudio18.h, but use the version
+ # 19 API if available
+ if use portaudio; then
+ if has_version "=media-libs/portaudio-19*" ; then
+ mv -f "${S}/src/portaudio19.h" "${S}/src/portaudio.h"
+ fi
+ fi
+}
+
+src_compile() {
+ cd src
+ emake AUDIO="$(get_audio)" CXXFLAGS="${CXXFLAGS}" all || die "Compilation failed"
+
+ einfo "Fixing byte order of phoneme data files"
+ cd "${S}/platforms/big_endian"
+ make
+ ./espeak-phoneme-data "${S}/espeak-data"
+ cp -f phondata phonindex phontab "${S}/espeak-data"
+}
+
+src_install() {
+ cd src
+ make DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)" AUDIO="$(get_audio)" install || die "Installation failed"
+
+ cd ..
+ insinto /usr/share/espeak-data
+ doins -r dictsource
+ dodoc ChangeLog ReadMe
+ dohtml -r docs/*
+}