summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain Perier <mrpouet@gentoo.org>2010-01-15 12:39:47 +0000
committerRomain Perier <mrpouet@gentoo.org>2010-01-15 12:39:47 +0000
commit893e79e7649bb9f6a5a9e077a5694ca84d4e9f85 (patch)
tree53620254031673d8ae1fbcf287e9d15a4bf34122 /app-accessibility
parentMigrate to new base eclass structure. (diff)
downloadgentoo-2-893e79e7649bb9f6a5a9e077a5694ca84d4e9f85.tar.gz
gentoo-2-893e79e7649bb9f6a5a9e077a5694ca84d4e9f85.tar.bz2
gentoo-2-893e79e7649bb9f6a5a9e077a5694ca84d4e9f85.zip
Fix some ugly warnings, originally per upstream bug #578798.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/gnome-mag/ChangeLog11
-rw-r--r--app-accessibility/gnome-mag/files/gnome-mag-0.15.9-magnifier-fix-warnings.patch71
-rw-r--r--app-accessibility/gnome-mag/gnome-mag-0.15.9-r1.ebuild64
3 files changed, 144 insertions, 2 deletions
diff --git a/app-accessibility/gnome-mag/ChangeLog b/app-accessibility/gnome-mag/ChangeLog
index 25a05a433397..9622228aa75a 100644
--- a/app-accessibility/gnome-mag/ChangeLog
+++ b/app-accessibility/gnome-mag/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-accessibility/gnome-mag
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/gnome-mag/ChangeLog,v 1.166 2009/12/03 17:24:30 ranger Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/gnome-mag/ChangeLog,v 1.167 2010/01/15 12:39:46 mrpouet Exp $
+
+*gnome-mag-0.15.9-r1 (15 Jan 2010)
+
+ 15 Jan 2010; Romain Perier <mrpouet@gentoo.org>
+ +gnome-mag-0.15.9-r1.ebuild,
+ +files/gnome-mag-0.15.9-magnifier-fix-warnings.patch:
+ Fix some ugly warnings, originally per upstream bug #578798.
03 Dec 2009; Brent Baude <ranger@gentoo.org> gnome-mag-0.15.9.ebuild:
Marking gnome-mag-0.15.9 ppc64 stable for bug 281427
diff --git a/app-accessibility/gnome-mag/files/gnome-mag-0.15.9-magnifier-fix-warnings.patch b/app-accessibility/gnome-mag/files/gnome-mag-0.15.9-magnifier-fix-warnings.patch
new file mode 100644
index 000000000000..6771ee910f25
--- /dev/null
+++ b/app-accessibility/gnome-mag/files/gnome-mag-0.15.9-magnifier-fix-warnings.patch
@@ -0,0 +1,71 @@
+From: Romain Perier <mrpouet@gentoo.org>
+Date: Fri, 15 Jan 2010 13:06:08 +0100
+Subject: Fix ugly warnings
+
+1)° g_object_get_data(GObject *, const gchar *) : needs a GObject * in first argument,
+ so because GdkPixbuf inherits from GObject, we've just to call G_OBJECT() macro.
+2)° Invalid function prototype, so invalid function pointer.
+ Note: this callback just returns a value, so it's inlinable.
+3)° Implicit declaration of 'gdk_pixbuf_set_option' due to missing GDK_PIXBUF_ENABLE_BACKEND
+ (see gdk-pixbuf/gdk-pixbuf-io.h for more details)
+4)° event was useless (unused)
+
+---
+ magnifier/magnifier.c | 9 +++++----
+ magnifier/x11/gmag-graphical-server.c | 5 ++---
+ 2 files changed, 7 insertions(+), 7 deletions(-)
+
+--- a/magnifier/magnifier.c
++++ b/magnifier/magnifier.c
+@@ -304,8 +304,8 @@ magnifier_set_cursor_from_pixbuf (Magnifier *magnifier,
+ magnifier->priv->cursor = pixmap;
+ magnifier->priv->cursor_mask = mask;
+
+- xhot_string = g_object_get_data (cursor_pixbuf, "x_hot");
+- yhot_string = g_object_get_data (cursor_pixbuf, "y_hot");
++ xhot_string = g_object_get_data (G_OBJECT(cursor_pixbuf), "x_hot");
++ yhot_string = g_object_get_data (G_OBJECT(cursor_pixbuf), "y_hot");
+
+ if (xhot_string)
+ magnifier->cursor_hotspot.x = atoi (xhot_string);
+@@ -1214,9 +1214,10 @@ magnifier_gobject_dispose (GObject *object)
+ BONOBO_CALL_PARENT (G_OBJECT_CLASS, dispose, (object));
+ }
+
+-static
++static inline
+ CORBA_boolean
+-impl_magnifier_support_colorblind_filters (Magnifier *magnifier)
++impl_magnifier_support_colorblind_filters (PortableServer_Servant _servant G_GNUC_UNUSED,
++ CORBA_Environment *ev G_GNUC_UNUSED)
+ {
+ #ifdef HAVE_COLORBLIND
+ return CORBA_TRUE;
+--- a/magnifier/x11/gmag-graphical-server.c
++++ b/magnifier/x11/gmag-graphical-server.c
+@@ -20,7 +20,7 @@
+ * Free Software Foundation, Inc., 59 Temple Place - Suite 330,
+ * Boston, MA 02111-1307, USA.
+ */
+-
++#define GDK_PIXBUF_ENABLE_BACKEND
+ #include "config.h"
+ #include "magnifier.h"
+ #include "magnifier-private.h"
+@@ -48,7 +48,6 @@
+ #include <stdlib.h>
+
+ #include <glib.h>
+-
+ #include <gdk/gdkx.h>
+ #include <gtk/gtk.h>
+
+@@ -439,7 +438,7 @@ gmag_gs_events_handler (GIOChannel *source, GIOCondition condition,
+ static gboolean
+ gmag_gs_use_damage ()
+ {
+- gint major, event, error;
++ gint major, error;
+ if (XQueryExtension (
+ dpy, "DAMAGE", &major, &damage_event_base, &error) &&
+ !g_getenv ("MAGNIFIER_IGNORE_DAMAGE")) {
diff --git a/app-accessibility/gnome-mag/gnome-mag-0.15.9-r1.ebuild b/app-accessibility/gnome-mag/gnome-mag-0.15.9-r1.ebuild
new file mode 100644
index 000000000000..07e1ffaa7bdf
--- /dev/null
+++ b/app-accessibility/gnome-mag/gnome-mag-0.15.9-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/gnome-mag/gnome-mag-0.15.9-r1.ebuild,v 1.1 2010/01/15 12:39:46 mrpouet Exp $
+
+inherit eutils gnome2 virtualx
+
+DESCRIPTION="Gnome magnification service definition"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.11.1
+ >=x11-libs/gtk+-2.6"
+
+# FIXME: need libcolorblind (debian package)
+# python deps are for applets
+# applet? (
+# >=dev-python/pygtk-2.6
+# dev-python/pygobject
+#
+# >=dev-python/libbonobo-python-2.10
+# >=dev-python/gconf-python-2.10
+# >=dev-python/libgnome-python-2.10
+# >=dev-python/gnome-applets-python-2.10 )
+
+RDEPEND="${RDEPEND}
+ >=gnome-base/libbonobo-1.107
+ >=gnome-extra/at-spi-1.5.2
+ >=gnome-base/orbit-2.3.100
+
+ x11-libs/libX11
+ x11-libs/libXtst
+ x11-libs/libXdamage
+ x11-libs/libXfixes
+ x11-libs/libXrender
+ x11-libs/libXcomposite"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/intltool-0.35
+
+ x11-proto/xextproto
+ x11-proto/xproto"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+#pkg_setup() {
+# G2CONF="${G2CONF} $(use_enable applet colorblind-applet)"
+#}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Fix some ugly warnings, originally per upstream bug #578798
+ epatch "${FILESDIR}/${P}-magnifier-fix-warnings.patch"
+}
+
+src_test() {
+ Xemake check || die "emake check failed"
+
+}