summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2009-10-08 17:47:26 +0000
committerWilliam Hubbs <williamh@gentoo.org>2009-10-08 17:47:26 +0000
commitc9241055c76d05b6fe29570ca5705d4e9fc076b6 (patch)
treef8bb628c82da56f31a9b699cda571cd469eb73dc /app-accessibility
parentadd prefix keywords - migrate from Gentoo Prefix (diff)
downloadgentoo-2-c9241055c76d05b6fe29570ca5705d4e9fc076b6.tar.gz
gentoo-2-c9241055c76d05b6fe29570ca5705d4e9fc076b6.tar.bz2
gentoo-2-c9241055c76d05b6fe29570ca5705d4e9fc076b6.zip
version bump
(Portage version: 2.2_rc44/cvs/Linux i686)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/brltty/ChangeLog8
-rw-r--r--app-accessibility/brltty/brltty-4.1.ebuild126
-rw-r--r--app-accessibility/brltty/metadata.xml11
3 files changed, 144 insertions, 1 deletions
diff --git a/app-accessibility/brltty/ChangeLog b/app-accessibility/brltty/ChangeLog
index e4345168d097..d23dea3a128b 100644
--- a/app-accessibility/brltty/ChangeLog
+++ b/app-accessibility/brltty/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-accessibility/brltty
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/ChangeLog,v 1.95 2009/09/15 11:51:21 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/ChangeLog,v 1.96 2009/10/08 17:47:26 williamh Exp $
+
+*brltty-4.1 (08 Oct 2009)
+
+ 08 Oct 2009; William Hubbs <williamh@gentoo.org> +brltty-4.1.ebuild,
+ metadata.xml:
+ version bump
15 Sep 2009; Jeroen Roovers <jer@gentoo.org> brltty-4.0.ebuild:
Stable for HPPA (bug #281126).
diff --git a/app-accessibility/brltty/brltty-4.1.ebuild b/app-accessibility/brltty/brltty-4.1.ebuild
new file mode 100644
index 000000000000..403295c6110d
--- /dev/null
+++ b/app-accessibility/brltty/brltty-4.1.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/brltty/brltty-4.1.ebuild,v 1.1 2009/10/08 17:47:26 williamh Exp $
+
+EAPI="2"
+FINDLIB_USE="ocaml"
+
+inherit findlib eutils multilib toolchain-funcs java-pkg-opt-2 flag-o-matic
+
+DESCRIPTION="Daemon that provides access to the Linux/Unix console for a blind person"
+HOMEPAGE="http://mielke.cc/brltty/"
+SRC_URI="http://mielke.cc/brltty/releases/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="+api +beeper bluetooth +contracted-braille doc +fm gpm iconv icu
+ java +learn-mode +midi nls ocaml +pcm +pm python usb +speech
+ static tcl X"
+
+COMMON_DEP="bluetooth? ( || ( net-wireless/bluez net-wireless/bluez-libs ) )
+ gpm? ( >=sys-libs/gpm-1.20 )
+ iconv? ( virtual/libiconv )
+ icu? ( dev-libs/icu )
+ nls? ( virtual/libintl )
+ python? ( >=dev-python/pyrex-0.9.4.1 )
+ tcl? ( >=dev-lang/tcl-8.4.15 )
+ usb? ( virtual/libusb:0 )
+ X? ( x11-libs/libXaw )"
+DEPEND="java? ( >=virtual/jdk-1.4 )
+ ${COMMON_DEP}"
+RDEPEND="java? ( >=virtual/jre-1.4 )
+ ${COMMON_DEP}"
+
+src_configure() {
+ # override prefix in order to install into /
+ # braille terminal needs to be available as soon in the boot process as
+ # possible
+ # Also override localstatedir so that the lib/brltty directory is installed
+ # correctly.
+ # Disable stripping since we do that ourselves.
+ econf \
+ --prefix=/ \
+ --includedir=/usr/include \
+ --localstatedir=/var \
+ --disable-stripping \
+ --with-install-root="${D}" \
+ $(use_enable api) \
+ $(use_enable beeper beeper-support) \
+ $(use_enable bluetooth bluetooth-support) \
+ $(use_enable contracted-braille) \
+ $(use_enable fm fm-support) \
+ $(use_enable gpm) \
+ $(use_enable iconv) \
+ $(use_enable icu) \
+ $(use_enable java java-bindings) \
+ $(use_enable learn-mode) \
+ $(use_enable midi midi-support) \
+ $(use_enable nls i18n) \
+ $(use_enable ocaml caml-bindings) \
+ $(use_enable pcm pcm-support) \
+ $(use_enable pm pm-configfile) \
+ $(use_enable python python-bindings) \
+ $(use_enable speech speech-support) \
+ $(use_enable static standalone-programs) \
+ $(use_enable usb usb-support) \
+ $(use_enable tcl tcl-bindings) \
+ $(use_enable X x) \
+ || die
+}
+
+src_compile() {
+ local JAVAC_CONF=""
+ if use java; then
+ append-flags "$(java-pkg_get-jni-cflags)"
+ JAVAC_CONF="${JAVAC} -encoding UTF-8 $(java-pkg_javac-args)"
+ fi
+
+ emake JAVAC="${JAVAC_CONF}" || die
+}
+
+src_install() {
+ if use ocaml; then
+ findlib_src_preinst
+ fi
+
+ emake install || die
+
+ if use java; then
+ # make install puts the _java.so there, and no it's not $(get_libdir)
+ rm -rf "${D}/usr/lib/java"
+ java-pkg_doso Bindings/Java/libbrlapi_java.so
+ java-pkg_dojar Bindings/Java/brlapi.jar
+ fi
+
+ insinto /etc
+ doins Documents/brltty.conf
+ insinto /etc/udev/rules.d
+ newins Hotplug/udev.rules 70-brltty.rules
+ newinitd "${FILESDIR}"/brltty.rc brltty
+
+ libdir="$(get_libdir)"
+ mkdir -p "${D}"/usr/${libdir}/
+ mv "${D}"/${libdir}/*.a "${D}"/usr/${libdir}/
+ gen_usr_ldscript libbrlapi.so
+
+ cd Documents
+ mv Manual-BRLTTY/English/BRLTTY.txt BRLTTY-en.txt
+ mv Manual-BRLTTY/French/BRLTTY.txt BRLTTY-fr.txt
+ mv Manual-BrlAPI/English/BrlAPI.txt BrlAPI-en.txt
+ dodoc CONTRIBUTORS ChangeLog HISTORY README* TODO BRLTTY-*.txt
+ dohtml -r Manual-BRLTTY
+ if use doc; then
+ dohtml -r Manual-BRLAPI
+ dodoc BrlAPI-*.txt
+ fi
+}
+
+pkg_postinst() {
+ elog
+ elog please be sure "${ROOT}"etc/brltty.conf is correct for your system.
+ elog
+ elog To make brltty start on boot, type this command as root:
+ elog
+ elog rc-update add brltty boot
+}
diff --git a/app-accessibility/brltty/metadata.xml b/app-accessibility/brltty/metadata.xml
index f049738fdb2a..5a81ad3003c5 100644
--- a/app-accessibility/brltty/metadata.xml
+++ b/app-accessibility/brltty/metadata.xml
@@ -6,6 +6,17 @@
<email>williamh@gentoo.org</email>
<name>William Hubbs</name>
</maintainer>
+ <use>
+ <flag name="api">build brltty's application program interface</flag>
+ <flag name="beeper">support the console tone generator</flag>
+ <flag name="contracted-braille">support in-line contracted braille</flag>
+ <flag name="fm">support for the sound card synthesizer</flag>
+ <flag name="learn-mode">support for interactive command learn mode</flag>
+ <flag name="midi">support the musical instrument digital interface</flag>
+ <flag name="pcm">support for sound card digital audio</flag>
+ <flag name="pm">user customization of Papenmeier driver</flag>
+ <flag name="speech">speech support</flag>
+</use>
<longdescription lang="en">
BRLTTY is a background process (daemon) which provides access to the Linux/Unix
console (when in text mode) for a blind person using a refreshable braille