summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2004-09-11 14:43:28 +0000
committerJon Hood <squinky86@gentoo.org>2004-09-11 14:43:28 +0000
commit5f6f7e82341f0606f4a4ebbc1c3b472b5fd778ed (patch)
tree8f053c5a6f22b1da2b56a9fb54b8ec01ed5ca70f /app-admin/aide
parentAdded to ~ppc (Manifest recommit) (diff)
downloadgentoo-2-5f6f7e82341f0606f4a4ebbc1c3b472b5fd778ed.tar.gz
gentoo-2-5f6f7e82341f0606f4a4ebbc1c3b472b5fd778ed.tar.bz2
gentoo-2-5f6f7e82341f0606f4a4ebbc1c3b472b5fd778ed.zip
fix mhash segfault irt #62194
Diffstat (limited to 'app-admin/aide')
-rw-r--r--app-admin/aide/ChangeLog6
-rw-r--r--app-admin/aide/aide-0.8.ebuild45
-rw-r--r--app-admin/aide/files/aide-0.10-gentoo.diff50
-rw-r--r--app-admin/aide/files/digest-aide-0.81
4 files changed, 34 insertions, 68 deletions
diff --git a/app-admin/aide/ChangeLog b/app-admin/aide/ChangeLog
index a18e62704e64..4b992a64c26e 100644
--- a/app-admin/aide/ChangeLog
+++ b/app-admin/aide/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-admin/aide
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/aide/ChangeLog,v 1.23 2004/07/03 14:45:56 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/aide/ChangeLog,v 1.24 2004/09/11 14:43:28 squinky86 Exp $
+
+ 11 Sep 2004; Jon Hood <squinky86@gentoo.org> files/aide-0.10-gentoo.diff,
+ -aide-0.8.ebuild:
+ Fix mhash segfault irt #62194, thanks Gianluca <g.insolvibile@cpr.it>.
03 Jul 2004; Bryan Østergaard <kloeri@gentoo.org> aide-0.10.ebuild:
Stable on alpha.
diff --git a/app-admin/aide/aide-0.8.ebuild b/app-admin/aide/aide-0.8.ebuild
deleted file mode 100644
index e68c70a896a4..000000000000
--- a/app-admin/aide/aide-0.8.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/aide/aide-0.8.ebuild,v 1.22 2004/06/24 21:22:23 agriffis Exp $
-
-DESCRIPTION="AIDE (Advanced Intrusion Detection Environment) is a free replacement for Tripwire"
-HOMEPAGE="http://www.cs.tut.fi/~rammer/aide.html"
-SRC_URI="http://www.cs.tut.fi/~rammer/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 ppc -sparc"
-IUSE="nls postgres"
-
-DEPEND="app-arch/gzip
- sys-devel/bison
- sys-devel/flex
- dev-libs/libgcrypt
- app-crypt/mhash
- postgres? ( dev-db/postgresql )"
-RDEPEND=""
-
-src_compile() {
- local myconf
- use postgres && myconf="${myconf} --with-psql"
- use nls && myconf="${myconf} --with-locale"
-
- econf \
- --with-zlib \
- --sysconfdir=/etc/aide \
- --with-mhash \
- --with-extra-lib=/usr/lib \
- ${myconf} || die
-
- emake || die
-}
-
-src_install() {
- make prefix=${D}/usr mandir=${D}/usr/share/man install || die
-
- dodir /etc/aide
- cp doc/aide.conf ${D}/etc/aide
-
- dodoc AUTHORS INSTALL NEWS README
- dohtml doc/manual.html
-}
diff --git a/app-admin/aide/files/aide-0.10-gentoo.diff b/app-admin/aide/files/aide-0.10-gentoo.diff
index d423819abad9..4664df190c86 100644
--- a/app-admin/aide/files/aide-0.10-gentoo.diff
+++ b/app-admin/aide/files/aide-0.10-gentoo.diff
@@ -1,6 +1,6 @@
-diff -ru ./src/commandconf.c /var/tmp/portage/aide-0.9/work/aide-0.9/src/commandconf.c
---- src/commandconf.c 2002-05-29 08:04:27.000000000 +0000
-+++ src/commandconf.c 2002-10-29 13:44:29.000000000 +0000
+diff -Naur aide-0.10/src/commandconf.c aide-0.10.fixed/src/commandconf.c
+--- aide-0.10/src/commandconf.c 2003-11-04 09:39:48.000000000 -0600
++++ aide-0.10.fixed/src/commandconf.c 2004-09-11 09:37:44.143790160 -0500
@@ -29,7 +29,7 @@
#include "aide.h"
#include "conf_lex.h"
@@ -10,9 +10,18 @@ diff -ru ./src/commandconf.c /var/tmp/portage/aide-0.9/work/aide-0.9/src/command
#include "db_config.h"
#include "gen_list.h"
#include "symboltable.h"
-diff -ru ./src/compare_db.c /var/tmp/portage/aide-0.9/work/aide-0.9/src/compare_db.c
---- src/compare_db.c 2002-05-30 09:42:46.000000000 +0000
-+++ src/compare_db.c 2002-10-29 13:44:29.000000000 +0000
+@@ -224,7 +224,7 @@
+ }
+ /* FIXME This does not handle the case that @@end_config is on
+ buffer boundary. */
+- if((tmp=strnstr(buf,"@@end_config",retval))!=NULL){
++ if((conf->confmd != MHASH_FAILED) && ((tmp=strnstr(buf,"@@end_config",retval))!=NULL)){
+ /* We have end of config don't feed the last line to mhash */
+ mhash(conf->confmd,(void*)buf,tmp-buf);
+ } else {
+diff -Naur aide-0.10/src/compare_db.c aide-0.10.fixed/src/compare_db.c
+--- aide-0.10/src/compare_db.c 2003-11-04 09:39:48.000000000 -0600
++++ aide-0.10.fixed/src/compare_db.c 2004-09-11 09:31:44.222506512 -0500
@@ -30,7 +30,7 @@
#include "gnu_regex.h"
#include "gen_list.h"
@@ -22,9 +31,9 @@ diff -ru ./src/compare_db.c /var/tmp/portage/aide-0.9/work/aide-0.9/src/compare_
#include "util.h"
#include "commandconf.h"
#include "gen_list.h"
-diff -ru ./src/conf_yacc.y /var/tmp/portage/aide-0.9/work/aide-0.9/src/conf_yacc.y
---- src/conf_yacc.y 2002-05-29 08:04:27.000000000 +0000
-+++ src/conf_yacc.y 2002-10-29 13:46:11.000000000 +0000
+diff -Naur aide-0.10/src/conf_yacc.y aide-0.10.fixed/src/conf_yacc.y
+--- aide-0.10/src/conf_yacc.y 2003-08-18 08:03:22.000000000 -0500
++++ aide-0.10.fixed/src/conf_yacc.y 2004-09-11 09:31:44.223506360 -0500
@@ -25,7 +25,7 @@
#include <string.h>
#include "list.h"
@@ -34,9 +43,9 @@ diff -ru ./src/conf_yacc.y /var/tmp/portage/aide-0.9/work/aide-0.9/src/conf_yacc
#include "db_config.h"
#include "symboltable.h"
#include "commandconf.h"
-diff -ru ./src/db.c /var/tmp/portage/aide-0.9/work/aide-0.9/src/db.c
---- src/db.c 2002-05-29 08:04:27.000000000 +0000
-+++ src/db.c 2002-10-29 13:45:01.000000000 +0000
+diff -Naur aide-0.10/src/db.c aide-0.10.fixed/src/db.c
+--- aide-0.10/src/db.c 2003-11-04 09:13:06.000000000 -0600
++++ aide-0.10.fixed/src/db.c 2004-09-11 09:31:44.224506208 -0500
@@ -22,7 +22,7 @@
#include <stdio.h>
#include <stdlib.h>
@@ -45,22 +54,22 @@ diff -ru ./src/db.c /var/tmp/portage/aide-0.9/work/aide-0.9/src/db.c
+#include "../include/db.h"
#include "db_file.h"
#include "db_disk.h"
-
-diff -ru ./src/db_sql.c /var/tmp/portage/aide-0.9/work/aide-0.9/src/db_sql.c
---- src/db_sql.c 2002-05-29 08:04:27.000000000 +0000
-+++ src/db_sql.c 2002-10-29 13:45:52.000000000 +0000
+
+diff -Naur aide-0.10/src/db_sql.c aide-0.10.fixed/src/db_sql.c
+--- aide-0.10/src/db_sql.c 2003-01-16 04:37:34.000000000 -0600
++++ aide-0.10.fixed/src/db_sql.c 2004-09-11 09:31:44.225506056 -0500
@@ -31,7 +31,7 @@
#include <string.h>
#include <gcrypt.h>
#include "base64.h"
-#include "db.h"
+#include "../include/db.h"
-
+
#include "db_sql.h"
#include "db_config.h"
-diff -ru ./src/gen_list.c /var/tmp/portage/aide-0.9/work/aide-0.9/src/gen_list.c
---- src/gen_list.c 2002-05-30 09:53:52.000000000 +0000
-+++ src/gen_list.c 2002-10-29 13:44:29.000000000 +0000
+diff -Naur aide-0.10/src/gen_list.c aide-0.10.fixed/src/gen_list.c
+--- aide-0.10/src/gen_list.c 2003-11-04 09:39:48.000000000 -0600
++++ aide-0.10.fixed/src/gen_list.c 2004-09-11 09:31:44.226505904 -0500
@@ -38,7 +38,7 @@
#include "list.h"
#include "gen_list.h"
@@ -70,4 +79,3 @@ diff -ru ./src/gen_list.c /var/tmp/portage/aide-0.9/work/aide-0.9/src/gen_list.c
#include "db_config.h"
#include "compare_db.h"
#include "commandconf.h"
-
diff --git a/app-admin/aide/files/digest-aide-0.8 b/app-admin/aide/files/digest-aide-0.8
deleted file mode 100644
index de2e7312ad77..000000000000
--- a/app-admin/aide/files/digest-aide-0.8
+++ /dev/null
@@ -1 +0,0 @@
-MD5 84b608ccf5051d41a8ccfee87ced5428 aide-0.8.tar.gz 197272