summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-09-12 08:30:57 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-09-12 08:30:57 +0000
commitd97d2dba47e112eeec34749a80ff113746218e44 (patch)
tree3be1e9fe81a458518d8ebcac2ec9d25d92c3923d /app-admin/augeas
parentBump (diff)
downloadgentoo-2-d97d2dba47e112eeec34749a80ff113746218e44.tar.gz
gentoo-2-d97d2dba47e112eeec34749a80ff113746218e44.tar.bz2
gentoo-2-d97d2dba47e112eeec34749a80ff113746218e44.zip
bump to 1.1.0 for bug 477700
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'app-admin/augeas')
-rw-r--r--app-admin/augeas/ChangeLog7
-rw-r--r--app-admin/augeas/augeas-1.1.0.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/app-admin/augeas/ChangeLog b/app-admin/augeas/ChangeLog
index b8d3b77500d1..481ce7054289 100644
--- a/app-admin/augeas/ChangeLog
+++ b/app-admin/augeas/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/augeas
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/augeas/ChangeLog,v 1.42 2013/02/03 13:19:20 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/augeas/ChangeLog,v 1.43 2013/09/12 08:30:57 prometheanfire Exp $
+
+*augeas-1.1.0 (12 Sep 2013)
+
+ 12 Sep 2013; Matthew Thode <prometheanfire@gentoo.org> +augeas-1.1.0.ebuild:
+ bump to 1.1.0 for bug 477700
03 Feb 2013; Matthew Thode <prometheanfire@gentoo.org>
augeas-0.10.0-r1.ebuild, metadata.xml:
diff --git a/app-admin/augeas/augeas-1.1.0.ebuild b/app-admin/augeas/augeas-1.1.0.ebuild
new file mode 100644
index 000000000000..ae9afab4248c
--- /dev/null
+++ b/app-admin/augeas/augeas-1.1.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/augeas/augeas-1.1.0.ebuild,v 1.1 2013/09/12 08:30:57 prometheanfire Exp $
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="A library for changing configuration files"
+HOMEPAGE="http://augeas.net/"
+SRC_URI="http://download.augeas.net/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="static-libs test"
+
+RDEPEND="
+ dev-libs/libxml2
+ sys-libs/readline"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=app-doc/NaturalDocs-1.40
+ test? ( dev-lang/ruby )"
+
+#PATCHES=(
+# "${FILESDIR}"/${P}-gets.patch
+# "${FILESDIR}"/${P}-test.patch
+# "${FILESDIR}"/${P}-test2.patch
+# "${FILESDIR}"/${P}-libxml2-pkgconfig.patch
+# )
+
+src_prepare() {
+ if [ -f /usr/share/NaturalDocs/Config/Languages.txt ] ; then
+ addwrite /usr/share/NaturalDocs/Config/Languages.txt
+ fi
+ if [ -f /usr/share/NaturalDocs/Config/Topics.txt ] ; then
+ addwrite /usr/share/NaturalDocs/Config/Topics.txt
+ fi
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ # Needs to implemented
+ local myeconfargs=( --without-selinux )
+ autotools-utils_src_configure
+}
+
+AUTOTOOLS_IN_SOURCE_BUILD=1