summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2010-01-22 16:06:50 +0000
committerJeremy Olexa <darkside@gentoo.org>2010-01-22 16:06:50 +0000
commit3cd9ae629308acfda3a4f0ae1edd7ea0413e89e1 (patch)
tree3e81ec10fa585a9129dcc343c7da9a65f78d8681 /app-admin/bcfg2
parentFix quotes (diff)
downloadgentoo-2-3cd9ae629308acfda3a4f0ae1edd7ea0413e89e1.tar.gz
gentoo-2-3cd9ae629308acfda3a4f0ae1edd7ea0413e89e1.tar.bz2
gentoo-2-3cd9ae629308acfda3a4f0ae1edd7ea0413e89e1.zip
Version bump, bug 301851
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/bcfg2')
-rw-r--r--app-admin/bcfg2/ChangeLog7
-rw-r--r--app-admin/bcfg2/bcfg2-1.0.1.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/app-admin/bcfg2/ChangeLog b/app-admin/bcfg2/ChangeLog
index d83469f8b550..c007e9330966 100644
--- a/app-admin/bcfg2/ChangeLog
+++ b/app-admin/bcfg2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/bcfg2
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/bcfg2/ChangeLog,v 1.8 2010/01/17 22:10:45 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/bcfg2/ChangeLog,v 1.9 2010/01/22 16:06:50 darkside Exp $
+
+*bcfg2-1.0.1 (22 Jan 2010)
+
+ 22 Jan 2010; Jeremy Olexa <darkside@gentoo.org> +bcfg2-1.0.1.ebuild:
+ Version bump, bug 301851
*bcfg2-1.0.0 (17 Jan 2010)
diff --git a/app-admin/bcfg2/bcfg2-1.0.1.ebuild b/app-admin/bcfg2/bcfg2-1.0.1.ebuild
new file mode 100644
index 000000000000..58815e54073a
--- /dev/null
+++ b/app-admin/bcfg2/bcfg2-1.0.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/bcfg2/bcfg2-1.0.1.ebuild,v 1.1 2010/01/22 16:06:50 darkside Exp $
+
+inherit distutils
+
+DESCRIPTION="Bcfg2 is a configuration management tool."
+HOMEPAGE="http://trac.mcs.anl.gov/projects/bcfg2"
+
+# handle the "pre" case
+MY_P="${P/_/}"
+SRC_URI="ftp://ftp.mcs.anl.gov/pub/bcfg/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+IUSE="server"
+
+DEPEND="app-portage/gentoolkit
+ >=dev-lang/python-2.6
+ server? (
+ dev-python/lxml
+ app-admin/gam-server )"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ distutils_src_install --record=PY_SERVER_LIBS --install-scripts /usr/sbin
+
+ # Remove files only necessary for a server installation
+ if ! use server; then
+ rm -rf "${D}"/usr/sbin/bcfg2-*
+ rm -rf "${D}"/usr/share/bcfg2
+ rm -rf "${D}"/usr/share/man/man8
+ fi
+
+ # Install a server init.d script
+ if use server; then
+ newinitd "${FILESDIR}"/bcfg2-server.rc bcfg2-server
+ fi
+
+ insinto /etc
+ doins "${S}"/examples/bcfg2.conf
+}
+
+pkg_postinst () {
+ use server && einfo "If this is a new installation, you probably need to run: "
+ use server && einfo " bcfg2-admin init"
+}
+
+pkg_postrm () {
+ python_mod_cleanup
+}