summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2011-10-27 14:08:19 +0000
committerMichael Weber <xmw@gentoo.org>2011-10-27 14:08:19 +0000
commit9c61d3398a1852e1d57ab5da8f28d85920c294c7 (patch)
treeb614dfcfd8ca9a0c2a61ad80a4cf391f62333a85 /app-admin/conkyforecast
parentChanges to pydoc conf.d and init.d files wrt bug #361867. Patch by Arfrever (diff)
downloadgentoo-2-9c61d3398a1852e1d57ab5da8f28d85920c294c7.tar.gz
gentoo-2-9c61d3398a1852e1d57ab5da8f28d85920c294c7.tar.bz2
gentoo-2-9c61d3398a1852e1d57ab5da8f28d85920c294c7.zip
Version bump
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/conkyforecast')
-rw-r--r--app-admin/conkyforecast/ChangeLog7
-rw-r--r--app-admin/conkyforecast/conkyforecast-2.20.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/app-admin/conkyforecast/ChangeLog b/app-admin/conkyforecast/ChangeLog
index d86a34440fa9..bd63159a16e1 100644
--- a/app-admin/conkyforecast/ChangeLog
+++ b/app-admin/conkyforecast/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/conkyforecast
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/conkyforecast/ChangeLog,v 1.2 2011/01/01 21:00:42 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/conkyforecast/ChangeLog,v 1.3 2011/10/27 14:08:19 xmw Exp $
+
+*conkyforecast-2.20 (27 Oct 2011)
+
+ 27 Oct 2011; Michael Weber <xmw@gentoo.org> +conkyforecast-2.20.ebuild:
+ Version bump (thanks to Jesse for the hint, bug 388177)
01 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
conkyforecast-2.12.ebuild:
diff --git a/app-admin/conkyforecast/conkyforecast-2.20.ebuild b/app-admin/conkyforecast/conkyforecast-2.20.ebuild
new file mode 100644
index 000000000000..b30fa16cfe15
--- /dev/null
+++ b/app-admin/conkyforecast/conkyforecast-2.20.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/conkyforecast/conkyforecast-2.20.ebuild,v 1.1 2011/10/27 14:08:19 xmw Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+
+inherit distutils
+
+DESCRIPTION="Conky weather forecast script with support for language files"
+HOMEPAGE="https://launchpad.net/~conky-companions"
+SRC_URI="https://launchpad.net/~conky-companions/+archive/ppa/+files/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-admin/conky"
+
+S=${WORKDIR}/src
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ sed -i -e "s:/usr/bin/python:$(PYTHON -a):" conkyForecast || die
+ distutils_src_prepare
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ elog "You have to define a partner id and registration code for "
+ elog "the weather.com xoap. You need to copy the template from"
+ elog "/usr/share/conkyforecast/conkyForecast.config into you account"
+ elog "as ~/.conkyForecast.config and edit the respective fields."
+ elog
+ elog "More details can be found in the README file."
+}