summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-09-25 05:53:26 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-09-25 05:53:26 +0000
commit9e0eb630c837d1420f5132f6bfa285ca376c22ae (patch)
tree6a2306ee5c12eb8830317a77c1d9982b39eec618 /app-admin/diradm
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-9e0eb630c837d1420f5132f6bfa285ca376c22ae.tar.gz
gentoo-2-9e0eb630c837d1420f5132f6bfa285ca376c22ae.tar.bz2
gentoo-2-9e0eb630c837d1420f5132f6bfa285ca376c22ae.zip
More fun for older LDAP setups, where organizationalUnit was used instead of automountMap, again thanks to Horatiu Halmaghi <hha13@sfu.ca>.
(Portage version: 2.2_rc8/cvs/Linux 2.6.27-rc1-10246-gca5de40 x86_64)
Diffstat (limited to 'app-admin/diradm')
-rw-r--r--app-admin/diradm/ChangeLog8
-rw-r--r--app-admin/diradm/diradm-2.9.6.ebuild69
2 files changed, 76 insertions, 1 deletions
diff --git a/app-admin/diradm/ChangeLog b/app-admin/diradm/ChangeLog
index 6d015cf47218..a05c550679da 100644
--- a/app-admin/diradm/ChangeLog
+++ b/app-admin/diradm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/diradm
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/diradm/ChangeLog,v 1.34 2008/09/24 00:55:57 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/diradm/ChangeLog,v 1.35 2008/09/25 05:53:26 robbat2 Exp $
+
+*diradm-2.9.6 (25 Sep 2008)
+
+ 25 Sep 2008; Robin H. Johnson <robbat2@gentoo.org> +diradm-2.9.6.ebuild:
+ More fun for older LDAP setups, where organizationalUnit was used instead
+ of automountMap, again thanks to Horatiu Halmaghi <hha13@sfu.ca>.
*diradm-2.9.5 (24 Sep 2008)
diff --git a/app-admin/diradm/diradm-2.9.6.ebuild b/app-admin/diradm/diradm-2.9.6.ebuild
new file mode 100644
index 000000000000..b0807e7fef75
--- /dev/null
+++ b/app-admin/diradm/diradm-2.9.6.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/diradm/diradm-2.9.6.ebuild,v 1.1 2008/09/25 05:53:26 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="diradm is a nearly complete nss/shadow suite for managing POSIX users/groups/data in LDAP."
+#HOMEPAGE="http://research.iat.sfu.ca/custom-software/diradm/"
+#SRC_URI="${HOMEPAGE}/${P}.tar.bz2"
+HOMEPAGE="http://orbis-terrarum.net/~robbat2/"
+SRC_URI="http://orbis-terrarum.net/~robbat2/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="samba irixpasswd automount test"
+DEPEND=">=net-nds/openldap-2.3
+ sys-apps/gawk
+ sys-apps/coreutils
+ sys-apps/grep
+ dev-lang/perl
+ app-shells/bash
+ sys-apps/sed
+ virtual/perl-MIME-Base64
+ samba? (
+ dev-perl/Crypt-SmbHash
+ >=net-fs/samba-3.0.6
+ )
+ test? ( dev-perl/Crypt-SmbHash >=net-fs/samba-3.0.6 dev-util/dejagnu )"
+
+pkg_setup() {
+ if use test; then
+ if built_with_use net-nds/openldap minimal ; then
+ die "You MUST have a non-minimal build of OpenLDAP to use the testcases!"
+ fi
+ elog "Warning, for test usage, diradm is built with all optional features!"
+ fi
+}
+
+src_compile() {
+ local myconf
+ if use test; then
+ myconf="--enable-samba --enable-automount --enable-irixpasswd"
+ else
+ myconf="`use_enable samba` `use_enable automount` `use_enable irixpasswd`"
+ fi
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc CHANGES* README AUTHORS ChangeLog NEWS README.prefork THANKS TODO KNOWN-BUGS
+ if use irixpasswd; then
+ insinto /etc/openldap/schema
+ doins irixpassword.schema
+ fi
+}
+
+pkg_postinst() {
+ elog "The new diradm pulls many settings from your LDAP configuration."
+ elog "But don't forget to customize /etc/diradm.conf for other settings."
+ elog "Please see the README to instructions if you problems."
+}
+
+src_test() {
+ use test || die "You must build diradm with USE=test to run the testcases!"
+ emake -j1 check
+}