summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Drake <dsd@gentoo.org>2007-08-07 15:36:23 +0000
committerDaniel Drake <dsd@gentoo.org>2007-08-07 15:36:23 +0000
commit0ef64f40ff021b001910c7e33c6bb3838c91c571 (patch)
treebe48693dfab0813adcc0f91a8bc1261c3a49915b /app-admin/gamin
parentStable on sparc wrt #176297 (diff)
downloadgentoo-2-0ef64f40ff021b001910c7e33c6bb3838c91c571.tar.gz
gentoo-2-0ef64f40ff021b001910c7e33c6bb3838c91c571.tar.bz2
gentoo-2-0ef64f40ff021b001910c7e33c6bb3838c91c571.zip
Version bump, and fix a bug where CFLAGS were being ignored (Arfrever Frehtes Taifersar Arahesis, #178266). x86-fbsd keywords dropped as fbsd patch no longer applies.
(Portage version: 2.1.3.3)
Diffstat (limited to 'app-admin/gamin')
-rw-r--r--app-admin/gamin/ChangeLog10
-rw-r--r--app-admin/gamin/files/digest-gamin-0.1.93
-rw-r--r--app-admin/gamin/files/gamin-0.1.9-user-cflags.patch107
-rw-r--r--app-admin/gamin/gamin-0.1.9.ebuild49
4 files changed, 168 insertions, 1 deletions
diff --git a/app-admin/gamin/ChangeLog b/app-admin/gamin/ChangeLog
index b4bcd50b4bc1..0e250fb62dbb 100644
--- a/app-admin/gamin/ChangeLog
+++ b/app-admin/gamin/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-admin/gamin
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/gamin/ChangeLog,v 1.66 2007/07/12 18:28:39 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/gamin/ChangeLog,v 1.67 2007/08/07 15:36:23 dsd Exp $
+
+*gamin-0.1.9 (07 Aug 2007)
+
+ 07 Aug 2007; Daniel Drake <dsd@gentoo.org>
+ +files/gamin-0.1.9-user-cflags.patch, +gamin-0.1.9.ebuild:
+ Version bump, and fix a bug where CFLAGS were being ignored (Arfrever
+ Frehtes Taifersar Arahesis, #178266). x86-fbsd keywords dropped as fbsd
+ patch no longer applies.
12 Jul 2007; Samuli Suominen <drac@gentoo.org> metadata.xml:
Change metadata from azarah to gnome, kde, and xfce.
diff --git a/app-admin/gamin/files/digest-gamin-0.1.9 b/app-admin/gamin/files/digest-gamin-0.1.9
new file mode 100644
index 000000000000..c4e502b2eff1
--- /dev/null
+++ b/app-admin/gamin/files/digest-gamin-0.1.9
@@ -0,0 +1,3 @@
+MD5 2d3a6a70df090ed923238e381e6c2982 gamin-0.1.9.tar.gz 645429
+RMD160 e376f551f7417dd04692e7463b46b9a193d48366 gamin-0.1.9.tar.gz 645429
+SHA256 19e2c620e84da678b629d4acb07d93f47a2e5075982892646f77520bb277f239 gamin-0.1.9.tar.gz 645429
diff --git a/app-admin/gamin/files/gamin-0.1.9-user-cflags.patch b/app-admin/gamin/files/gamin-0.1.9-user-cflags.patch
new file mode 100644
index 000000000000..f4020bfd756b
--- /dev/null
+++ b/app-admin/gamin/files/gamin-0.1.9-user-cflags.patch
@@ -0,0 +1,107 @@
+
+From: Daniel Drake <dsd@gentoo.org>
+
+gamin ignores user-supplied CFLAGS.
+http://bugzilla.gnome.org/show_bug.cgi?id=450262
+https://bugs.gentoo.org/show_bug.cgi?id=178266
+
+Index: configure.in
+===================================================================
+--- configure.in (revision 325)
++++ configure.in (working copy)
+@@ -1,13 +1,12 @@
+ dnl Process this file with autoconf to produce a configure script.
+-
+-# get any external flags setting before we start playing with the CFLAGS variable
+-ENV_CFLAGS=$CFLAGS
+-
+ AC_PREREQ(2.52)
+ AC_INIT(libgamin)
+ AM_CONFIG_HEADER(config.h)
+ AC_CANONICAL_SYSTEM
+
++# get any external flags setting before we start playing with the CFLAGS variable
++ENV_CFLAGS="$CFLAGS"
++
+ GAMIN_MAJOR_VERSION=0
+ GAMIN_MINOR_VERSION=1
+ GAMIN_MICRO_VERSION=9
+@@ -37,6 +36,12 @@
+ AC_PROG_INSTALL
+ AC_PROG_MAKE_SET
+
++dnl If the user set no CFLAGS, then don't assume the autotools defaults of
++dnl "-g -O2". We set default CFLAGS later based on the --disable-debug flag.
++if test -z "$ENV_CFLAGS"; then
++ CFLAGS=""
++fi
++
+ dnl for the spec file
+ RELDATE=`date +'%a %b %e %Y'`
+ AC_SUBST(RELDATE)
+@@ -506,44 +511,45 @@
+ AC_MSG_CHECKING(for more compiler warnings)
+ if test "$GCC" = "yes" -a "$set_more_warnings" != "no"; then
+ AC_MSG_RESULT(yes)
+- CFLAGS="\
++ warning_cflags="\
+ -Wall\
+ -Wchar-subscripts -Wmissing-declarations -Wmissing-prototypes\
+ -Wnested-externs\
+ -Wsign-compare"
+
++ SAVE_CFLAGS="$CFLAGS"
+ for option in -Wno-sign-compare; do
+- SAVE_CFLAGS="$CFLAGS"
+- CFLAGS="$CFLAGS $option"
++ CFLAGS="$option"
+ AC_MSG_CHECKING([whether gcc understands $option])
+ AC_TRY_COMPILE([], [],
+ has_option=yes,
+ has_option=no,)
+- if test $has_option = no; then
+- CFLAGS="$SAVE_CFLAGS"
++ if test "$has_option" != "no"; then
++ warning_cflags="$warning_cflags $option"
+ fi
+ AC_MSG_RESULT($has_option)
+ unset has_option
+- unset SAVE_CFLAGS
+ done
++ CFLAGS="$SAVE_CFLAGS"
+ unset option
+ else
+ AC_MSG_RESULT(no)
+- unset CFLAGS
+ fi
+
+ if test "$GCC" = "yes"; then
+ if test "$debug" = "yes"; then
+- CFLAGS="$CFLAGS -g"
++ debug_cflags="-g"
+ else
+- #don't optimise with -g
++ # autotools defaults to "-O2 -g" for cflags, but we don't
++ # want -g in non-debug builds
+ if test -z "$ENV_CFLAGS"; then
+- ENV_CFLAGS="-O2"
++ CFLAGS="-O2"
+ fi
+ fi
+ fi
+
+-CFLAGS="$CFLAGS $ENV_CFLAGS"
++AM_CFLAGS="$warning_cflags $debug_cflags"
++AC_SUBST(AM_CFLAGS)
+
+ dnl ==========================================================================
+
+@@ -569,7 +575,7 @@
+ prefix: ${prefix}
+ source code location: ${srcdir}
+ compiler: ${CC}
+- compiler flags: ${CFLAGS}
++ compiler flags: ${AM_CFLAGS} ${CFLAGS}
+
+ backends: ${backends}
+ build documentation: ${build_docs}
diff --git a/app-admin/gamin/gamin-0.1.9.ebuild b/app-admin/gamin/gamin-0.1.9.ebuild
new file mode 100644
index 000000000000..b66e4a7931f6
--- /dev/null
+++ b/app-admin/gamin/gamin-0.1.9.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/gamin/gamin-0.1.9.ebuild,v 1.1 2007/08/07 15:36:23 dsd Exp $
+
+inherit autotools eutils libtool
+
+DESCRIPTION="Library providing the FAM File Alteration Monitor API"
+HOMEPAGE="http://www.gnome.org/~veillard/gamin/"
+SRC_URI="http://www.gnome.org/~veillard/gamin/sources/${P}.tar.gz"
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="debug kernel_linux"
+
+RDEPEND=">=dev-libs/glib-2
+ !app-admin/fam"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+PROVIDE="virtual/fam"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch "${FILESDIR}/${P}-user-cflags.patch"
+
+ # autoconf is required as the user-cflags patch modifies configure.in
+ # however, elibtoolize is also required, so when the above patch is
+ # removed, replace the following call with a call to elibtoolize
+ eautoreconf
+}
+
+src_compile() {
+ econf --disable-debug \
+ $(use_enable kernel_linux inotify) \
+ $(use_enable debug debug-api) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog README TODO NEWS doc/*txt
+ dohtml doc/*
+}