summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Gurr <tgurr@gentoo.org>2008-03-17 22:48:10 +0000
committerTimo Gurr <tgurr@gentoo.org>2008-03-17 22:48:10 +0000
commite8314fe0f659af4512dd084c7242a29ed9d360b9 (patch)
tree5ef6a762b382035de9292b73b2a568c438d8083c /app-admin/keepassx
parentAdd ~amd64 keyword, bug #207565 (diff)
downloadgentoo-2-e8314fe0f659af4512dd084c7242a29ed9d360b9.tar.gz
gentoo-2-e8314fe0f659af4512dd084c7242a29ed9d360b9.tar.bz2
gentoo-2-e8314fe0f659af4512dd084c7242a29ed9d360b9.zip
Version bump, fixing bug #213667.
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-admin/keepassx')
-rw-r--r--app-admin/keepassx/ChangeLog10
-rw-r--r--app-admin/keepassx/keepassx-0.3.1-r20.ebuild (renamed from app-admin/keepassx/keepassx-0.3.0a-r20.ebuild)24
-rw-r--r--app-admin/keepassx/keepassx-0.3.1.ebuild (renamed from app-admin/keepassx/keepassx-0.3.0a.ebuild)23
3 files changed, 35 insertions, 22 deletions
diff --git a/app-admin/keepassx/ChangeLog b/app-admin/keepassx/ChangeLog
index e31988ff6ba0..9fcad2e81a4f 100644
--- a/app-admin/keepassx/ChangeLog
+++ b/app-admin/keepassx/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-admin/keepassx
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/keepassx/ChangeLog,v 1.24 2008/03/16 12:42:06 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/keepassx/ChangeLog,v 1.25 2008/03/17 22:48:10 tgurr Exp $
+
+*keepassx-0.3.1-r20 (17 Mar 2008)
+*keepassx-0.3.1 (17 Mar 2008)
+
+ 17 Mar 2008; Timo Gurr <tgurr@gentoo.org> -keepassx-0.3.0a.ebuild,
+ -keepassx-0.3.0a-r20.ebuild, +keepassx-0.3.1.ebuild,
+ +keepassx-0.3.1-r20.ebuild:
+ Version bump, fixing bug #213667.
16 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
keepassx-0.3.0a.ebuild, keepassx-0.3.0a-r20.ebuild:
diff --git a/app-admin/keepassx/keepassx-0.3.0a-r20.ebuild b/app-admin/keepassx/keepassx-0.3.1-r20.ebuild
index 79923d2fb174..fdc0df830e3f 100644
--- a/app-admin/keepassx/keepassx-0.3.0a-r20.ebuild
+++ b/app-admin/keepassx/keepassx-0.3.1-r20.ebuild
@@ -1,33 +1,37 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/keepassx/keepassx-0.3.0a-r20.ebuild,v 1.3 2008/03/16 12:42:06 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/keepassx/keepassx-0.3.1-r20.ebuild,v 1.1 2008/03/17 22:48:10 tgurr Exp $
-EAPI=1
+EAPI="1"
inherit eutils qt4
-DESCRIPTION="Qt password manager compatible with its Win32 and Pocket PC versions"
+DESCRIPTION="Qt password manager compatible with its Win32 and Pocket PC versions."
HOMEPAGE="http://keepassx.sourceforge.net/"
SRC_URI="mirror://sourceforge/keepassx/KeePassX-${PV}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-DEPEND="( >=x11-libs/qt-4.4.0_rc1:4
- x11-libs/qt-qt3support )"
+IUSE="debug"
+DEPEND="( >=x11-libs/qt-core-4.4.0_beta1:4
+ >=x11-libs/qt-gui-4.4.0_beta1:4
+ >=x11-libs/qt-xmlpatterns-4.4.0_beta1:4 )"
RDEPEND="${DEPEND}"
+
S="${WORKDIR}/KeePassX-${PV}"
src_compile() {
cd "${S}/src"
- lrelease src.pro || die
+ lrelease src.pro || die "lrelease failed"
mv "${S}"/src/translations/*.qm "${S}"/share/keepassx/i18n
cd "${S}"
- eqmake4 keepass.pro PREFIX="${D}/usr" ${myconf} || die
- emake || die
+ use debug && myconf="DEBUG=1"
+ eqmake4 keepass.pro PREFIX="${D}/usr" ${myconf} || die "eqmake4 failed"
+ emake || die "emake failed"
}
src_install(){
- emake DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc changelog todo
}
diff --git a/app-admin/keepassx/keepassx-0.3.0a.ebuild b/app-admin/keepassx/keepassx-0.3.1.ebuild
index 1ab379535a3c..c51028e82929 100644
--- a/app-admin/keepassx/keepassx-0.3.0a.ebuild
+++ b/app-admin/keepassx/keepassx-0.3.1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/keepassx/keepassx-0.3.0a.ebuild,v 1.3 2008/03/16 12:42:06 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/keepassx/keepassx-0.3.1.ebuild,v 1.1 2008/03/17 22:48:10 tgurr Exp $
-EAPI=1
+EAPI="1"
inherit eutils qt4
-DESCRIPTION="Qt password manager compatible with its Win32 and Pocket PC versions"
+DESCRIPTION="Qt password manager compatible with its Win32 and Pocket PC versions."
HOMEPAGE="http://keepassx.sourceforge.net/"
SRC_URI="mirror://sourceforge/keepassx/KeePassX-${PV}.tar.gz"
@@ -20,24 +20,25 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/KeePassX-${PV}"
pkg_setup() {
- if ! built_with_use --missing true x11-libs/qt qt3support png; then
+ if ! built_with_use --missing true x11-libs/qt qt3support png ; then
eerror
- eerror "You need to rebuild x11-libs/qt with USE=qt3support and png enabled"
+ eerror "You need to rebuild x11-libs/qt with USE=\"qt3support\" and USE=\"png\" enabled."
eerror
- die "please rebuild x11-libs/qt with USE=\"qt3support png\""
+ die "Please rebuild x11-libs/qt with USE=\"qt3support png\"."
fi
}
src_compile() {
cd "${S}/src"
- lrelease src.pro || die
+ lrelease src.pro || die "lrelease failed"
mv "${S}"/src/translations/*.qm "${S}"/share/keepassx/i18n
cd "${S}"
- use debug || myconf="DEBUG=1"
- eqmake4 keepass.pro PREFIX="${D}/usr" ${myconf}|| die
- emake || die
+ use debug && myconf="DEBUG=1"
+ eqmake4 keepass.pro PREFIX="${D}/usr" ${myconf} || die "eqmake4 failed"
+ emake || die "emake failed"
}
src_install(){
- emake install || die
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc changelog todo
}