summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-02-28 22:18:23 +0000
committerMike Frysinger <vapier@gentoo.org>2003-02-28 22:18:23 +0000
commit7c73e08543517d4eb4091b8c5e98071e5d3eba07 (patch)
treeac17f917253454c53b2647f16ad06604db6906d5 /app-admin/logsentry/logsentry-1.1.1.ebuild
parenttouchups (diff)
downloadgentoo-2-7c73e08543517d4eb4091b8c5e98071e5d3eba07.tar.gz
gentoo-2-7c73e08543517d4eb4091b8c5e98071e5d3eba07.tar.bz2
gentoo-2-7c73e08543517d4eb4091b8c5e98071e5d3eba07.zip
touchups
Diffstat (limited to 'app-admin/logsentry/logsentry-1.1.1.ebuild')
-rw-r--r--app-admin/logsentry/logsentry-1.1.1.ebuild29
1 files changed, 13 insertions, 16 deletions
diff --git a/app-admin/logsentry/logsentry-1.1.1.ebuild b/app-admin/logsentry/logsentry-1.1.1.ebuild
index 30ecda1dfe4d..3c627e11cb5b 100644
--- a/app-admin/logsentry/logsentry-1.1.1.ebuild
+++ b/app-admin/logsentry/logsentry-1.1.1.ebuild
@@ -1,38 +1,36 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/logsentry/logsentry-1.1.1.ebuild,v 1.8 2003/02/13 05:26:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/logsentry/logsentry-1.1.1.ebuild,v 1.9 2003/02/28 22:18:23 vapier Exp $
-S=${WORKDIR}/logcheck-${PV}
-DESCRIPTION="LogSentry automatically monitors your system logs and mails security violations to you on a periodic basis"
+DESCRIPTION="automatically monitor system logs and mail security violations on a periodic basis"
HOMEPAGE="http://www.psionic.com/products/logsentry.html/"
SRC_URI="http://www.psionic.com/downloads/${P}.tar.gz"
-IUSE=""
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 ~ppc sparc"
-DEPEND="sys-apps/supersed"
-RDEPEND="${DEPEND}
- net-mail/mailx"
+RDEPEND="net-mail/mailx"
-src_compile() {
+S=${WORKDIR}/logcheck-${PV}
- echo "compile and install mixed in the package makefile"
+src_compile() {
+ einfo "compile and install mixed in the package makefile"
}
src_install() {
-
dodir /usr/bin /etc/logcheck/tmp /etc/cron.hourly
- ssed -i -e 's:/usr/local/bin:/usr/bin:' \
+ cp systems/linux/logcheck.sh{,.orig}
+ sed -e 's:/usr/local/bin:/usr/bin:' \
-e 's:/usr/local/etc:/etc/logcheck:' \
- ${S}/systems/linux/logcheck.sh || die
- ssed -i -e "s:/usr/local/bin:${D}/usr/bin:" \
+ systems/linux/logcheck.sh.orig > systems/linux/logcheck.sh
+ cp Makefile{,.orig}
+ sed -e "s:/usr/local/bin:${D}/usr/bin:" \
-e "s:/usr/local/etc:${D}/etc/logcheck:" \
- ${S}/Makefile || die
+ Makefile.orig > Makefile
make CFLAGS="${CFLAGS}" linux || die
- dodoc README* CHANGES LICENSE CREDITS
+ dodoc README* CHANGES CREDITS
dodoc systems/linux/README.*
cat << EOF > ${D}/etc/cron.hourly/logsentry.cron
@@ -47,7 +45,6 @@ src_install() {
#/bin/sh /etc/logcheck/logcheck.sh
EOF
-
}
pkg_postinst() {