summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-03-09 20:43:50 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-03-09 20:43:50 +0000
commitfc639123b100acd83d20a662259854fddd754f86 (patch)
treee62f550b0cc841c7c1fe55e1e8491d81c9f79bc9 /app-admin/modconf
parentVersion bump (diff)
downloadgentoo-2-fc639123b100acd83d20a662259854fddd754f86.tar.gz
gentoo-2-fc639123b100acd83d20a662259854fddd754f86.tar.bz2
gentoo-2-fc639123b100acd83d20a662259854fddd754f86.zip
initial import
Diffstat (limited to 'app-admin/modconf')
-rw-r--r--app-admin/modconf/ChangeLog13
-rw-r--r--app-admin/modconf/files/digest-modconf-0.2.431
-rw-r--r--app-admin/modconf/files/modconf-0.2.43-gentoo.patch26
-rw-r--r--app-admin/modconf/modconf-0.2.43.ebuild46
4 files changed, 86 insertions, 0 deletions
diff --git a/app-admin/modconf/ChangeLog b/app-admin/modconf/ChangeLog
new file mode 100644
index 000000000000..4712456d87ae
--- /dev/null
+++ b/app-admin/modconf/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for app-admin/modconf
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/modconf/ChangeLog,v 1.1 2003/03/09 20:43:50 azarah Exp $
+
+*modconf-0.2.43 (09 Mar 2003)
+
+ 09 Mar 2003; Martin Schlemmer <azarah@gentoo.org> modconf-0.2.43.ebuild,
+ modconf-0.2.43-gentoo.patch :
+ Initial import. Ebuild requested by Denny Schierz <linuxmail@4lin.net>.
+ It mostly works, but should need some more tweaking ... need to figure out
+ why whiplash (dev-libs/newt) segfault for instance, and why I cannot seem to
+ edit options for modules.
+
diff --git a/app-admin/modconf/files/digest-modconf-0.2.43 b/app-admin/modconf/files/digest-modconf-0.2.43
new file mode 100644
index 000000000000..66eb8027a552
--- /dev/null
+++ b/app-admin/modconf/files/digest-modconf-0.2.43
@@ -0,0 +1 @@
+MD5 047158f552c133ef4672bc909a6715c6 modconf_0.2.43.tar.gz 148061
diff --git a/app-admin/modconf/files/modconf-0.2.43-gentoo.patch b/app-admin/modconf/files/modconf-0.2.43-gentoo.patch
new file mode 100644
index 000000000000..9a7b41b08660
--- /dev/null
+++ b/app-admin/modconf/files/modconf-0.2.43-gentoo.patch
@@ -0,0 +1,26 @@
+diff -urN modconf-0.2.43/modules/dialog modconf-0.2.43.gentoo/modules/dialog
+--- modconf-0.2.43/modules/dialog 2002-02-27 23:17:13.000000000 +0200
++++ modconf-0.2.43.gentoo/modules/dialog 2003-03-09 21:54:27.000000000 +0200
+@@ -8,7 +8,7 @@
+ # Bruce Perens, November 1995
+ # This is free software under the GNU General Public License.
+
+-export DIALOG_COMMAND=whiptail
++export DIALOG_COMMAND=dialog
+ #test -x /usr/bin/dialog && export DIALOG_COMMAND=dialog
+ # dialog breaks on zero-arguments
+
+diff -urN modconf-0.2.43/modules/params modconf-0.2.43.gentoo/modules/params
+--- modconf-0.2.43/modules/params 2002-03-26 07:58:30.000000000 +0200
++++ modconf-0.2.43.gentoo/modules/params 2003-03-09 20:48:56.000000000 +0200
+@@ -48,8 +48,8 @@
+ KernelVersion=$(uname -r)
+
+ Dir_Prefix=$Target/lib/modules/$KernelVersion
+-CFGFILE=$Target/etc/modules.conf
+-MODULESFILE=$Target/etc/modules
++CFGFILE=$Target/etc/modules.d/modconf
++MODULESFILE=$Target/etc/modules.autoload
+ MODUTILSDIR=$Target/etc/modutils
+
+ CFGHEADER="### This file is automatically generated by update-modules"
diff --git a/app-admin/modconf/modconf-0.2.43.ebuild b/app-admin/modconf/modconf-0.2.43.ebuild
new file mode 100644
index 000000000000..ddc49b2d3c45
--- /dev/null
+++ b/app-admin/modconf/modconf-0.2.43.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/modconf/modconf-0.2.43.ebuild,v 1.1 2003/03/09 20:43:50 azarah Exp $
+
+# Some notes: This should rather depend on dev-libs/newt, and use whiptail,
+# not dev-util/dialog.
+#
+# I could not get it to edit module options, but mostly because I
+# have 2.5 on this box, and a limited 2.4 on my gateway, so it
+# "should" work, but is not really tested.
+
+inherit eutils
+
+IUSE=""
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Modconf provides a GUI for installing and configuring device driver modules."
+SRC_URI="http://ftp.debian.org/debian/pool/main/m/modconf/${P/-/_}.tar.gz"
+HOMEPAGE="http://packages.debian.org/stable/base/modconf.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="dev-util/dialog
+ sys-apps/modutils"
+# dev-libs/newt
+
+pkg_setup() {
+ check_KV
+}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}; epatch ${FILESDIR}/${P}-gentoo.patch
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}
+