summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-12-12 18:13:14 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-12-12 18:13:14 +0000
commitc2bc77640148125c5d0c0357a0059b630265c911 (patch)
tree3ae4cea0e71b54bb40a08915d1fa97bdcd715be0 /app-admin/paxtest
parentRestrict tests for all release versions. (diff)
downloadgentoo-2-c2bc77640148125c5d0c0357a0059b630265c911.tar.gz
gentoo-2-c2bc77640148125c5d0c0357a0059b630265c911.tar.bz2
gentoo-2-c2bc77640148125c5d0c0357a0059b630265c911.zip
Version bump
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'app-admin/paxtest')
-rw-r--r--app-admin/paxtest/ChangeLog11
-rw-r--r--app-admin/paxtest/files/paxtest-0.9.13-Makefile.patch21
-rw-r--r--app-admin/paxtest/paxtest-0.9.13.ebuild80
3 files changed, 109 insertions, 3 deletions
diff --git a/app-admin/paxtest/ChangeLog b/app-admin/paxtest/ChangeLog
index c4a26bd7a7ce..9be124e9bd69 100644
--- a/app-admin/paxtest/ChangeLog
+++ b/app-admin/paxtest/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/paxtest
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/paxtest/ChangeLog,v 1.43 2011/05/03 14:58:16 blueness Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/paxtest/ChangeLog,v 1.44 2014/12/12 18:13:14 blueness Exp $
+
+*paxtest-0.9.13 (12 Dec 2014)
+
+ 12 Dec 2014; Anthony G. Basile <blueness@gentoo.org>
+ +files/paxtest-0.9.13-Makefile.patch, +paxtest-0.9.13.ebuild:
+ Version bump
03 May 2011; Anthony G. Basile <blueness@gentoo.org>
-paxtest-0.9.7_pre5.ebuild, -files/paxtest-0.9.7_pre5-Makefile.patch,
@@ -182,4 +188,3 @@
04 Aug 2003; <solar@gentoo.org> metadata.xml, paxtest-0.9.1.ebuild:
Initial import of paxtest into portage, PaX regression test suite developed by
Peter Busser
-
diff --git a/app-admin/paxtest/files/paxtest-0.9.13-Makefile.patch b/app-admin/paxtest/files/paxtest-0.9.13-Makefile.patch
new file mode 100644
index 000000000000..1f8a99a689b2
--- /dev/null
+++ b/app-admin/paxtest/files/paxtest-0.9.13-Makefile.patch
@@ -0,0 +1,21 @@
+diff -Naur paxtest-0.9.13.orig/Makefile paxtest-0.9.13/Makefile
+--- paxtest-0.9.13.orig/Makefile 2014-12-09 19:53:48.000000000 -0500
++++ paxtest-0.9.13/Makefile 2014-12-12 13:07:55.715099100 -0500
+@@ -52,12 +52,14 @@
+ endif
+
+ # for some reason the .c files need it, else GNU_STACK=RWE
+-OPT_FLAGS := -O2 $(ASFLAGS)
++# Gentoo's CFLAGS should be honored
++OPT_FLAGS := $(CFLAGS) $(ASFLAGS)
+ PTHREAD := -lpthread
+ # define stripping of binaries/libs here, or set these on make's commandline,
+ # else you'll loose the chpax flags!
+-LDFLAGS :=
+-SHLDFLAGS :=
++# Gentoo's LDFLAGS should be honored
++LDFLAGS := $(LDFLAGS)
++SHLDFLAGS := $(LDFLAGS)
+ ifndef RUNDIR
+ RUNDIR := .
+ endif
diff --git a/app-admin/paxtest/paxtest-0.9.13.ebuild b/app-admin/paxtest/paxtest-0.9.13.ebuild
new file mode 100644
index 000000000000..be2dc2674c1f
--- /dev/null
+++ b/app-admin/paxtest/paxtest-0.9.13.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/paxtest/paxtest-0.9.13.ebuild,v 1.1 2014/12/12 18:13:14 blueness Exp $
+
+EAPI="2"
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="PaX regression test suite"
+HOMEPAGE="http://pax.grsecurity.net"
+SRC_URI="http://grsecurity.net/~spender/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ sys-apps/paxctl"
+
+# EI_PAX flags are not strip safe.
+RESTRICT="strip"
+
+QA_EXECSTACK="usr/bin/${PN}
+ usr/$(get_libdir)/${PN}/getamap
+ usr/$(get_libdir)/${PN}/shlibtest2.so
+ usr/$(get_libdir)/${PN}/execheap
+ usr/$(get_libdir)/${PN}/mprotstack
+ usr/$(get_libdir)/${PN}/mprotdata
+ usr/$(get_libdir)/${PN}/mprotheap
+ usr/$(get_libdir)/${PN}/randshlib
+ usr/$(get_libdir)/${PN}/randmain1
+ usr/$(get_libdir)/${PN}/getshlib
+ usr/$(get_libdir)/${PN}/randheap2
+ usr/$(get_libdir)/${PN}/rettofunc2x
+ usr/$(get_libdir)/${PN}/shlibdata
+ usr/$(get_libdir)/${PN}/shlibbss
+ usr/$(get_libdir)/${PN}/getmain1
+ usr/$(get_libdir)/${PN}/execdata
+ usr/$(get_libdir)/${PN}/execstack
+ usr/$(get_libdir)/${PN}/rettofunc2
+ usr/$(get_libdir)/${PN}/mprotshdata
+ usr/$(get_libdir)/${PN}/getstack1
+ usr/$(get_libdir)/${PN}/randamap
+ usr/$(get_libdir)/${PN}/rettofunc1x
+ usr/$(get_libdir)/${PN}/getheap2
+ usr/$(get_libdir)/${PN}/getheap1
+ usr/$(get_libdir)/${PN}/randheap1
+ usr/$(get_libdir)/${PN}/getstack2
+ usr/$(get_libdir)/${PN}/getmain2
+ usr/$(get_libdir)/${PN}/rettofunc1
+ usr/$(get_libdir)/${PN}/randstack2
+ usr/$(get_libdir)/${PN}/mprotshbss
+ usr/$(get_libdir)/${PN}/randstack1
+ usr/$(get_libdir)/${PN}/mprotanon
+ usr/$(get_libdir)/${PN}/randmain2
+ usr/$(get_libdir)/${PN}/writetext
+ usr/$(get_libdir)/${PN}/mprotbss
+ usr/$(get_libdir)/${PN}/anonmap
+ usr/$(get_libdir)/${PN}/execbss
+ usr/$(get_libdir)/${PN}/shlibtest.so"
+
+src_prepare() {
+ mv Makefile.psm Makefile
+ epatch "${FILESDIR}/${P}-Makefile.patch"
+ sed -i "s/^CC := gcc/CC := $(tc-getCC)/" Makefile
+ sed -i "s/^LD := ld/LD := $(tc-getLD)/" Makefile
+}
+
+src_compile() {
+ emake RUNDIR=/usr/$(get_libdir)/paxtest || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" BINDIR=/usr/bin RUNDIR=/usr/$(get_libdir)/paxtest install || die
+
+ newman debian/manpage.1.ex paxtest.1 || die
+ dodoc ChangeLog README || die
+}