summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Hoffmann <hoffie@gentoo.org>2009-09-29 16:03:10 +0000
committerChristian Hoffmann <hoffie@gentoo.org>2009-09-29 16:03:10 +0000
commit9e938ded51d4564de75787ae6b42847b5cdcabf2 (patch)
tree523f2d330f2c642463893d871392568fc25d0e8d /app-admin/phpsyslogng/phpsyslogng-2.9.8m-r1.ebuild
parentVersion bump. (diff)
downloadgentoo-2-9e938ded51d4564de75787ae6b42847b5cdcabf2.tar.gz
gentoo-2-9e938ded51d4564de75787ae6b42847b5cdcabf2.tar.bz2
gentoo-2-9e938ded51d4564de75787ae6b42847b5cdcabf2.zip
fixing bug 269822, thanks to Cameron Tacklind <cameron@tacklind.com>
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/phpsyslogng/phpsyslogng-2.9.8m-r1.ebuild')
-rw-r--r--app-admin/phpsyslogng/phpsyslogng-2.9.8m-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-admin/phpsyslogng/phpsyslogng-2.9.8m-r1.ebuild b/app-admin/phpsyslogng/phpsyslogng-2.9.8m-r1.ebuild
new file mode 100644
index 000000000000..e699e48d52d9
--- /dev/null
+++ b/app-admin/phpsyslogng/phpsyslogng-2.9.8m-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/phpsyslogng/phpsyslogng-2.9.8m-r1.ebuild,v 1.1 2009/09/29 16:03:10 hoffie Exp $
+
+inherit webapp
+
+DESCRIPTION="php-syslog-ng is a log monitor designed to easily manage logs from many hosts."
+HOMEPAGE="http://php-syslog-ng.googlecode.com/"
+SRC_URI="http://php-syslog-ng.googlecode.com/files/php-syslog-ng-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="mysql"
+
+RDEPEND="virtual/httpd-php
+ mysql? ( >=virtual/mysql-4.1 )"
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc html/README html/CHANGELOG \
+ html/INSTALL-STEPS \
+ html/TROUBLESHOOTING-INSTALL
+ rm html/LICENSE html/README \
+ html/CHANGELOG html/INSTALL-STEPS \
+ html/TROUBLESHOOTING-INSTALL
+ dodoc scripts/*
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r ./html/{.htaccess,*}
+
+ webapp_configfile "${MY_HTDOCSDIR}/config/config.php"
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}/config/"
+ webapp_serverowned -R "${MY_HTDOCSDIR}/jpcache/"
+
+ webapp_postinst_txt en "${FILESDIR}/postinstall-en.txt"
+
+ webapp_src_install
+}