summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-09-05 13:16:04 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-09-05 13:16:04 +0000
commit0dd015d0145871c465885e3db92514ea97ad2580 (patch)
treedd3397a30bcac08af85afa13c360a854c5e18f40 /app-admin/skey
parentInitial import (diff)
downloadgentoo-2-0dd015d0145871c465885e3db92514ea97ad2580.tar.gz
gentoo-2-0dd015d0145871c465885e3db92514ea97ad2580.tar.bz2
gentoo-2-0dd015d0145871c465885e3db92514ea97ad2580.zip
Initial import
Diffstat (limited to 'app-admin/skey')
-rw-r--r--app-admin/skey/ChangeLog10
-rw-r--r--app-admin/skey/Manifest4
-rw-r--r--app-admin/skey/files/digest-skey-1.1.52
-rw-r--r--app-admin/skey/metadata.xml17
-rw-r--r--app-admin/skey/skey-1.1.5.ebuild72
5 files changed, 104 insertions, 1 deletions
diff --git a/app-admin/skey/ChangeLog b/app-admin/skey/ChangeLog
new file mode 100644
index 000000000000..02110385239a
--- /dev/null
+++ b/app-admin/skey/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-admin/skey
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/skey/ChangeLog,v 1.1 2003/09/05 13:15:59 taviso Exp $
+
+*skey-1.1.5 (05 Sep 2003)
+
+ 05 Sep 2003; Tavis Ormandy <taviso@gentoo.org> skey-1.1.5.ebuild:
+ Initial import, Thanks to Jeb Campbell <jebc@c4solutions.net> for
+ submitting the ebuild in #11478
+
diff --git a/app-admin/skey/Manifest b/app-admin/skey/Manifest
index 624baf841923..2cc2cd9befbc 100644
--- a/app-admin/skey/Manifest
+++ b/app-admin/skey/Manifest
@@ -1,2 +1,4 @@
-MD5 23cbd8615e15a7cf0dd8b05906443e07 skey-1.1.5.ebuild 1222
+MD5 13c6bf8f5062e0521c41a29c3547e9a8 skey-1.1.5.ebuild 1803
+MD5 6b5dadc216188e86be87eb6d5f7f8243 ChangeLog 409
+MD5 fb946a077c4e2ae03befc41f3a095b39 metadata.xml 1425
MD5 bc72b21ce3e5fcbcb1e728c0cc55702a files/digest-skey-1.1.5 117
diff --git a/app-admin/skey/files/digest-skey-1.1.5 b/app-admin/skey/files/digest-skey-1.1.5
new file mode 100644
index 000000000000..61a316d30073
--- /dev/null
+++ b/app-admin/skey/files/digest-skey-1.1.5
@@ -0,0 +1,2 @@
+MD5 af816298e3a0bc722380d0fe480189d9 skey-1.1.5.tar.bz2 61911
+MD5 4f50b7ee1c696818eab06800e4252b6a rfc1938.txt 44844
diff --git a/app-admin/skey/metadata.xml b/app-admin/skey/metadata.xml
new file mode 100644
index 000000000000..50098562cca9
--- /dev/null
+++ b/app-admin/skey/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>taviso@gentoo.org</email>
+ <name>Tavis Ormandy</name>
+</maintainer>
+<longdescription>
+From RFC2289:
+One form of attack on networked computing systems is eavesdropping on network connections to obtain authentication information such as the login IDs and passwords of legitimate users. Once this information is captured, it can be used at a later time to gain access to the system. One-time password systems are designed to counter this type of attack, called a "replay attack."
+
+The authentication system described in this document uses a secret pass-phrase to generate a sequence of one-time (single use) passwords. With this system, the user's secret pass-phrase never needs to cross the network at any time such as during authentication or during pass-phrase changes. Thus, it is not vulnerable to replay attacks. Added security is provided by the property that no secret information need be stored on any system, including the server being protected.
+
+The OTP system protects against external passive attacks against the authentication subsystem. It does not prevent a network eavesdropper from gaining access to private information and does not provide protection against either "social engineering" or active attacks.
+</longdescription>
+</pkgmetadata>
diff --git a/app-admin/skey/skey-1.1.5.ebuild b/app-admin/skey/skey-1.1.5.ebuild
new file mode 100644
index 000000000000..3351f2433a5f
--- /dev/null
+++ b/app-admin/skey/skey-1.1.5.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/skey/skey-1.1.5.ebuild,v 1.1 2003/09/05 13:15:59 taviso Exp $
+
+inherit flag-o-matic ccc
+
+DESCRIPTION="Linux Port of OpenBSD Single-key Password System"
+HOMEPAGE="http://www.sparc.spb.su/solaris/skey/"
+SRC_URI="http://www.sparc.spb.su/solaris/skey/${P}.tar.bz2
+ doc? ( http://www.ietf.org/rfc/rfc1938.txt )"
+
+LICENSE="BSD X11"
+SLOT="0"
+KEYWORDS="~x86 ~alpha"
+
+IUSE="doc"
+RDEPEND=">=dev-lang/perl-5.8.0
+ virtual/mta
+ virtual/glibc"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+
+ if use alpha; then
+ append-flags -fPIC
+ append-ldflags -fPIC
+ fi
+
+ econf --sysconfdir=/etc/skey || die
+ emake || die
+}
+
+src_install() {
+ doman skey.1 skeyaudit.1 skeyinfo.1 skeyinit.1 skeyprune.8
+ dobin skey skeyinit skeyinfo skeyaudit
+ newbin skeyprune.pl skeyprune
+ dolib.a libskey.a
+
+ insinto /usr/include
+ doins skey.h sha1.h rmd160.h
+
+ insinto /etc/skey
+ newins /dev/null skeykeys
+
+ # only root needs to have access to these files.
+ fperms g-rx,o-rx /etc/skey/skeykeys /etc/skey
+
+ # skeyinit and skeyinfo must be suid root so users
+ # can generate their passwords.
+ #
+ # probably a good idea to remove read permission to
+ # suid binaries.
+ fperms u+s,o-r,g-r /usr/bin/skeyinit /usr/bin/skeyinfo
+
+ dodoc README CHANGES md4.copyright md5.copyright
+ use doc && dodoc ${DISTDIR}/rfc1938.txt
+
+ prepallman
+}
+
+pkg_postinst() {
+ einfo "For an introduction into using S/Key authentication with"
+ einfo "OpenSSH, SANS has a primer available here"
+ einfo
+ einfo "http://www.sans.org/rr/paper.php?id=100"
+ einfo
+ einfo "Please remember, to enable S/Key authentication with"
+ einfo "openssh, you must install openssh with the skey USE"
+ einfo "flag set."
+}