summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2007-06-21 18:09:41 +0000
committerAli Polatel <hawking@gentoo.org>2007-06-21 18:09:41 +0000
commit4f97c2b4f262bef9e1f742b7bd7593d19379ecaf (patch)
tree258e384e25067e0fc1a3441b414ddc8eb4aaa1f4 /app-admin/sshguard/sshguard-1.0.ebuild
parentAdded missing dep - stops building at the start, so no bump (either it worked... (diff)
downloadgentoo-2-4f97c2b4f262bef9e1f742b7bd7593d19379ecaf.tar.gz
gentoo-2-4f97c2b4f262bef9e1f742b7bd7593d19379ecaf.tar.bz2
gentoo-2-4f97c2b4f262bef9e1f742b7bd7593d19379ecaf.zip
new package, import from sunrise (bug #169754)
(Portage version: 2.1.3_rc4)
Diffstat (limited to 'app-admin/sshguard/sshguard-1.0.ebuild')
-rw-r--r--app-admin/sshguard/sshguard-1.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-admin/sshguard/sshguard-1.0.ebuild b/app-admin/sshguard/sshguard-1.0.ebuild
new file mode 100644
index 000000000000..0f243a48d78c
--- /dev/null
+++ b/app-admin/sshguard/sshguard-1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sshguard/sshguard-1.0.ebuild,v 1.1 2007/06/21 18:09:40 hawking Exp $
+
+DESCRIPTION="protects hosts from brute force attacks against ssh"
+HOMEPAGE="http://sshguard.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="net-firewall/iptables"
+
+src_compile() {
+ econf --with-firewall=iptables
+ emake CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README Changes || die "dodoc failed"
+ dodoc -r examples || die "dodoc failed"
+}