summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2003-08-10 07:56:37 +0000
committerJoshua Kinard <kumba@gentoo.org>2003-08-10 07:56:37 +0000
commit1cf90d8d5671bd3ff9d13e31c34ff7146966200e (patch)
tree4c11361a2b8ce22f00b1eeac5808a4f9f25b852e /app-admin/sus/sus-2.0.2.ebuild
parentMoved sus-2.0.1 to x86 stable; added sus-2.0.2 to unstable (diff)
downloadgentoo-2-1cf90d8d5671bd3ff9d13e31c34ff7146966200e.tar.gz
gentoo-2-1cf90d8d5671bd3ff9d13e31c34ff7146966200e.tar.bz2
gentoo-2-1cf90d8d5671bd3ff9d13e31c34ff7146966200e.zip
Moved sus-2.0.1 to x86 stable; added sus-2.0.2 to unstable
Diffstat (limited to 'app-admin/sus/sus-2.0.2.ebuild')
-rw-r--r--app-admin/sus/sus-2.0.2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-admin/sus/sus-2.0.2.ebuild b/app-admin/sus/sus-2.0.2.ebuild
new file mode 100644
index 000000000000..7075e0703ffa
--- /dev/null
+++ b/app-admin/sus/sus-2.0.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sus/sus-2.0.2.ebuild,v 1.1 2003/08/10 07:56:31 kumba Exp $
+
+DESCRIPTION="allows certain users to run commands as root or other users"
+SRC_URI="http://pdg.uow.edu.au/sus/${P}.tar.Z"
+HOMEPAGE="http://pdg.uow.edu.au/sus/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~mips"
+IUSE="pam"
+
+DEPEND="virtual/glibc
+ pam? ( >=sys-libs/pam-0.73-r1 )"
+
+src_compile() {
+ local myconf
+ local lflags
+ myconf="-DDEBUG"
+ use pam > /dev/null 2>&1 && myconf="${myconf} -DUSE_PAM" && lflags="-lpam"
+ myconf="${myconf} -DPROMISCUOUS -DUSE_SHADOW \
+ -DSUSERS=\\\"/etc/susers.cpp\\\""
+ make \
+ CC=${CC} \
+ CFLAGS="${CFLAGS} ${myconf}" \
+ LFLAGS="${lflags}" \
+ sus || die
+}
+
+src_install() {
+ ln -s man/sus.1 sus.8
+ dobin sus
+ doman sus.8
+ dodoc COPYING INSTALL README susers.sample
+ dodir /var/run/sus
+ insinto /etc
+ newins ${FILESDIR}/susers.cpp susers.cpp
+ fperms 4755 /usr/bin/sus
+ fperms 700 /var/run/sus
+ insinto /etc
+ doins ${FILESDIR}/susers.cpp
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "A default configuration file has been installed as"
+ einfo "/etc/susers.cpp. It is best to read over it and"
+ einfo "make any changes as necessary."
+ einfo ""
+}