summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-03-10 02:49:12 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-03-10 02:49:12 +0000
commit3eb677bdcdc552589f92c55f46d53d9d36ad5e73 (patch)
treeb127324aeeac1b980f9767afda5213322153d032 /app-admin/sxid/sxid-4.0.4-r1.ebuild
parentStable on sparc (diff)
downloadgentoo-2-3eb677bdcdc552589f92c55f46d53d9d36ad5e73.tar.gz
gentoo-2-3eb677bdcdc552589f92c55f46d53d9d36ad5e73.tar.bz2
gentoo-2-3eb677bdcdc552589f92c55f46d53d9d36ad5e73.zip
Bug #50847, fix dep on mail stuff.
(Portage version: 2.0.51.16)
Diffstat (limited to 'app-admin/sxid/sxid-4.0.4-r1.ebuild')
-rw-r--r--app-admin/sxid/sxid-4.0.4-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-admin/sxid/sxid-4.0.4-r1.ebuild b/app-admin/sxid/sxid-4.0.4-r1.ebuild
new file mode 100644
index 000000000000..4b8969081f16
--- /dev/null
+++ b/app-admin/sxid/sxid-4.0.4-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sxid/sxid-4.0.4-r1.ebuild,v 1.1 2005/03/10 02:49:12 robbat2 Exp $
+
+DESCRIPTION="suid, sgid file and directory checking"
+SRC_URI="http://www.phunnypharm.org/pub/sxid/${P/-/_}.tar.gz"
+HOMEPAGE="http://freshmeat.net/projects/sxid"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE=""
+
+RDEPEND="virtual/libc
+ mail-client/mailx"
+DEPEND="virtual/libc
+ sys-apps/sed
+ sys-devel/gcc
+ sys-devel/autoconf"
+
+src_compile() {
+ # this is an admin application and really requires root to run correctly
+ # we need to move the binary to the sbin directory
+ cd source
+ sed -i s/bindir/sbindir/g Makefile.in
+ cd ..
+
+ econf || die "econf failed"
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc README docs/sxid.conf.example docs/sxid.cron.example
+}
+
+pkg_postinst() {
+ einfo "You will need to configure sxid.conf for your system using the manpage and example"
+}