summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bock <nicolasbock@gentoo.org>2015-04-20 21:21:56 +0000
committerNicolas Bock <nicolasbock@gentoo.org>2015-04-20 21:21:56 +0000
commit43294a7334f1aac2067202804c798ed7448c3bac (patch)
tree2539a815e6c410cdad3b70fc5ba7ed4eef8ae519 /app-admin/testdisk
parentPatch by hal to control more visualizers #536610. (diff)
downloadgentoo-2-43294a7334f1aac2067202804c798ed7448c3bac.tar.gz
gentoo-2-43294a7334f1aac2067202804c798ed7448c3bac.tar.bz2
gentoo-2-43294a7334f1aac2067202804c798ed7448c3bac.zip
app-admin/testdisk: Fix doc installation path.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key AC91CA52)
Diffstat (limited to 'app-admin/testdisk')
-rw-r--r--app-admin/testdisk/ChangeLog7
-rw-r--r--app-admin/testdisk/testdisk-7.0-r1.ebuild77
2 files changed, 83 insertions, 1 deletions
diff --git a/app-admin/testdisk/ChangeLog b/app-admin/testdisk/ChangeLog
index 3edb9d399138..30c1c6a93c54 100644
--- a/app-admin/testdisk/ChangeLog
+++ b/app-admin/testdisk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/testdisk
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/testdisk/ChangeLog,v 1.57 2015/04/20 19:59:01 nicolasbock Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/testdisk/ChangeLog,v 1.58 2015/04/20 21:21:56 nicolasbock Exp $
+
+*testdisk-7.0-r1 (20 Apr 2015)
+
+ 20 Apr 2015; Nicolas Bock <nicolasbock@gentoo.org> +testdisk-7.0-r1.ebuild:
+ app-admin/testdisk: Fix doc installation path.
20 Apr 2015; Nicolas Bock <nicolasbock@gentoo.org> files/install-gentoo.patch,
testdisk-6.14.ebuild, testdisk-7.0.ebuild:
diff --git a/app-admin/testdisk/testdisk-7.0-r1.ebuild b/app-admin/testdisk/testdisk-7.0-r1.ebuild
new file mode 100644
index 000000000000..3dd66af94910
--- /dev/null
+++ b/app-admin/testdisk/testdisk-7.0-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/testdisk/testdisk-7.0-r1.ebuild,v 1.1 2015/04/20 21:21:56 nicolasbock Exp $
+
+EAPI=5
+
+inherit autotools-utils eutils flag-o-matic
+
+DESCRIPTION="Checks and undeletes partitions + PhotoRec, signature based recovery tool"
+HOMEPAGE="http://www.cgsecurity.org/wiki/TestDisk"
+SRC_URI="http://www.cgsecurity.org/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="jpeg ntfs reiserfs static"
+
+# WARNING: reiserfs support does NOT work with reiserfsprogs
+# you MUST use progsreiserfs-0.3.1_rc8 (the last version ever released).
+DEPEND="
+ static? (
+ sys-apps/util-linux[static-libs]
+ >=sys-libs/ncurses-5.2[static-libs]
+ jpeg? ( virtual/jpeg:*[static-libs] )
+ ntfs? ( <=sys-fs/ntfs3g-2013.1.13[static-libs] )
+ reiserfs? ( >=sys-fs/progsreiserfs-0.3.1_rc8[static-libs] )
+ >=sys-fs/e2fsprogs-1.35[static-libs]
+ sys-libs/zlib[static-libs]
+ )
+ !static? (
+ sys-apps/util-linux
+ >=sys-libs/ncurses-5.2
+ jpeg? ( virtual/jpeg:* )
+ ntfs? ( <=sys-fs/ntfs3g-2013.1.13 )
+ reiserfs? ( >=sys-fs/progsreiserfs-0.3.1_rc8 )
+ >=sys-fs/e2fsprogs-1.35
+ sys-libs/zlib
+ )"
+RDEPEND="!static? ( ${DEPEND} )"
+
+PATCHES=( "${FILESDIR}/install-gentoo.patch" )
+DOCS=( )
+AUTOTOOLS_AUTORECONF=1
+BUILD_DIR="${S}"
+
+src_configure() {
+ local myconf
+
+ # this is static method is the same used by upstream for their 'static' make
+ # target, but better, as it doesn't break.
+ use static && append-ldflags -static
+
+ # --with-foo are broken, any use of --with/--without disable the
+ # functionality.
+ # The following variation must be used.
+ use reiserfs || myconf+=" --without-reiserfs"
+ use ntfs || myconf+=" --without-ntfs --without-ntfs3g"
+ use jpeg || myconf+=" --without-jpeg"
+
+ econf \
+ --docdir "${ROOT}/usr/share/doc/${P}" \
+ --disable-qt \
+ --without-ewf \
+ --enable-sudo \
+ ${myconf}
+
+ # perform safety checks for NTFS, REISERFS and JPEG
+ if use ntfs && ! egrep -q '^#define HAVE_LIBNTFS(3G)? 1$' "${S}"/config.h ; then
+ die "Failed to find either NTFS or NTFS-3G library."
+ fi
+ if use reiserfs && egrep -q 'undef HAVE_LIBREISERFS\>' "${S}"/config.h ; then
+ die "Failed to find reiserfs library."
+ fi
+ if use jpeg && egrep -q 'undef HAVE_LIBJPEG\>' "${S}"/config.h ; then
+ die "Failed to find jpeg library."
+ fi
+}