summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2008-06-18 12:28:03 +0000
committerChristian Faulhammer <opfer@gentoo.org>2008-06-18 12:28:03 +0000
commitfacd64ec63daae6a9eb9b6b3826c9efac78fc19c (patch)
tree1ecbb2e20dc093bd22d0f83c48c5af1d858b1dff /app-admin/tmpwatch
parentRemoved old ebuilds. (diff)
downloadgentoo-2-facd64ec63daae6a9eb9b6b3826c9efac78fc19c.tar.gz
gentoo-2-facd64ec63daae6a9eb9b6b3826c9efac78fc19c.tar.bz2
gentoo-2-facd64ec63daae6a9eb9b6b3826c9efac78fc19c.zip
version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-admin/tmpwatch')
-rw-r--r--app-admin/tmpwatch/ChangeLog8
-rw-r--r--app-admin/tmpwatch/tmpwatch-2.9.13.2.ebuild39
2 files changed, 46 insertions, 1 deletions
diff --git a/app-admin/tmpwatch/ChangeLog b/app-admin/tmpwatch/ChangeLog
index a10531cc7f5c..91622cd013d9 100644
--- a/app-admin/tmpwatch/ChangeLog
+++ b/app-admin/tmpwatch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/tmpwatch
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/tmpwatch/ChangeLog,v 1.69 2008/03/01 18:29:02 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/tmpwatch/ChangeLog,v 1.70 2008/06/18 12:28:03 opfer Exp $
+
+*tmpwatch-2.9.13.2 (18 Jun 2008)
+
+ 18 Jun 2008; Christian Faulhammer <opfer@gentoo.org>
+ +tmpwatch-2.9.13.2.ebuild:
+ version bump
01 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
-tmpwatch-2.9.11.2.ebuild:
diff --git a/app-admin/tmpwatch/tmpwatch-2.9.13.2.ebuild b/app-admin/tmpwatch/tmpwatch-2.9.13.2.ebuild
new file mode 100644
index 000000000000..479a0d52b154
--- /dev/null
+++ b/app-admin/tmpwatch/tmpwatch-2.9.13.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/tmpwatch/tmpwatch-2.9.13.2.ebuild,v 1.1 2008/06/18 12:28:03 opfer Exp $
+
+inherit rpm versionator
+
+RPM_P="${PN}-$(replace_version_separator 3 '-')"
+MY_P="${RPM_P%-*}"
+
+DESCRIPTION="Files which haven't been accessed in a given period of time are removed from specified directories"
+HOMEPAGE="https://fedorahosted.org/tmpwatch/"
+SRC_URI="http://download.fedora.redhat.com/pub/fedora/linux/development/source/SRPMS/${RPM_P}.src.rpm"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ rpm_src_unpack
+
+ cd "${S}"
+ sed -i -e "s:..RPM_OPT_FLAGS.:${CFLAGS}:" \
+ -e "s:^CVS:#CVS:g" Makefile \
+ || die "sed Makefile failed"
+ sed -i 's|/sbin/fuser|/bin/fuser|' tmpwatch.c \
+ || die "sed tmpwatch.c failed"
+ sed -i 's|/sbin|/bin|' tmpwatch.8 || die "sed tmpwatch.8 failed"
+}
+
+src_install() {
+ dosbin tmpwatch || die "dosbin failed"
+ doman tmpwatch.8 || die "doman failed"
+
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}/${PN}.cron" "${PN}" || die 'failed to install cron'
+}