summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2005-01-01 19:09:15 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2005-01-01 19:09:15 +0000
commit7acb94a71139715730e38c20f59452077643a84b (patch)
tree83f06b510bfd8c494a01d00527d5c231ed626045 /app-admin/ulogd/ulogd-1.02-r1.ebuild
parentremove support of 2004.1 ppc64 profile, (it was experimental anyway) (diff)
downloadgentoo-2-7acb94a71139715730e38c20f59452077643a84b.tar.gz
gentoo-2-7acb94a71139715730e38c20f59452077643a84b.tar.bz2
gentoo-2-7acb94a71139715730e38c20f59452077643a84b.zip
Closing #74924
Diffstat (limited to 'app-admin/ulogd/ulogd-1.02-r1.ebuild')
-rw-r--r--app-admin/ulogd/ulogd-1.02-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-admin/ulogd/ulogd-1.02-r1.ebuild b/app-admin/ulogd/ulogd-1.02-r1.ebuild
new file mode 100644
index 000000000000..6a212145f5fe
--- /dev/null
+++ b/app-admin/ulogd/ulogd-1.02-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/ulogd/ulogd-1.02-r1.ebuild,v 1.1 2005/01/01 19:09:15 aliz Exp $
+
+DESCRIPTION="iptables daemon for ULOG target for userspace iptables filter logging"
+SRC_URI="http://ftp.netfilter.org/pub/ulogd/${P}.tar.bz2"
+HOMEPAGE="http://www.gnumonks.org/gnumonks/projects/project_details?p_id=1"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc -sparc amd64"
+IUSE="mysql postgres"
+
+DEPEND="net-firewall/iptables
+ mysql? ( dev-db/mysql )
+ postgres? ( dev-db/postgresql )"
+
+src_compile() {
+ # enables logfiles over 2G (#74924)
+ append-flags -D_FILE_OFFSET_BITS=64
+
+ econf \
+ `use_with mysql` \
+ `use_with postgres pgsql` \
+ || die "configure failed"
+ make || die "make failed"
+}
+
+src_install() {
+ # the Makefile seems to be "broken" -
+ # it relies on the existance of /usr, /etc ..
+ dodir /usr/sbin /etc/init.d
+
+ make DESTDIR=${D} install || die "install failed"
+
+ cp ${FILESDIR}/ulogd-0.98 ${D}/etc/init.d/ulogd
+
+ dodoc README AUTHORS Changes
+ cd doc/
+ dodoc ulogd.txt ulogd.a4.ps
+
+ if use mysql; then
+ dodoc mysql.table mysql.table.ipaddr-as-string
+ fi
+
+ if use postgres; then
+ dodoc pgsql.table
+ fi
+
+ dohtml ulogd.html
+}