summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-08-06 05:39:21 +0000
committerMike Frysinger <vapier@gentoo.org>2004-08-06 05:39:21 +0000
commit805edde682ed2ca2d0d87f692b074e46f93a7b2d (patch)
tree61b492a90876d3102f6f9cb564a92d7348d0d9b9 /app-admin/watchdog/watchdog-5.2.ebuild
parentfinish up the profile (diff)
downloadgentoo-2-805edde682ed2ca2d0d87f692b074e46f93a7b2d.tar.gz
gentoo-2-805edde682ed2ca2d0d87f692b074e46f93a7b2d.tar.bz2
gentoo-2-805edde682ed2ca2d0d87f692b074e46f93a7b2d.zip
ver bump
Diffstat (limited to 'app-admin/watchdog/watchdog-5.2.ebuild')
-rw-r--r--app-admin/watchdog/watchdog-5.2.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/app-admin/watchdog/watchdog-5.2.ebuild b/app-admin/watchdog/watchdog-5.2.ebuild
index 80f4fbc4501e..410dee50b916 100644
--- a/app-admin/watchdog/watchdog-5.2.ebuild
+++ b/app-admin/watchdog/watchdog-5.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/watchdog/watchdog-5.2.ebuild,v 1.20 2004/07/04 16:36:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/watchdog/watchdog-5.2.ebuild,v 1.21 2004/08/06 05:39:21 vapier Exp $
inherit eutils
@@ -18,8 +18,8 @@ DEPEND="virtual/libc"
src_unpack() {
unpack ${A}
cd ${S}
- epatch ${FILESDIR}/sundries.diff
- epatch ${FILESDIR}/${P}-alpha.diff
+ epatch ${FILESDIR}/${PV}-sundries.patch
+ epatch ${FILESDIR}/${PV}-alpha.patch
}
src_compile() {
@@ -34,13 +34,12 @@ src_install() {
dodir /etc/watchdog
make DESTDIR="${D}" install || die
exeinto /etc/init.d
- doexe "${FILESDIR}/${PVR}/watchdog"
+ doexe ${FILESDIR}/watchdog
}
pkg_postinst() {
einfo "To enable the start-up script run \"rc-update add watchdog boot\"."
- if [ ! -e ${ROOT}/dev/watchdog ]
- then
+ if [ ! -e ${ROOT}/dev/watchdog ] ; then
ewarn "No /dev/watchdog found! Make sure your kernel has watchdog support"
ewarn "compiled in or the kernel module is loaded. The watchdog service"
ewarn "will not start at boot until your kernel is configured properly."