summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2010-10-28 03:05:21 +0000
committerSebastian Pipping <sping@gentoo.org>2010-10-28 03:05:21 +0000
commit3f465d6e8eebde3f3614d464992b1f61d4b27966 (patch)
tree447615b13bb1779a00d8f91b72209350c23809ed /app-admin/webalizer/webalizer-2.01.10-r15.ebuild
parentRemoving old ebuilds. (diff)
downloadgentoo-2-3f465d6e8eebde3f3614d464992b1f61d4b27966.tar.gz
gentoo-2-3f465d6e8eebde3f3614d464992b1f61d4b27966.tar.bz2
gentoo-2-3f465d6e8eebde3f3614d464992b1f61d4b27966.zip
app-admin/webalizer: Move to EAPI 2 with src_prepare() and src_configure() (bug #331027)
(Portage version: 2.1.9.22/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/webalizer/webalizer-2.01.10-r15.ebuild')
-rw-r--r--app-admin/webalizer/webalizer-2.01.10-r15.ebuild18
1 files changed, 8 insertions, 10 deletions
diff --git a/app-admin/webalizer/webalizer-2.01.10-r15.ebuild b/app-admin/webalizer/webalizer-2.01.10-r15.ebuild
index 2c6d3bf9991f..4cff09842dea 100644
--- a/app-admin/webalizer/webalizer-2.01.10-r15.ebuild
+++ b/app-admin/webalizer/webalizer-2.01.10-r15.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webalizer/webalizer-2.01.10-r15.ebuild,v 1.11 2010/03/10 16:50:36 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webalizer/webalizer-2.01.10-r15.ebuild,v 1.12 2010/10/28 03:05:21 sping Exp $
+
+EAPI="2"
# uses webapp.eclass to create directories with right permissions
# probably slight overkill but works well
@@ -51,9 +53,7 @@ pkg_setup() {
fi
}
-src_unpack() {
- unpack ${A} ; cd "${S}"
-
+src_prepare() {
if use geoip; then
epatch "${WORKDIR}"/geolizer_${MY_PV}-patch/geolizer.patch || die
use xtended && elog "Xtended doesn't work with geolizer, skipping"
@@ -66,9 +66,12 @@ src_unpack() {
# bug 121816: prevent truncated useragent fields
sed -i -e 's:^#define MAXAGENT 64:#define MAXAGENT 128:' webalizer.h
+
+ # stupid broken configuration file
+ eautoreconf
}
-src_compile() {
+src_configure() {
local myconf=" --enable-dns \
--with-db=$(db_includedir) \
--with-dblib=$(db_libname)"
@@ -86,12 +89,7 @@ src_compile() {
myconf="${myconf} --with-language=english"
fi
- # stupid broken configuration file
- eautoreconf
-
econf ${myconf} || die "econf failed"
-
- emake || die "emake failed"
}
src_install() {