summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-04-03 14:26:31 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-04-03 14:26:31 +0000
commit9111ff50a0220e81e12b1d73775c63100a08d4ee (patch)
tree9bee041c81529eb5b67c634df74a5420d87565d0 /app-admin/yaala/yaala-0.7.3-r1.ebuild
parentFix src_install function, bug 464270 by Tom Samstag. (diff)
downloadgentoo-2-9111ff50a0220e81e12b1d73775c63100a08d4ee.tar.gz
gentoo-2-9111ff50a0220e81e12b1d73775c63100a08d4ee.tar.bz2
gentoo-2-9111ff50a0220e81e12b1d73775c63100a08d4ee.zip
Taking maintainership. Bump: Added required perl dependencies and two optional dependencies gd and storable as per the scripts and site which users, this will bring more functionality to the user. Revised the install function to install to the proper locations (eg. /etc), also added patches in src_prepare such that the proper config and var directories are used by Yaala by default. Also made the ebuild slightly more maintainable. Extensively tested.
(Portage version: 2.1.11.60/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'app-admin/yaala/yaala-0.7.3-r1.ebuild')
-rw-r--r--app-admin/yaala/yaala-0.7.3-r1.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/app-admin/yaala/yaala-0.7.3-r1.ebuild b/app-admin/yaala/yaala-0.7.3-r1.ebuild
new file mode 100644
index 000000000000..76ad5902b237
--- /dev/null
+++ b/app-admin/yaala/yaala-0.7.3-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/yaala/yaala-0.7.3-r1.ebuild,v 1.1 2013/04/03 14:26:31 tomwij Exp $
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="Yet Another Log Analyzer"
+HOMEPAGE="http://www.yaala.org/"
+SRC_URI="http://www.${PN}.org/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gd storable"
+
+RDEPEND="dev-lang/perl
+ gd? ( dev-perl/GDGraph )
+ storable? ( virtual/perl-Storable )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PF}-correct-paths.patch
+
+ sed -i "s:/var/lib/${PN}:/usr/bin:g" packaging/${PN}.cron || die 'Failed to correct path in cron file.'
+}
+
+src_install() {
+ dobin ${PN}
+
+ exeinto /usr/lib64/perl5/vendor_perl/${PN^}/
+ doexe lib/${PN^}/*.pm
+
+ exeinto /usr/lib64/perl5/vendor_perl/${PN^}/Data/
+ doexe lib/${PN^}/Data/*.pm
+
+ exeinto /usr/lib64/perl5/vendor_perl/${PN^}/Parser/
+ doexe lib/${PN^}/Parser/*.pm
+
+ exeinto /usr/lib64/perl5/vendor_perl/${PN^}/Report/
+ doexe lib/${PN^}/Report/*.pm
+
+ dodoc AUTHORS CHANGELOG README{,.persistency,.selections}
+
+ insinto /usr/share/${PN}
+ doins -r reports
+ doins -r sample_configs
+
+ insinto /etc/${PN}
+ doins {,webserver.}config
+
+ insinto /etc/logrotate.d
+ doins packaging/${PN}.cron
+
+ if use storable ; then
+ dodir /var/lib/${PN}
+ keepdir /var/lib/${PN}
+ chmod 777 /var/lib/${PN}
+ fi
+}
+
+pkg_postinst() {
+ ewarn "It is required that you change the configuration files in /etc/${PN}"
+ ewarn "before you run \`yaala ...\`, otherwise it will refuse to execute because"
+ ewarn "Setup.pm checks whether the variable 'select' has been unquoted and set."
+ echo ""
+ elog "Example configuration files can be found in /usr/share/${PN}."
+}