summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-06-01 11:57:12 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-06-01 11:57:12 +0000
commit23cab012c7e0b53743d1411fd49939d92e5fd928 (patch)
treee049d9c4cfc63094f99232039df8c4568dba175d /app-admin
parentStable on ppc wrt bug 224015 (diff)
downloadgentoo-2-23cab012c7e0b53743d1411fd49939d92e5fd928.tar.gz
gentoo-2-23cab012c7e0b53743d1411fd49939d92e5fd928.tar.bz2
gentoo-2-23cab012c7e0b53743d1411fd49939d92e5fd928.zip
fix #219515
(Portage version: 2.1.5.2)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/apache-tools/ChangeLog8
-rw-r--r--app-admin/apache-tools/apache-tools-2.2.8-r1.ebuild95
2 files changed, 102 insertions, 1 deletions
diff --git a/app-admin/apache-tools/ChangeLog b/app-admin/apache-tools/ChangeLog
index 4630878b71ba..cce8c9ff42d8 100644
--- a/app-admin/apache-tools/ChangeLog
+++ b/app-admin/apache-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/apache-tools
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/ChangeLog,v 1.34 2008/02/17 13:13:21 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/ChangeLog,v 1.35 2008/06/01 11:57:12 hollow Exp $
+
+*apache-tools-2.2.8-r1 (01 Jun 2008)
+
+ 01 Jun 2008; Benedikt Böhm <hollow@gentoo.org>
+ +apache-tools-2.2.8-r1.ebuild:
+ fix #219515
17 Feb 2008; Christoph Mende <angelos@gentoo.org>
apache-tools-2.2.8.ebuild:
diff --git a/app-admin/apache-tools/apache-tools-2.2.8-r1.ebuild b/app-admin/apache-tools/apache-tools-2.2.8-r1.ebuild
new file mode 100644
index 000000000000..cf38f972cd4d
--- /dev/null
+++ b/app-admin/apache-tools/apache-tools-2.2.8-r1.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/apache-tools/apache-tools-2.2.8-r1.ebuild,v 1.1 2008/06/01 11:57:12 hollow Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Useful Apache tools - htdigest, htpasswd, ab, htdbm"
+HOMEPAGE="http://httpd.apache.org/"
+SRC_URI="mirror://apache/httpd/httpd-${PV}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="ssl"
+RESTRICT="test"
+
+RDEPEND="=dev-libs/apr-1*
+ =dev-libs/apr-util-1*
+ dev-libs/libpcre
+ ssl? ( dev-libs/openssl )
+ !<www-servers/apache-2.2.4"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/httpd-${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Apply these patches:
+ # (1) apache-tools-Makefile.patch:
+ # - fix up the `make install' for support/
+ # - remove envvars from `make install'
+ epatch "${FILESDIR}"/${PN}-Makefile.patch
+}
+
+src_compile() {
+ local myconf=""
+ cd "${S}"
+
+ # Instead of filtering --as-needed (bug #128505), append --no-as-needed
+ # Thanks to Harald van Dijk
+ append-ldflags -Wl,--no-as-needed
+
+ if use ssl ; then
+ myconf="${myconf} --with-ssl=/usr --enable-ssl"
+ append-flags -DHAVE_OPENSSL -DUSE_SSL -I/usr/include/openssl
+ append-ldflags -lssl
+ fi
+
+ # econf overwrites the stuff from config.layout, so we have to put them into
+ # our myconf line too
+
+ econf \
+ --sbindir=/usr/sbin \
+ --with-perl=/usr/bin/perl \
+ --with-expat=/usr \
+ --with-z=/usr \
+ --with-apr=/usr \
+ --with-apr-util=/usr \
+ --with-pcre=/usr \
+ ${myconf} || die "econf failed!"
+
+ cd support
+ emake || die "emake support/ failed!"
+}
+
+src_install () {
+ cd "${S}"/support
+
+ make DESTDIR="${D}" install || die "make install failed!"
+
+ # install manpages
+ doman "${S}"/docs/man/{dbmmanage,htdigest,htpasswd,htdbm}.1 \
+ "${S}"/docs/man/{ab,htcacheclean,logresolve,rotatelogs}.8
+
+ # Providing compatiblity symlinks for #177697 (which we'll stop to install
+ # at some point).
+
+ for i in $(ls "${D}"/usr/sbin 2>/dev/null); do
+ dosym /usr/sbin/${i} /usr/sbin/${i}2
+ done
+
+ # Provide a symlink for ab-ssl
+ if use ssl ; then
+ dosym /usr/sbin/ab /usr/sbin/ab-ssl
+ dosym /usr/sbin/ab /usr/sbin/ab2-ssl
+ fi
+
+ # make htpasswd accessible for non-root users
+ dosym /usr/sbin/htpasswd /usr/bin/htpasswd
+
+ dodoc "${S}"/CHANGES
+}