summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2004-10-28 12:35:55 +0000
committerMarinus Schraal <foser@gentoo.org>2004-10-28 12:35:55 +0000
commit2656d8b60882eb8890529e967e23c1f0df0f1d30 (patch)
tree00e480bb1be35977d2520ba0a719ab82925259cf /app-admin
parent~amd64 (Manifest recommit) (diff)
downloadgentoo-2-2656d8b60882eb8890529e967e23c1f0df0f1d30.tar.gz
gentoo-2-2656d8b60882eb8890529e967e23c1f0df0f1d30.tar.bz2
gentoo-2-2656d8b60882eb8890529e967e23c1f0df0f1d30.zip
minor fixes
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/fam/ChangeLog9
-rw-r--r--app-admin/fam/Manifest3
-rw-r--r--app-admin/fam/fam-2.7.0-r2.ebuild86
-rw-r--r--app-admin/fam/files/digest-fam-2.7.0-r21
4 files changed, 97 insertions, 2 deletions
diff --git a/app-admin/fam/ChangeLog b/app-admin/fam/ChangeLog
index 74d4a02f1db6..c4b6b224a956 100644
--- a/app-admin/fam/ChangeLog
+++ b/app-admin/fam/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/fam
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/fam/ChangeLog,v 1.18 2004/10/11 22:39:19 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/fam/ChangeLog,v 1.19 2004/10/28 12:35:55 foser Exp $
+
+*fam-2.7.0-r2 (28 Oct 2004)
+
+ 28 Oct 2004; foser <foser@gentoo.org> fam-2.7.0-r2.ebuild :
+ Fix sedding & spiff-up postinst message (#59896)
+ Remove --background from init script (#64029)
+ Add gamin block
12 Oct 2004; foser <foser@gentoo.org> fam-2.7.0{-r1}.ebuild :
Add provide for virtual/fam (#67170)
diff --git a/app-admin/fam/Manifest b/app-admin/fam/Manifest
index 7004dbb408fd..20624c9df606 100644
--- a/app-admin/fam/Manifest
+++ b/app-admin/fam/Manifest
@@ -1,8 +1,9 @@
-MD5 73329e55dcf67ad2134db4625b63971c fam-2.7.0-r1.ebuild 2062
+MD5 a25c0e01e1ed1fd31745a4b1e2c9b213 fam-2.7.0-r2.ebuild 2076
MD5 9e60119cd6efc8c2de7e96ef34d223ed ChangeLog 6416
MD5 68a04e23ccfb7971cff8ce012aee659c metadata.xml 221
MD5 4d1b2c159a798e794f7045b237db72ab fam-2.7.0.ebuild 1900
MD5 894ce263618ad960c3d0874259cd1b54 files/famd 506
MD5 a7434bbb78ba9e735212e8b1e5bb0a0f files/digest-fam-2.7.0 61
MD5 a7434bbb78ba9e735212e8b1e5bb0a0f files/digest-fam-2.7.0-r1 61
+MD5 a7434bbb78ba9e735212e8b1e5bb0a0f files/digest-fam-2.7.0-r2 61
MD5 46e90fb6975cfcaa7f5946ab36aa2023 files/fam-2.7.0-dnotify.patch 26419
diff --git a/app-admin/fam/fam-2.7.0-r2.ebuild b/app-admin/fam/fam-2.7.0-r2.ebuild
new file mode 100644
index 000000000000..54ceac600665
--- /dev/null
+++ b/app-admin/fam/fam-2.7.0-r2.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/fam/fam-2.7.0-r2.ebuild,v 1.1 2004/10/28 12:35:55 foser Exp $
+
+inherit libtool eutils gnuconfig
+
+DESCRIPTION="FAM, the File Alteration Monitor"
+HOMEPAGE="http://oss.sgi.com/projects/fam/"
+SRC_URI="ftp://oss.sgi.com/projects/fam/download/stable/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="x86 ~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc"
+IUSE=""
+
+DEPEND=">=net-nds/portmap-5b-r6
+ !app-admin/gamin"
+
+PROVIDE="virtual/fam"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ # dnotify patch #43027
+ epatch ${FILESDIR}/${P}-dnotify.patch
+
+ # Fix permission problems with user* in FEATURES (#35307)
+ chmod u+w ${S}/configure
+
+ # Please do not remove this again - fixes $S and $D in libtool linker
+ # scripts (.la files)
+ cd ${S}; elibtoolize
+}
+
+src_compile() {
+
+ gnuconfig_update
+
+ econf || die "econf failed"
+ emake || die "emake failed"
+
+}
+
+src_install() {
+
+ einstall || die
+
+ dosed "s:local_only = false:local_only = true:g" /etc/fam.conf
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/famd
+
+ dodoc AUTHORS ChangeLog INSTALL NEWS TODO README
+
+}
+
+pkg_postinst() {
+
+ einfo "To enable fam on boot you will have to add it to the"
+ einfo "default profile, issue the following command as root to do so."
+ echo
+ einfo "rc-update add famd default"
+
+ # temporary warning for people upgrading
+ # 6-12-03 foser <foser@gentoo.org>
+ if [ -e /etc/init.d/fam ]
+ then
+ echo
+ echo
+ ewarn "IMPORTANT INFO FOR USERS UPGRADING FROM OLDER (<2.7.0) FAM VERSIONS :"
+ echo
+ einfo "With the 2.7.0 version the fam daemon moved to sbin and was"
+ einfo "renamed from 'fam' to 'famd'. These changes are for consistency"
+ einfo "reasons also applied to the Gentoo init script. This means you"
+ einfo "will have to remove fam from the default runlevel and add famd."
+ einfo "This can be done by issueing the following commands :"
+ echo
+ einfo "rc-update del fam"
+ einfo "rc-update add famd default"
+ einfo "rm /etc/init.d/fam"
+ echo
+ einfo "The last command removes the old init script."
+ fi
+
+}
diff --git a/app-admin/fam/files/digest-fam-2.7.0-r2 b/app-admin/fam/files/digest-fam-2.7.0-r2
new file mode 100644
index 000000000000..107b73637116
--- /dev/null
+++ b/app-admin/fam/files/digest-fam-2.7.0-r2
@@ -0,0 +1 @@
+MD5 1bf3ae6c0c58d3201afc97c6a4834e39 fam-2.7.0.tar.gz 301974