summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-02-04 11:35:14 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-02-04 11:35:14 +0000
commit7891ff3e8487fbd6ce59a3358fffc8f1c110b561 (patch)
treee0b92f72f29295635303d3d8611105955080dba2 /app-admin
parentVersion bumped. (diff)
downloadgentoo-2-7891ff3e8487fbd6ce59a3358fffc8f1c110b561.tar.gz
gentoo-2-7891ff3e8487fbd6ce59a3358fffc8f1c110b561.tar.bz2
gentoo-2-7891ff3e8487fbd6ce59a3358fffc8f1c110b561.zip
Version bumped, bug #303261.
(Portage version: 2.1.7.16/cvs/Linux x86_64)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/augeas/ChangeLog9
-rw-r--r--app-admin/augeas/augeas-0.7.0.ebuild35
2 files changed, 42 insertions, 2 deletions
diff --git a/app-admin/augeas/ChangeLog b/app-admin/augeas/ChangeLog
index ba1da6120e53..717840095659 100644
--- a/app-admin/augeas/ChangeLog
+++ b/app-admin/augeas/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/augeas
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/augeas/ChangeLog,v 1.13 2009/10/10 14:59:01 armin76 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/augeas/ChangeLog,v 1.14 2010/02/04 11:35:14 matsuu Exp $
+
+*augeas-0.7.0 (04 Feb 2010)
+
+ 04 Feb 2010; MATSUU Takuto <matsuu@gentoo.org> +augeas-0.7.0.ebuild:
+ Version bumped, bug #303261.
10 Oct 2009; Raúl Porcel <armin76@gentoo.org> augeas-0.5.2.ebuild:
sparc stable wrt #282759
diff --git a/app-admin/augeas/augeas-0.7.0.ebuild b/app-admin/augeas/augeas-0.7.0.ebuild
new file mode 100644
index 000000000000..35e8b234062a
--- /dev/null
+++ b/app-admin/augeas/augeas-0.7.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/augeas/augeas-0.7.0.ebuild,v 1.1 2010/02/04 11:35:14 matsuu Exp $
+
+DESCRIPTION="A library for changing configuration files"
+HOMEPAGE="http://augeas.net/"
+SRC_URI="http://augeas.net/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="sys-libs/readline"
+DEPEND="${RDEPEND}
+ >=app-doc/NaturalDocs-1.40
+ test? ( dev-lang/ruby )"
+
+src_compile() {
+ if [ -f /usr/share/NaturalDocs/Config/Languages.txt ] ; then
+ addwrite /usr/share/NaturalDocs/Config/Languages.txt
+ fi
+ if [ -f /usr/share/NaturalDocs/Config/Topics.txt ] ; then
+ addwrite /usr/share/NaturalDocs/Config/Topics.txt
+ fi
+
+ econf || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ dodoc AUTHORS ChangeLog README NEWS
+}