summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-05 16:35:24 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-05 16:35:24 +0000
commit8f4bc41b9dbb85b848273c510efffba5eeb2e96c (patch)
tree7d31d7c9f85f007614077dc5ca5ad52dcef89166 /app-admin
parentkonversation version bump (diff)
downloadgentoo-2-8f4bc41b9dbb85b848273c510efffba5eeb2e96c.tar.gz
gentoo-2-8f4bc41b9dbb85b848273c510efffba5eeb2e96c.tar.bz2
gentoo-2-8f4bc41b9dbb85b848273c510efffba5eeb2e96c.zip
Append -fno-PIC -fno-PIE to avoid problems with hardened compiler.
(Portage version: 13919-svn/cvs/Linux x86_64)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/eselect-python/ChangeLog6
-rw-r--r--app-admin/eselect-python/eselect-python-20090804.ebuild9
2 files changed, 12 insertions, 3 deletions
diff --git a/app-admin/eselect-python/ChangeLog b/app-admin/eselect-python/ChangeLog
index b815ab60d29a..afbcbb43168c 100644
--- a/app-admin/eselect-python/ChangeLog
+++ b/app-admin/eselect-python/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-admin/eselect-python
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-python/ChangeLog,v 1.34 2009/08/04 20:53:43 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-python/ChangeLog,v 1.35 2009/08/05 16:35:24 arfrever Exp $
+
+ 05 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ eselect-python-20090804.ebuild:
+ Append -fno-PIC -fno-PIE to avoid problems with hardened compiler.
*eselect-python-20090804 (04 Aug 2009)
diff --git a/app-admin/eselect-python/eselect-python-20090804.ebuild b/app-admin/eselect-python/eselect-python-20090804.ebuild
index 6c1a22ed4e5d..7bcadc79074a 100644
--- a/app-admin/eselect-python/eselect-python-20090804.ebuild
+++ b/app-admin/eselect-python/eselect-python-20090804.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-python/eselect-python-20090804.ebuild,v 1.2 2009/08/04 21:41:00 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-python/eselect-python-20090804.ebuild,v 1.3 2009/08/05 16:35:24 arfrever Exp $
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Manages multiple Python versions"
HOMEPAGE="http://www.gentoo.org"
@@ -16,7 +16,12 @@ IUSE=""
DEPEND=">=app-admin/eselect-1.0.2"
RDEPEND="${DEPEND}"
+pkg_setup() {
+ append-flags -fno-PIC -fno-PIE
+}
+
src_compile() {
+ echo $(tc-getCC) ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} -o python-wrapper python.c
$(tc-getCC) ${CPPFLAGS} ${CFLAGS} ${LDFLAGS} -o python-wrapper python.c || die "Building of python wrapper failed"
}