summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2008-07-19 14:36:35 +0000
committerDaniel Black <dragonheart@gentoo.org>2008-07-19 14:36:35 +0000
commita43d1d653d2ad20ff75b6fb05f94a336382d9956 (patch)
treebf88a829da49a1d580c8de0a2eddf7c8085a98ba /app-admin
parentbuild-time-specific (no revbump): fixing warnings (which sometimes seem to be... (diff)
downloadgentoo-2-a43d1d653d2ad20ff75b6fb05f94a336382d9956.tar.gz
gentoo-2-a43d1d653d2ad20ff75b6fb05f94a336382d9956.tar.bz2
gentoo-2-a43d1d653d2ad20ff75b6fb05f94a336382d9956.zip
version bump
(Portage version: 2.2_rc1/cvs/Linux 2.6.22-vs2.2.0.7-gentoo x86_64)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/testdisk/ChangeLog7
-rw-r--r--app-admin/testdisk/testdisk-6.10.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/app-admin/testdisk/ChangeLog b/app-admin/testdisk/ChangeLog
index c23789f2667f..55d1a852258d 100644
--- a/app-admin/testdisk/ChangeLog
+++ b/app-admin/testdisk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/testdisk
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/testdisk/ChangeLog,v 1.33 2008/07/17 21:35:56 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/testdisk/ChangeLog,v 1.34 2008/07/19 14:36:35 dragonheart Exp $
+
+*testdisk-6.10 (19 Jul 2008)
+
+ 19 Jul 2008; Daniel Black <dragonheart@gentoo.org> +testdisk-6.10.ebuild:
+ version bump
17 Jul 2008; Doug Goldstein <cardoe@gentoo.org> metadata.xml:
add GLEP 56 USE flag desc from use.local.desc
diff --git a/app-admin/testdisk/testdisk-6.10.ebuild b/app-admin/testdisk/testdisk-6.10.ebuild
new file mode 100644
index 000000000000..debb1c37d9f5
--- /dev/null
+++ b/app-admin/testdisk/testdisk-6.10.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/testdisk/testdisk-6.10.ebuild,v 1.1 2008/07/19 14:36:35 dragonheart Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Checks and undeletes partitions + PhotoRec, signature based recovery tool"
+HOMEPAGE="http://www.cgsecurity.org/wiki/TestDisk"
+SRC_URI="http://www.cgsecurity.org/${P}.tar.bz2"
+#SRC_URI="http://www.cgsecurity.org/${P}-WIP.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static reiserfs ntfs jpeg"
+# WARNING: reiserfs support does NOT work with reiserfsprogs
+# you MUST use progsreiserfs-0.3.1_rc8 (the last version ever released).
+DEPEND=">=sys-libs/ncurses-5.2
+ jpeg? ( media-libs/jpeg )
+ ntfs? ( >=sys-fs/ntfsprogs-2.0.0 )
+ reiserfs? ( >=sys-fs/progsreiserfs-0.3.1_rc8 )
+ >=sys-fs/e2fsprogs-1.35
+ sys-libs/zlib"
+RDEPEND="!static? ( ${DEPEND} )"
+
+#S=${WORKDIR}/${P}-WIP
+
+src_compile() {
+ local myconf="--without-ewf --enable-sudo"
+ # --with-foo are broken, any use of --with/--without disable the
+ # functionality.
+ # The following variation must be used.
+ use reiserfs || myconf="${myconf} --without-reiserfs"
+ use ntfs || myconf="${myconf} --without-ntfs"
+ use jpeg || myconf="${myconf} --without-jpeg"
+
+ # this is static method is the same used by upstream for their 'static' make
+ # target, but better, as it doesn't break.
+ use static && append-ldflags -static
+
+ econf ${myconf} || die
+
+ # perform safety checks for NTFS and REISERFS
+ if useq ntfs && egrep -q 'undef HAVE_LIBNTFS\>' "${S}"/config.h ; then
+ die "Failed to find NTFS library."
+ fi
+ if useq reiserfs && egrep -q 'undef HAVE_LIBREISERFS\>' "${S}"/config.h ; then
+ die "Failed to find reiserfs library."
+ fi
+ if useq jpeg && egrep -q 'undef HAVE_LIBJPEG\>' "${S}"/config.h ; then
+ die "Failed to find jpeg library."
+ fi
+
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ [ "$PF" != "$P" ] && mv "${D}"/usr/share/doc/${P} "${D}"/usr/share/doc/${PF}
+}