summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2013-02-10 20:07:33 +0000
committerBenedikt Boehm <hollow@gentoo.org>2013-02-10 20:07:33 +0000
commitff9ef788450f6ee6f480c68a81370e626df33e42 (patch)
tree135908c0e6d8166c32c6c2c6aecfdd84575f3a66 /app-admin
parentversion bump (diff)
downloadgentoo-2-ff9ef788450f6ee6f480c68a81370e626df33e42.tar.gz
gentoo-2-ff9ef788450f6ee6f480c68a81370e626df33e42.tar.bz2
gentoo-2-ff9ef788450f6ee6f480c68a81370e626df33e42.zip
version bump
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/chef-server-api/ChangeLog10
-rw-r--r--app-admin/chef-server-api/chef-server-api-10.20.0.ebuild66
-rw-r--r--app-admin/chef-server-api/files/initd/chef-server-api11
3 files changed, 82 insertions, 5 deletions
diff --git a/app-admin/chef-server-api/ChangeLog b/app-admin/chef-server-api/ChangeLog
index 1396573c42f7..0adc9dd7de01 100644
--- a/app-admin/chef-server-api/ChangeLog
+++ b/app-admin/chef-server-api/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/chef-server-api
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/chef-server-api/ChangeLog,v 1.16 2012/12/27 07:11:41 hollow Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/chef-server-api/ChangeLog,v 1.17 2013/02/10 20:07:33 hollow Exp $
+
+*chef-server-api-10.20.0 (10 Feb 2013)
+
+ 10 Feb 2013; Benedikt Böhm <hollow@gentoo.org>
+ +chef-server-api-10.20.0.ebuild, files/initd/chef-server-api:
+ version bump
*chef-server-api-10.16.4 (27 Dec 2012)
diff --git a/app-admin/chef-server-api/chef-server-api-10.20.0.ebuild b/app-admin/chef-server-api/chef-server-api-10.20.0.ebuild
new file mode 100644
index 000000000000..e2981bf56a0f
--- /dev/null
+++ b/app-admin/chef-server-api/chef-server-api-10.20.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/chef-server-api/chef-server-api-10.20.0.ebuild,v 1.1 2013/02/10 20:07:33 hollow Exp $
+
+EAPI=4
+USE_RUBY="ruby19"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Configuration management tool"
+HOMEPAGE="http://wiki.opscode.com/display/chef"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# specs require root access
+RESTRICT="test"
+
+RDEPEND=">=dev-db/couchdb-0.10.0
+ >=net-misc/rabbitmq-server-1.7.0"
+
+ruby_add_rdepend "~app-admin/chef-${PV}
+ >=dev-ruby/dep_selector-0.0.3
+ >=dev-ruby/merb-assets-1.1.0
+ <dev-ruby/merb-assets-1.2
+ >=dev-ruby/merb-core-1.1.0
+ <dev-ruby/merb-core-1.2
+ >=dev-ruby/merb-helpers-1.1.0
+ <dev-ruby/merb-helpers-1.2
+ >=dev-ruby/merb-param-protection-1.1.0
+ <dev-ruby/merb-param-protection-1.2
+ >=dev-ruby/mixlib-authentication-1.1.3
+ >=dev-ruby/uuidtools-2.1.1
+ <dev-ruby/uuidtools-2.2
+ www-servers/thin"
+
+each_ruby_install() {
+ each_fakegem_install
+ ruby_fakegem_doins -r app
+ ruby_fakegem_doins -r config
+ ruby_fakegem_doins -r public
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doinitd "${FILESDIR}/initd/chef-server-api"
+ doconfd "${FILESDIR}/confd/chef-server-api"
+
+ insinto /etc/chef
+ doins "${FILESDIR}/server.rb"
+}
+
+pkg_postinst() {
+ elog
+ elog "You should edit /etc/chef/server.rb before starting the service with"
+ elog "/etc/init.d/chef-server-api start"
+ elog
+}
diff --git a/app-admin/chef-server-api/files/initd/chef-server-api b/app-admin/chef-server-api/files/initd/chef-server-api
index 297fc6895418..538cfd51bea2 100644
--- a/app-admin/chef-server-api/files/initd/chef-server-api
+++ b/app-admin/chef-server-api/files/initd/chef-server-api
@@ -1,5 +1,5 @@
#!/sbin/runscript
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
depend() {
@@ -16,8 +16,13 @@ CHEF_USER=${CHEF_USER:-chef}
CHEF_GROUP=${CHEF_GROUP:-chef}
start_pre() {
- checkpath -q -d -m 0750 -o ${user}:${group} /etc/chef /var/{lib,log,run}/chef
- checkpath -q -f -m 0600 ${CONFIGFILE}
+ checkpath -q -d -m 0750 -o ${CHEF_USER}:${CHEF_GROUP} \
+ /etc/chef \
+ /etc/chef/certificates \
+ /var/{lib,log,run}/chef
+
+ checkpath -q -f -m 0600 -o ${CHEF_USER}:${CHEF_GROUP} \
+ ${CONFIGFILE}
}
start() {