summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-06-09 23:57:34 +0000
committerTim Harder <radhermit@gentoo.org>2011-06-09 23:57:34 +0000
commitd5554632ae34c835ebfa1a38dceb1d92af7c3811 (patch)
tree0d76f500ca57dea25ae04f169d5688648ea5b46e /app-antivirus
parentVersion bumped, bug #368979. (diff)
downloadgentoo-2-d5554632ae34c835ebfa1a38dceb1d92af7c3811.tar.gz
gentoo-2-d5554632ae34c835ebfa1a38dceb1d92af7c3811.tar.bz2
gentoo-2-d5554632ae34c835ebfa1a38dceb1d92af7c3811.zip
Version bump (bug #370791). Add static-libs USE flag.
(Portage version: 2.2.0_alpha37/cvs/Linux x86_64)
Diffstat (limited to 'app-antivirus')
-rw-r--r--app-antivirus/clamav/ChangeLog7
-rw-r--r--app-antivirus/clamav/clamav-0.97.1.ebuild121
2 files changed, 127 insertions, 1 deletions
diff --git a/app-antivirus/clamav/ChangeLog b/app-antivirus/clamav/ChangeLog
index 348eff5e3985..169f1440e50d 100644
--- a/app-antivirus/clamav/ChangeLog
+++ b/app-antivirus/clamav/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-antivirus/clamav
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.386 2011/03/16 11:47:47 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.387 2011/06/09 23:57:34 radhermit Exp $
+
+*clamav-0.97.1 (09 Jun 2011)
+
+ 09 Jun 2011; Tim Harder <radhermit@gentoo.org> +clamav-0.97.1.ebuild:
+ Version bump (bug #370791). Add static-libs USE flag.
16 Mar 2011; Tomáš Chvátal <scarabeus@gentoo.org> clamav-0.97.ebuild:
Drop virtual definition per bug #358817. Drop glibc check as minimal user can
diff --git a/app-antivirus/clamav/clamav-0.97.1.ebuild b/app-antivirus/clamav/clamav-0.97.1.ebuild
new file mode 100644
index 000000000000..477f2d22c381
--- /dev/null
+++ b/app-antivirus/clamav/clamav-0.97.1.ebuild
@@ -0,0 +1,121 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.97.1.ebuild,v 1.1 2011/06/09 23:57:34 radhermit Exp $
+
+EAPI=4
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="Clam Anti-Virus Scanner"
+HOMEPAGE="http://www.clamav.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="bzip2 clamdtop iconv ipv6 milter selinux static-libs"
+
+CDEPEND="bzip2? ( app-arch/bzip2 )
+ clamdtop? ( sys-libs/ncurses )
+ iconv? ( virtual/libiconv )
+ milter? ( || ( mail-filter/libmilter mail-mta/sendmail ) )
+ >=sys-libs/zlib-1.2.2"
+DEPEND="${CDEPEND}
+ >=dev-util/pkgconfig-0.20"
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-clamav )"
+
+RESTRICT="test"
+
+pkg_setup() {
+ enewgroup clamav
+ enewuser clamav -1 -1 /dev/null clamav
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.97-nls.patch
+}
+
+src_configure() {
+ econf \
+ --disable-experimental \
+ --enable-id-check \
+ --with-dbdir=/var/lib/clamav \
+ $(use_enable bzip2) \
+ $(use_enable clamdtop) \
+ $(use_enable ipv6) \
+ $(use_enable milter) \
+ $(use_enable static-libs static) \
+ $(use_with iconv)
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+ rm -rf "${ED}"/var/lib/clamav
+ dodoc AUTHORS BUGS ChangeLog FAQ INSTALL NEWS README UPGRADE
+ newinitd "${FILESDIR}"/clamd.rc clamd
+ newconfd "${FILESDIR}"/clamd.conf clamd
+
+ keepdir /var/lib/clamav
+ fowners clamav:clamav /var/lib/clamav
+ keepdir /var/run/clamav
+ fowners clamav:clamav /var/run/clamav
+ keepdir /var/log/clamav
+ fowners clamav:clamav /var/log/clamav
+
+ dodir /etc/logrotate.d
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/clamav.logrotate clamav
+
+ use static-libs || find "${ED}" -name '*.la' -exec rm -f '{}' +
+
+ # Modify /etc/{clamd,freshclam}.conf to be usable out of the box
+ sed -i -e "s:^\(Example\):\# \1:" \
+ -e "s:.*\(PidFile\) .*:\1 /var/run/clamav/clamd.pid:" \
+ -e "s:.*\(LocalSocket\) .*:\1 /var/run/clamav/clamd.sock:" \
+ -e "s:.*\(User\) .*:\1 clamav:" \
+ -e "s:^\#\(LogFile\) .*:\1 /var/log/clamav/clamd.log:" \
+ -e "s:^\#\(LogTime\).*:\1 yes:" \
+ -e "s:^\#\(AllowSupplementaryGroups\).*:\1 yes:" \
+ "${ED}"/etc/clamd.conf
+ sed -i -e "s:^\(Example\):\# \1:" \
+ -e "s:.*\(PidFile\) .*:\1 /var/run/clamav/freshclam.pid:" \
+ -e "s:.*\(DatabaseOwner\) .*:\1 clamav:" \
+ -e "s:^\#\(UpdateLogFile\) .*:\1 /var/log/clamav/freshclam.log:" \
+ -e "s:^\#\(NotifyClamd\).*:\1 /etc/clamd.conf:" \
+ -e "s:^\#\(ScriptedUpdates\).*:\1 yes:" \
+ -e "s:^\#\(AllowSupplementaryGroups\).*:\1 yes:" \
+ "${ED}"/etc/freshclam.conf
+
+ if use milter ; then
+ # MilterSocket one to include ' /' because there is a 2nd line for
+ # inet: which we want to leave
+ dodoc "${FILESDIR}"/clamav-milter.README.gentoo
+ sed -i -e "s:^\(Example\):\# \1:" \
+ -e "s:.*\(PidFile\) .*:\1 /var/run/clamav/clamav-milter.pid:" \
+ -e "s+^\#\(ClamdSocket\) .*+\1 unix:/var/run/clamav/clamd.sock+" \
+ -e "s:.*\(User\) .*:\1 clamav:" \
+ -e "s+^\#\(MilterSocket\) /.*+\1 unix:/var/run/clamav/clamav-milter.sock+" \
+ -e "s:^\#\(AllowSupplementaryGroups\).*:\1 yes:" \
+ -e "s:^\#\(LogFile\) .*:\1 /var/log/clamav/clamav-milter.log:" \
+ "${ED}"/etc/clamav-milter.conf
+ cat << EOF >> "${ED}"/etc/conf.d/clamd
+MILTER_NICELEVEL=19
+START_MILTER=no
+EOF
+ fi
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "Since clamav-0.97, signatures are not installed anymore. If you are"
+ ewarn "installing for the first time or upgrading from a version older"
+ ewarn "than clamav-0.97 you must download the newest signatures by"
+ ewarn "executing: /usr/bin/freshclam"
+ ewarn
+
+ if use milter ; then
+ elog "For simple instructions how to setup the clamav-milter read the"
+ elog "clamav-milter.README.gentoo in /usr/share/doc/${PF}"
+ fi
+}