summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2011-08-11 20:59:44 +0000
committerPatrick McLean <chutzpah@gentoo.org>2011-08-11 20:59:44 +0000
commita1b9140d337e1148cd4b45b97b27ea6777a5093c (patch)
tree5db490634ee793a83bdf2adbc4982edeca21373b /app-arch/pxz
parentAdded upstream patch to work around kdelibs focus stealing, bug 375829 (diff)
downloadgentoo-2-a1b9140d337e1148cd4b45b97b27ea6777a5093c.tar.gz
gentoo-2-a1b9140d337e1148cd4b45b97b27ea6777a5093c.tar.bz2
gentoo-2-a1b9140d337e1148cd4b45b97b27ea6777a5093c.zip
New package, a parallelized version of xz.
(Portage version: 2.1.10.10/cvs/Linux x86_64)
Diffstat (limited to 'app-arch/pxz')
-rw-r--r--app-arch/pxz/ChangeLog10
-rw-r--r--app-arch/pxz/metadata.xml17
-rw-r--r--app-arch/pxz/pxz-5.0_pre20110811.ebuild25
3 files changed, 52 insertions, 0 deletions
diff --git a/app-arch/pxz/ChangeLog b/app-arch/pxz/ChangeLog
new file mode 100644
index 000000000000..ef671ced6e50
--- /dev/null
+++ b/app-arch/pxz/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-arch/pxz
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/pxz/ChangeLog,v 1.1 2011/08/11 20:59:44 chutzpah Exp $
+
+*pxz-5.0_pre20110811 (11 Aug 2011)
+
+ 11 Aug 2011; Patrick McLean <chutzpah@gentoo.org>
+ +pxz-5.0_pre20110811.ebuild, +metadata.xml:
+ Initial ebuild.
+
diff --git a/app-arch/pxz/metadata.xml b/app-arch/pxz/metadata.xml
new file mode 100644
index 000000000000..429678842ab3
--- /dev/null
+++ b/app-arch/pxz/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+<email>chutzpah@gentoo.org</email>
+<name>Patrick McLean</name>
+</maintainer>
+<longdescription lang="en">
+Parallel XZ is a compression utility that takes advantage of running LZMA
+compression of different parts of an input file on multiple cores and
+processors simultaneously. Its primary goal is to utilize all resources
+to speed up compression time with minimal possible influence on compression
+ratio.
+</longdescription>
+</pkgmetadata>
+
diff --git a/app-arch/pxz/pxz-5.0_pre20110811.ebuild b/app-arch/pxz/pxz-5.0_pre20110811.ebuild
new file mode 100644
index 000000000000..fec761540e46
--- /dev/null
+++ b/app-arch/pxz/pxz-5.0_pre20110811.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/pxz/pxz-5.0_pre20110811.ebuild,v 1.1 2011/08/11 20:59:44 chutzpah Exp $
+
+EAPI="3"
+
+inherit flag-o-matic
+
+DESCRIPTION="Parallel implementation of the XZ compression utility"
+HOMEPAGE="http://jnovy.fedorapeople.org/pxz/"
+SRC_URI="mirror://gentoo/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+RDEPEND="app-arch/xz-utils"
+DEPEND="${RDEPEND}
+ sys-devel/gcc[openmp]"
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+}