summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStanislav Ochotnicky <sochotnicky@gentoo.org>2010-04-22 20:59:36 +0000
committerStanislav Ochotnicky <sochotnicky@gentoo.org>2010-04-22 20:59:36 +0000
commit86e6fbcf44b35501aa3b849ded877d7733b723f2 (patch)
treeccbb50e60542e9dce5c67d466b876e6ced9f299b /app-arch/rpm
parentFixing manifest wrt bug 316719 (diff)
downloadgentoo-2-86e6fbcf44b35501aa3b849ded877d7733b723f2.tar.gz
gentoo-2-86e6fbcf44b35501aa3b849ded877d7733b723f2.tar.bz2
gentoo-2-86e6fbcf44b35501aa3b849ded877d7733b723f2.zip
Fix configure/build error with certain CFLAGS
db3/configure tried to strip CFLAGS (unsuccesfully) and after doing that it crashed when for example '--param l1-cache-size=64' was used in CFLAGS. Should fix bug #315771 (Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'app-arch/rpm')
-rw-r--r--app-arch/rpm/ChangeLog7
-rw-r--r--app-arch/rpm/files/rpm-4.4.6-fix-cflags-stripping.patch14
-rw-r--r--app-arch/rpm/rpm-4.4.6-r6.ebuild3
-rw-r--r--app-arch/rpm/rpm-4.4.6-r7.ebuild3
4 files changed, 24 insertions, 3 deletions
diff --git a/app-arch/rpm/ChangeLog b/app-arch/rpm/ChangeLog
index ae64ef18161b..728e3c208875 100644
--- a/app-arch/rpm/ChangeLog
+++ b/app-arch/rpm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/rpm
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/ChangeLog,v 1.108 2010/04/15 10:27:53 deathwing00 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/ChangeLog,v 1.109 2010/04/22 20:59:35 sochotnicky Exp $
+
+ 22 Apr 2010; Stanislav Ochotnicky <sochotnicky@gentoo.org>
+ rpm-4.4.6-r6.ebuild, rpm-4.4.6-r7.ebuild,
+ +files/rpm-4.4.6-fix-cflags-stripping.patch:
+ Fix configure/build failure when using certain CFLAGS.
*rpm-4.4.6-r7 (15 Apr 2010)
diff --git a/app-arch/rpm/files/rpm-4.4.6-fix-cflags-stripping.patch b/app-arch/rpm/files/rpm-4.4.6-fix-cflags-stripping.patch
new file mode 100644
index 000000000000..3be0c1fb1513
--- /dev/null
+++ b/app-arch/rpm/files/rpm-4.4.6-fix-cflags-stripping.patch
@@ -0,0 +1,14 @@
+diff --git a/db3/configure b/db3/configure
+index 012b423..2856f20 100755
+--- a/db3/configure
++++ b/db3/configure
+@@ -8,7 +8,7 @@ db_dist="${base_path}../db/dist"
+ rm -f config.cache
+
+ # XXX edit CFLAGS= ... out of invocation args ???
+-ARGS="`echo $* | sed -e 's% [^ ]*CFLAGS=[^ ]*%%' -e 's% -[^-][^ ]*%%g' -e 's% --param=[^ ]*%%g' -e 's%--cache-file=.*$%%'`"
++ARGS="`echo $* | sed -e 's%--param[ =][^ ]*%%g' -e 's% [^ ]*CFLAGS=[^ ]*%%' -e 's% -[^-][^ ]*%%g' -e 's%--cache-file=.*$%%'`"
+
+ CC="$CC" CFLAGS="$CFLAGS" $db_dist/configure $ARGS \
+ --enable-shared --enable-static --enable-rpc \
+
diff --git a/app-arch/rpm/rpm-4.4.6-r6.ebuild b/app-arch/rpm/rpm-4.4.6-r6.ebuild
index 2f09e9773380..40474987c8f2 100644
--- a/app-arch/rpm/rpm-4.4.6-r6.ebuild
+++ b/app-arch/rpm/rpm-4.4.6-r6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/rpm-4.4.6-r6.ebuild,v 1.11 2010/04/04 21:48:31 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/rpm-4.4.6-r6.ebuild,v 1.12 2010/04/22 20:59:35 sochotnicky Exp $
inherit eutils autotools distutils perl-module flag-o-matic
@@ -38,6 +38,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-autotools.patch
epatch "${FILESDIR}"/${P}-buffer-overflow.patch
epatch "${FILESDIR}"/${P}-qa-fix-undefined.patch
+ epatch "${FILESDIR}"/${P}-fix-cflags-stripping.patch
# bug 214799
epatch "${FILESDIR}"/${P}-neon-0.28.patch
diff --git a/app-arch/rpm/rpm-4.4.6-r7.ebuild b/app-arch/rpm/rpm-4.4.6-r7.ebuild
index 55287e9a9741..97b5d9752702 100644
--- a/app-arch/rpm/rpm-4.4.6-r7.ebuild
+++ b/app-arch/rpm/rpm-4.4.6-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/rpm-4.4.6-r7.ebuild,v 1.1 2010/04/15 10:26:11 deathwing00 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/rpm/rpm-4.4.6-r7.ebuild,v 1.2 2010/04/22 20:59:35 sochotnicky Exp $
inherit eutils autotools distutils perl-module flag-o-matic
@@ -38,6 +38,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-autotools.patch
epatch "${FILESDIR}"/${P}-buffer-overflow.patch
epatch "${FILESDIR}"/${P}-qa-fix-undefined.patch
+ epatch "${FILESDIR}"/${P}-fix-cflags-stripping.patch
# bug 214799
epatch "${FILESDIR}"/${P}-neon-0.28.patch