summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-03-17 05:11:21 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-03-17 05:11:21 +0000
commit9fdd357b7c19828efaec6231709aa3e9cbbd657b (patch)
treea4a7f2062320b297c72d0d4a0c139f83dc9e7154 /app-arch/unzip/unzip-5.50-r2.ebuild
parentClean up ;) (Manifest recommit) (diff)
downloadgentoo-2-9fdd357b7c19828efaec6231709aa3e9cbbd657b.tar.gz
gentoo-2-9fdd357b7c19828efaec6231709aa3e9cbbd657b.tar.bz2
gentoo-2-9fdd357b7c19828efaec6231709aa3e9cbbd657b.zip
tighten DEPEND (bug #44817); sed in src_unpack, not src_compile; use emake
Diffstat (limited to 'app-arch/unzip/unzip-5.50-r2.ebuild')
-rw-r--r--app-arch/unzip/unzip-5.50-r2.ebuild20
1 files changed, 12 insertions, 8 deletions
diff --git a/app-arch/unzip/unzip-5.50-r2.ebuild b/app-arch/unzip/unzip-5.50-r2.ebuild
index 3a665a5fef8f..9eaab9293f62 100644
--- a/app-arch/unzip/unzip-5.50-r2.ebuild
+++ b/app-arch/unzip/unzip-5.50-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/unzip/unzip-5.50-r2.ebuild,v 1.8 2004/03/14 19:28:42 tgall Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unzip/unzip-5.50-r2.ebuild,v 1.9 2004/03/17 05:11:21 mr_bones_ Exp $
inherit eutils
@@ -12,29 +12,33 @@ LICENSE="Info-ZIP"
SLOT="0"
KEYWORDS="x86 ppc alpha hppa mips amd64 ia64 sparc ppc64"
-DEPEND="virtual/glibc
+RDEPEND="virtual/glibc"
+DEPEND="${RDEPEND}
>=sys-apps/sed-4"
src_unpack() {
unpack ${A} ; cd ${S}
epatch ${FILESDIR}/${P}-dotdot.patch
-}
-src_compile() {
- sed -i -e "s:-O3:${CFLAGS}:" \
+ sed -i \
+ -e "s:-O3:${CFLAGS}:" \
-e "s:CC=gcc LD=gcc:CC=${CC:-gcc} LD=${CC:-gcc}:" \
- -e "s:-O :${CFLAGS} :" unix/Makefile
+ -e "s:-O :${CFLAGS} :" unix/Makefile \
+ || die "sed unix/Makefile failed"
+}
+
+src_compile() {
use x86 \
&& TARGET=linux \
|| TARGET=linux_noasm
- make -f unix/Makefile ${TARGET} || die
+ emake -f unix/Makefile ${TARGET} || die "emake failed"
}
src_install() {
- dobin unzip funzip unzipsfx unix/zipgrep
+ dobin unzip funzip unzipsfx unix/zipgrep || die "dobin failed"
dosym /usr/bin/unzip /usr/bin/zipinfo
doman man/*.1
dodoc BUGS COPYING.OLD History* LICENSE README ToDo WHERE