summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-10-14 07:43:22 +0000
committerMichał Górny <mgorny@gentoo.org>2012-10-14 07:43:22 +0000
commit3d0dc7ed161ed5e4d0b67829834a1a59a5fdbf4b (patch)
tree769f87135cbbeefc65c262ae1f2e19faf1ec4b43 /app-arch
parentVersion bump. (diff)
downloadgentoo-2-3d0dc7ed161ed5e4d0b67829834a1a59a5fdbf4b.tar.gz
gentoo-2-3d0dc7ed161ed5e4d0b67829834a1a59a5fdbf4b.tar.bz2
gentoo-2-3d0dc7ed161ed5e4d0b67829834a1a59a5fdbf4b.zip
Version bump, now with journaling & deduplicating.
(Portage version: 2.2.0_alpha137_p1/cvs/Linux x86_64)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/zpaq/ChangeLog8
-rw-r--r--app-arch/zpaq/zpaq-6.10.ebuild45
2 files changed, 51 insertions, 2 deletions
diff --git a/app-arch/zpaq/ChangeLog b/app-arch/zpaq/ChangeLog
index 8d058f8f8ec7..339f9ed8a70b 100644
--- a/app-arch/zpaq/ChangeLog
+++ b/app-arch/zpaq/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/zpaq
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/zpaq/ChangeLog,v 1.9 2012/05/24 04:35:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/zpaq/ChangeLog,v 1.10 2012/10/14 07:43:22 mgorny Exp $
+
+*zpaq-6.10 (14 Oct 2012)
+
+ 14 Oct 2012; Michał Górny <mgorny@gentoo.org> +zpaq-6.10.ebuild:
+ Version bump, now with journaling & deduplicating.
24 May 2012; Mike Frysinger <vapier@gentoo.org> zpaq-2.05.ebuild,
zpaq-3.01.ebuild, zpaq-4.04.ebuild:
@@ -52,4 +57,3 @@
Importing zpaq archiver from Sunrise as per bug #278021. The ebuild was
updated to install latest libzpaq & zpaq. It also patches in an
autotools-based build system to avoid build difficulties.
-
diff --git a/app-arch/zpaq/zpaq-6.10.ebuild b/app-arch/zpaq/zpaq-6.10.ebuild
new file mode 100644
index 000000000000..cd621973017a
--- /dev/null
+++ b/app-arch/zpaq/zpaq-6.10.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/zpaq/zpaq-6.10.ebuild,v 1.1 2012/10/14 07:43:22 mgorny Exp $
+
+EAPI=3
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils eutils
+
+MY_P=${PN}${PV/./}
+DESCRIPTION="Journaling incremental deduplicating archiving compressor"
+HOMEPAGE="http://mattmahoney.net/dc/zpaq.html"
+SRC_URI="http://mattmahoney.net/dc/${MY_P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="=app-arch/libzpaq-6*
+ dev-libs/libdivsufsort"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_prepare() {
+ EPATCH_OPTS+=-p1 epatch "${FILESDIR}"/${PN}-4-autotools.patch
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ # man-page is no longer there
+ ac_cv_prog_POD2MAN=
+ )
+
+ autotools-utils_src_configure
+}
+
+pkg_postinst() {
+ elog "You may also want to install app-arch/zpaq-extras package which provides"
+ elog "few additional configs and preprocessors for use with zpaq."
+}