summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Yao <ryao@gentoo.org>2014-07-31 17:41:30 +0000
committerRichard Yao <ryao@gentoo.org>2014-07-31 17:41:30 +0000
commit63b47e7945f1a17e1b90291d078b0070e21b47f5 (patch)
tree643b767753d4fa3fb1d5e1080e76c1dce00cabdd /app-arch
parentDisable wireshark dissector support to fix automagic dependency and resulting... (diff)
downloadgentoo-2-63b47e7945f1a17e1b90291d078b0070e21b47f5.tar.gz
gentoo-2-63b47e7945f1a17e1b90291d078b0070e21b47f5.tar.bz2
gentoo-2-63b47e7945f1a17e1b90291d078b0070e21b47f5.zip
Bump to upstream r120; Keywords on alpha, hppa and ia64 are dropped because valgrind is unavailable on those architectures; We now pull from github, so future updates will be easier
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xBEE84C64)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/lz4/ChangeLog9
-rw-r--r--app-arch/lz4/lz4-0_p120.ebuild46
2 files changed, 54 insertions, 1 deletions
diff --git a/app-arch/lz4/ChangeLog b/app-arch/lz4/ChangeLog
index 90b0198bc4a0..b4db2369ecc6 100644
--- a/app-arch/lz4/ChangeLog
+++ b/app-arch/lz4/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-arch/lz4
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/lz4/ChangeLog,v 1.23 2014/07/24 21:19:18 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lz4/ChangeLog,v 1.24 2014/07/31 17:41:30 ryao Exp $
+
+*lz4-0_p120 (31 Jul 2014)
+
+ 31 Jul 2014; Richard Yao <ryao@gentoo.org> +lz4-0_p120.ebuild:
+ Bump to upstream r120; Keywords on alpha, hppa and ia64 are dropped because
+ valgrind is unavailable on those architectures; We now pull from github, so
+ future updates will be easier
24 Jul 2014; Michał Górny <mgorny@gentoo.org> lz4-9999.ebuild:
Use the development branch. Switch back to plain Makefile which is better
diff --git a/app-arch/lz4/lz4-0_p120.ebuild b/app-arch/lz4/lz4-0_p120.ebuild
new file mode 100644
index 000000000000..00cb57857fb1
--- /dev/null
+++ b/app-arch/lz4/lz4-0_p120.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lz4/lz4-0_p120.ebuild,v 1.1 2014/07/31 17:41:30 ryao Exp $
+
+EAPI=5
+
+inherit multilib multilib-minimal
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Cyan4973/lz4.git"
+ EGIT_BRANCH=dev
+else
+ MY_PV="r${PV##0_p}"
+ MY_P="${PN}-${MY_PV}"
+ SRC_URI="https://github.com/Cyan4973/lz4/archive/${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~mips ~s390 ~x86 ~amd64-linux ~x86-linux"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="Extremely Fast Compression algorithm"
+HOMEPAGE="https://code.google.com/p/lz4/"
+
+LICENSE="BSD-2 GPL-2"
+SLOT="0"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="test? ( dev-util/valgrind )"
+
+src_prepare() {
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ # we must not use the 'all' target since it builds test programs
+ # & extra -m32 executables
+ emake
+ emake -C programs
+}
+
+multilib_src_install() {
+ emake install DESTDIR="${D}" \
+ PREFIX="${EPREFIX}/usr" \
+ LIBDIR="${EPREFIX}"/usr/$(get_libdir)
+}