summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-02-22 04:10:06 +0000
committerMike Frysinger <vapier@gentoo.org>2008-02-22 04:10:06 +0000
commit874263c0deee47007f3f4e505b5ec786c112e1f8 (patch)
tree4bbfb80bf7657d89875b78855dba074c3d4bef0a /app-arch
parentfix descriptions (diff)
downloadgentoo-2-874263c0deee47007f3f4e505b5ec786c112e1f8.tar.gz
gentoo-2-874263c0deee47007f3f4e505b5ec786c112e1f8.tar.bz2
gentoo-2-874263c0deee47007f3f4e505b5ec786c112e1f8.zip
Version bump #210980 and fix when testing when dpkg is not already installed #210997 by nixnut.
(Portage version: 2.2_pre2)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/dpkg/ChangeLog10
-rw-r--r--app-arch/dpkg/dpkg-1.14.12.ebuild3
-rw-r--r--app-arch/dpkg/dpkg-1.14.16.4.ebuild3
-rw-r--r--app-arch/dpkg/dpkg-1.14.16.6.ebuild47
-rw-r--r--app-arch/dpkg/files/dpkg-1.14.16.6-check-PATH.patch13
5 files changed, 73 insertions, 3 deletions
diff --git a/app-arch/dpkg/ChangeLog b/app-arch/dpkg/ChangeLog
index f14f4f1ddb35..11e996110db8 100644
--- a/app-arch/dpkg/ChangeLog
+++ b/app-arch/dpkg/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-arch/dpkg
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/ChangeLog,v 1.55 2008/02/04 20:41:37 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/ChangeLog,v 1.56 2008/02/22 04:10:05 vapier Exp $
+
+*dpkg-1.14.16.6 (22 Feb 2008)
+
+ 22 Feb 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/dpkg-1.14.16.6-check-PATH.patch, dpkg-1.14.12.ebuild,
+ dpkg-1.14.16.4.ebuild, +dpkg-1.14.16.6.ebuild:
+ Version bump #210980 and fix when testing when dpkg is not already installed
+ #210997 by nixnut.
04 Feb 2008; Jeroen Roovers <jer@gentoo.org> dpkg-1.14.12.ebuild:
Stable for HPPA too.
diff --git a/app-arch/dpkg/dpkg-1.14.12.ebuild b/app-arch/dpkg/dpkg-1.14.12.ebuild
index 994e1b15c9e1..954d0e4066c3 100644
--- a/app-arch/dpkg/dpkg-1.14.12.ebuild
+++ b/app-arch/dpkg/dpkg-1.14.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.14.12.ebuild,v 1.5 2008/02/04 20:41:37 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.14.12.ebuild,v 1.6 2008/02/22 04:10:05 vapier Exp $
inherit eutils multilib
@@ -24,6 +24,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}-nls.patch #192819
+ epatch "${FILESDIR}"/${PN}-1.14.16.6-check-PATH.patch #210997
}
src_compile() {
diff --git a/app-arch/dpkg/dpkg-1.14.16.4.ebuild b/app-arch/dpkg/dpkg-1.14.16.4.ebuild
index 3c8034d9f8c2..a399957db867 100644
--- a/app-arch/dpkg/dpkg-1.14.16.4.ebuild
+++ b/app-arch/dpkg/dpkg-1.14.16.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.14.16.4.ebuild,v 1.1 2008/01/26 06:47:29 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.14.16.4.ebuild,v 1.2 2008/02/22 04:10:05 vapier Exp $
inherit eutils multilib
@@ -24,6 +24,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${PN}-1.14.12-nls.patch #192819
+ epatch "${FILESDIR}"/${PN}-1.14.16.6-check-PATH.patch #210997
}
src_compile() {
diff --git a/app-arch/dpkg/dpkg-1.14.16.6.ebuild b/app-arch/dpkg/dpkg-1.14.16.6.ebuild
new file mode 100644
index 000000000000..f5ad0688a333
--- /dev/null
+++ b/app-arch/dpkg/dpkg-1.14.16.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.14.16.6.ebuild,v 1.1 2008/02/22 04:10:05 vapier Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="Package maintenance system for Debian"
+HOMEPAGE="http://packages.qa.debian.org/dpkg"
+SRC_URI="mirror://debian/pool/main/d/dpkg/${P/-/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~s390 ~sh ~sparc ~x86"
+IUSE="bzip2 nls selinux zlib"
+
+RDEPEND=">=dev-lang/perl-5.6.0
+ >=sys-libs/ncurses-5.2-r7
+ zlib? ( >=sys-libs/zlib-1.1.4 )
+ bzip2? ( app-arch/bzip2 )"
+DEPEND="${RDEPEND}
+ nls? ( app-text/po4a )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.14.12-nls.patch #192819
+ epatch "${FILESDIR}"/${PN}-1.14.16.6-check-PATH.patch #210997
+}
+
+src_compile() {
+ econf \
+ $(use_with bzip2 bz2lib) \
+ $(use_enable nls) \
+ $(use_with selinux) \
+ $(use_with zlib) \
+ || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ rm "${D}"/usr/sbin/{install-info,start-stop-daemon}
+ rm "${D}"/usr/share/man/man?/{install-info,start-stop-daemon}.?
+ dodoc ChangeLog INSTALL THANKS TODO
+ keepdir /usr/$(get_libdir)/db/methods/{mnt,floppy,disk}
+ keepdir /usr/$(get_libdir)/db/{alternatives,info,methods,parts,updates}
+}
diff --git a/app-arch/dpkg/files/dpkg-1.14.16.6-check-PATH.patch b/app-arch/dpkg/files/dpkg-1.14.16.6-check-PATH.patch
new file mode 100644
index 000000000000..5af5a42758a5
--- /dev/null
+++ b/app-arch/dpkg/files/dpkg-1.14.16.6-check-PATH.patch
@@ -0,0 +1,13 @@
+http://bugs.gentoo.org/210997
+
+--- scripts/Makefile.in
++++ scripts/Makefile.in
+@@ -760,7 +760,7 @@
+ # a bit hacky...
+ $(mkdir_p) t.tmp
+ cp -dRl $(srcdir)/t/200_Dpkg_Shlibs/ld.so.conf* t.tmp/
+- srcdir=$(srcdir) PERL5LIB=$(srcdir) PERL_DL_NONLAZY=1 $(PERL) -I$(srcdir) "-MExtUtils::Command::MM" "-e" "test_harness($(TEST_VERBOSE), '.')" $(TEST_FILES)
++ PATH="$(top_builddir)/src:$(PATH)" srcdir=$(srcdir) PERL5LIB=$(srcdir) PERL_DL_NONLAZY=1 $(PERL) -I$(srcdir) "-MExtUtils::Command::MM" "-e" "test_harness($(TEST_VERBOSE), '.')" $(TEST_FILES)
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+ .NOEXPORT: