summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2011-08-14 23:35:13 +0000
committerMatt Turner <mattst88@gentoo.org>2011-08-14 23:35:13 +0000
commit9efde12547fd4e084b133f769a7b0c6b7610556f (patch)
tree1ccf00f2a34afe990a009d58d065839ce5603bf2 /app-arch
parentdrop amd64 (bug #375497) (diff)
downloadgentoo-2-9efde12547fd4e084b133f769a7b0c6b7610556f.tar.gz
gentoo-2-9efde12547fd4e084b133f769a7b0c6b7610556f.tar.bz2
gentoo-2-9efde12547fd4e084b133f769a7b0c6b7610556f.zip
Don't use lfs.sh from test.sh. Should help BSD.
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/lbzip2/ChangeLog6
-rw-r--r--app-arch/lbzip2/files/0.23-test.sh.patch19
-rw-r--r--app-arch/lbzip2/lbzip2-0.23-r2.ebuild3
3 files changed, 26 insertions, 2 deletions
diff --git a/app-arch/lbzip2/ChangeLog b/app-arch/lbzip2/ChangeLog
index bcd75af1c60b..d97b78dacbfe 100644
--- a/app-arch/lbzip2/ChangeLog
+++ b/app-arch/lbzip2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-arch/lbzip2
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/lbzip2/ChangeLog,v 1.16 2011/08/06 19:19:45 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lbzip2/ChangeLog,v 1.17 2011/08/14 23:35:13 mattst88 Exp $
+
+ 14 Aug 2011; Matt Turner <mattst88@gentoo.org> +files/0.23-test.sh.patch,
+ lbzip2-0.23-r2.ebuild:
+ Don't use lfs.sh from test.sh. Should help BSD.
*lbzip2-0.23-r2 (06 Aug 2011)
diff --git a/app-arch/lbzip2/files/0.23-test.sh.patch b/app-arch/lbzip2/files/0.23-test.sh.patch
new file mode 100644
index 000000000000..f6ed68a4e1ad
--- /dev/null
+++ b/app-arch/lbzip2/files/0.23-test.sh.patch
@@ -0,0 +1,19 @@
+Only in lbzip2: .lfs.sh.swp
+diff -u lbzip2.orig//test.sh lbzip2/test.sh
+--- lbzip2.orig//test.sh 2009-11-26 22:38:44.000000000 -0500
++++ lbzip2/test.sh 2011-08-14 19:28:31.746454047 -0400
+@@ -99,12 +99,8 @@
+ }
+ EOT
+
+- T_CFLAGS="$(set CFLAGS; set +e; . "$OLDPWD"/lfs.sh)"
+- T_LDFLAGS="$(set LDFLAGS; set +e; . "$OLDPWD"/lfs.sh)"
+- T_LIBS="$(set LIBS; set +e; . "$OLDPWD"/lfs.sh)"
+-
+- $C_CC1 $T_CFLAGS -D _XOPEN_SOURCE=500 $C_CC2 -o scratch/nullfmt -s \
+- $T_LDFLAGS scratch/nullfmt.c $T_LIBS
++ $C_CC1 $CFLAGS $C_CC2 -o scratch/nullfmt -s \
++ $LDFLAGS scratch/nullfmt.c $LIBS
+ C_NULLFMT="$(scratch/nullfmt)"
+ fi
+ readonly C_NULLFMT
diff --git a/app-arch/lbzip2/lbzip2-0.23-r2.ebuild b/app-arch/lbzip2/lbzip2-0.23-r2.ebuild
index 8836d20c458c..ea3f51cb17ca 100644
--- a/app-arch/lbzip2/lbzip2-0.23-r2.ebuild
+++ b/app-arch/lbzip2/lbzip2-0.23-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/lbzip2/lbzip2-0.23-r2.ebuild,v 1.1 2011/08/06 19:19:45 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lbzip2/lbzip2-0.23-r2.ebuild,v 1.2 2011/08/14 23:35:13 mattst88 Exp $
EAPI="3"
@@ -28,6 +28,7 @@ S=${WORKDIR}/${PN}
src_prepare() {
epatch "${FILESDIR}"/${PV}-s_isreg.patch
epatch "${FILESDIR}"/0.23-Makefile.patch
+ epatch "${FILESDIR}"/0.23-test.sh.patch
}
src_compile() {