summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-07-27 13:21:54 +0000
committerJeroen Roovers <jer@gentoo.org>2013-07-27 13:21:54 +0000
commitc5114579b3271a192fec8ecde634d17fcc87115c (patch)
tree076bebab5a3bfcaaa764912b76ade6f8d1bd2695 /app-arch
parentFix maximized windows jumping to a different monitor (#470248#c37 by kisak42) (diff)
downloadgentoo-2-c5114579b3271a192fec8ecde634d17fcc87115c.tar.gz
gentoo-2-c5114579b3271a192fec8ecde634d17fcc87115c.tar.bz2
gentoo-2-c5114579b3271a192fec8ecde634d17fcc87115c.zip
Version bump.
(Portage version: 2.2.0_alpha190/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/dpkg/ChangeLog8
-rw-r--r--app-arch/dpkg/dpkg-1.17.0.ebuild95
-rw-r--r--app-arch/dpkg/files/dpkg-1.17.0-gzip-rsyncable.patch11
-rw-r--r--app-arch/dpkg/metadata.xml1
4 files changed, 114 insertions, 1 deletions
diff --git a/app-arch/dpkg/ChangeLog b/app-arch/dpkg/ChangeLog
index 65709a12cc2c..ebc1e9f8f261 100644
--- a/app-arch/dpkg/ChangeLog
+++ b/app-arch/dpkg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/dpkg
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/ChangeLog,v 1.230 2013/07/02 07:41:42 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/ChangeLog,v 1.231 2013/07/27 13:21:53 jer Exp $
+
+*dpkg-1.17.0 (27 Jul 2013)
+
+ 27 Jul 2013; Jeroen Roovers <jer@gentoo.org> +dpkg-1.17.0.ebuild,
+ +files/dpkg-1.17.0-gzip-rsyncable.patch, metadata.xml:
+ Version bump.
02 Jul 2013; Agostino Sarubbo <ago@gentoo.org> dpkg-1.16.10.ebuild:
Stable for sh, wrt bug #473840
diff --git a/app-arch/dpkg/dpkg-1.17.0.ebuild b/app-arch/dpkg/dpkg-1.17.0.ebuild
new file mode 100644
index 000000000000..f9ac76d5c40b
--- /dev/null
+++ b/app-arch/dpkg/dpkg-1.17.0.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/dpkg/dpkg-1.17.0.ebuild,v 1.1 2013/07/27 13:21:53 jer Exp $
+
+EAPI=5
+inherit eutils multilib autotools toolchain-funcs
+
+DESCRIPTION="Package maintenance system for Debian"
+HOMEPAGE="http://packages.qa.debian.org/dpkg"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
+IUSE="+bzip2 dselect +lzma nls test unicode +update-alternatives +zlib"
+REQUIRED_USE="dselect? ( nls )"
+
+RDEPEND="
+ >=dev-lang/perl-5.6.0
+ dev-perl/TimeDate
+ >=sys-libs/ncurses-5.2-r7
+ lzma? ( app-arch/xz-utils )
+ zlib? ( >=sys-libs/zlib-1.1.4 )
+ bzip2? ( app-arch/bzip2 )
+"
+DEPEND="
+ ${RDEPEND}
+ app-arch/xz-utils
+ sys-devel/flex
+ virtual/pkgconfig
+ nls? (
+ app-text/po4a
+ sys-devel/gettext
+ )
+ test? (
+ dev-perl/DateTime-Format-DateParse
+ dev-perl/IO-String
+ dev-perl/Test-Pod
+ )
+"
+
+DOCS=( ChangeLog THANKS TODO )
+
+src_prepare() {
+ # do not expect Debian's gzip --rsyncable extension
+ epatch "${FILESDIR}"/${PN}-1.17.0-gzip-rsyncable.patch
+
+ # Force the use of the running bash for get-version (this file is never
+ # installed, so no need to worry about hardcoding a temporary bash)
+ sed -i -e '1c\#!'"${BASH}" get-version || die
+
+ # this test depends on a Debian only gzip extension that adds --rsyncable
+ # which will therefore always fail on Gentoo. (bug #310847).
+ sed -i scripts/Makefile.am \
+ -e '/850_Dpkg_Compression.t/d' \
+ || die "sed failed"
+
+ # test fails (bug #414095)
+ sed -i utils/Makefile.am \
+ -e '/^test_cases/d;/100_update_alternatives/d' || die
+
+ use nls && strip-linguas -i po
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+ econf \
+ $(use_enable dselect) \
+ $(use_enable nls) \
+ $(use_enable unicode) \
+ $(use_enable update-alternatives) \
+ $(use_with bzip2 bz2) \
+ $(use_with zlib) \
+ $(use_with lzma liblzma) \
+ --disable-compiler-optimisations \
+ --disable-compiler-warnings \
+ --disable-linker-optimisations \
+ --disable-silent-rules \
+ --disable-start-stop-daemon \
+ --localstatedir="${EPREFIX}"/var \
+ --without-selinux
+}
+
+src_compile() {
+ emake AR=$(tc-getAR)
+}
+
+src_install() {
+ default
+
+ keepdir /usr/$(get_libdir)/db/methods/{mnt,floppy,disk}
+ keepdir /usr/$(get_libdir)/db/{alternatives,info,methods,parts,updates}
+}
diff --git a/app-arch/dpkg/files/dpkg-1.17.0-gzip-rsyncable.patch b/app-arch/dpkg/files/dpkg-1.17.0-gzip-rsyncable.patch
new file mode 100644
index 000000000000..f956ca590ce7
--- /dev/null
+++ b/app-arch/dpkg/files/dpkg-1.17.0-gzip-rsyncable.patch
@@ -0,0 +1,11 @@
+--- a/scripts/Dpkg/Compression.pm
++++ b/scripts/Dpkg/Compression.pm
+@@ -52,7 +52,7 @@
+ my $COMP = {
+ gzip => {
+ file_ext => 'gz',
+- comp_prog => [ 'gzip', '--no-name', '--rsyncable' ],
++ comp_prog => [ 'gzip', '--no-name' ],
+ decomp_prog => [ 'gunzip' ],
+ default_level => 9,
+ },
diff --git a/app-arch/dpkg/metadata.xml b/app-arch/dpkg/metadata.xml
index 7ac2656a4029..e096f0b5b8b4 100644
--- a/app-arch/dpkg/metadata.xml
+++ b/app-arch/dpkg/metadata.xml
@@ -4,5 +4,6 @@
<herd>deb-tools</herd>
<use>
<flag name="dselect">Build the dselect package-management frontend</flag>
+<flag name="update-alternatives">Install update-alternatives</flag>
</use>
</pkgmetadata>