summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-10-09 09:23:15 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-10-09 09:23:15 +0000
commit211c989efff7608c868cc33a6cd5787d897f4281 (patch)
treedc01da3125725c2bd8919b582692284471384b0a /app-backup/amanda/amanda-2.5.1_p3-r1.ebuild
parentDrop old ebuilds. (diff)
downloadgentoo-2-211c989efff7608c868cc33a6cd5787d897f4281.tar.gz
gentoo-2-211c989efff7608c868cc33a6cd5787d897f4281.tar.bz2
gentoo-2-211c989efff7608c868cc33a6cd5787d897f4281.zip
Fix quoting in all ebuilds.
(Portage version: 2.1.3.12)
Diffstat (limited to 'app-backup/amanda/amanda-2.5.1_p3-r1.ebuild')
-rw-r--r--app-backup/amanda/amanda-2.5.1_p3-r1.ebuild82
1 files changed, 42 insertions, 40 deletions
diff --git a/app-backup/amanda/amanda-2.5.1_p3-r1.ebuild b/app-backup/amanda/amanda-2.5.1_p3-r1.ebuild
index b52025e15a87..e43014345ae3 100644
--- a/app-backup/amanda/amanda-2.5.1_p3-r1.ebuild
+++ b/app-backup/amanda/amanda-2.5.1_p3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/amanda/amanda-2.5.1_p3-r1.ebuild,v 1.4 2007/07/15 04:23:35 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/amanda/amanda-2.5.1_p3-r1.ebuild,v 1.5 2007/10/09 09:23:15 robbat2 Exp $
inherit eutils
@@ -134,7 +134,7 @@ src_compile() {
[ ! -f "${TMPENVFILE}" ] && die "Variable setting file (${TMPENVFILE}) should exist!"
source "${TMPENVFILE}"
local myconf
- cd ${S}
+ cd "${S}"
einfo "Using '${AMANDA_DBMODE}' style database"
myconf="${myconf} --with-db=${AMANDA_DBMODE}"
@@ -208,11 +208,11 @@ src_install() {
source ${TMPENVFILE}
einfo "Doing stock install"
- make DESTDIR=${D} install || die
+ emake -j1 DESTDIR="${D}" install || die
# Prepare our custom files
einfo "Building custom configuration files"
- cp ${FILESDIR}/amanda-* ${MYFILESDIR}
+ cp "${FILESDIR}"/amanda-* "${MYFILESDIR}"
local i # our iterator
local sedexpr # var for sed expr
sedexpr=''
@@ -226,19 +226,21 @@ src_install() {
# now apply the sed expr
for i in "${FILESDIR}"/amanda-* ; do
local filename
- filename=`basename ${i}`
+ filename="`basename ${i}`"
#einfo "Applying compiled SED expression to ${filename}"
- sed -re "${sedexpr}" <${i} >"${MYFILESDIR}/${filename}"
+ sed -re "${sedexpr}" <"${i}" >"${MYFILESDIR}"/${filename}
done
# Build the envdir file
# Don't forget this..
einfo "Building environment file"
- echo "# These settings are what was present in the environment when this" >>${MYFILESDIR}/${ENVDFILE}
- echo "# Amanda was compiled. Changing anything below this comment will" >>${MYFILESDIR}/${ENVDFILE}
- echo "# have no effect on your application, but it merely exists to" >>${MYFILESDIR}/${ENVDFILE}
- echo "# preserve them for your next emerge of Amanda" >>${MYFILESDIR}/${ENVDFILE}
- cat ${TMPENVFILE} | sed "s,=\$,='',g" >>${MYFILESDIR}/${ENVDFILE}
+ local t
+ t="${MYFILESDIR}"/${ENVDFILE}
+ echo "# These settings are what was present in the environment when this" >>"${t}"
+ echo "# Amanda was compiled. Changing anything below this comment will" >>"${t}"
+ echo "# have no effect on your application, but it merely exists to" >>"${t}"
+ echo "# preserve them for your next emerge of Amanda" >>"${t}"
+ cat "${TMPENVFILE}" | sed "s,=\$,='',g" >>"${t}"
into /usr
@@ -251,35 +253,35 @@ src_install() {
dodoc AUTHORS C* INSTALL NEWS README
# Clean up some bits
dodoc /usr/share/amanda/*
- rm -rf ${D}/usr/share/amanda
- mkdir -p ${D}/${MYINSTTMPDIR} || die
- cp ${TMPENVFILE} "${D}/${TMPINSTENVFILE}" || die
+ rm -rf "${D}"/usr/share/amanda
+ mkdir -p "${D}"/${MYINSTTMPDIR} || die
+ cp "${TMPENVFILE}" "${D}"/${TMPINSTENVFILE} || die
# our inetd sample
einfo "Installing standard inetd sample"
- newdoc ${MYFILESDIR}/amanda-inetd.amanda.sample-2.5.1_p3-r1 amanda-inetd.amanda.sample
+ newdoc "${MYFILESDIR}"/amanda-inetd.amanda.sample-2.5.1_p3-r1 amanda-inetd.amanda.sample
# Stock extra docs
docinto docs
- dodoc ${S}/docs/*
+ dodoc "${S}"/docs/*
# Labels
einfo "Installing labels"
docinto labels
- dodoc ${S}/example/3hole.ps
- dodoc ${S}/example/8.5x11.ps
- dodoc ${S}/example/DIN-A4.ps
- dodoc ${S}/example/DLT.ps
- dodoc ${S}/example/EXB-8500.ps
- dodoc ${S}/example/HP-DAT.ps
+ dodoc "${S}"/example/3hole.ps
+ dodoc "${S}"/example/8.5x11.ps
+ dodoc "${S}"/example/DIN-A4.ps
+ dodoc "${S}"/example/DLT.ps
+ dodoc "${S}"/example/EXB-8500.ps
+ dodoc "${S}"/example/HP-DAT.ps
# Amanda example configs
einfo "Installing example configurations"
docinto example
- dodoc ${S}/example/*
+ dodoc "${S}"/example/*
docinto example1
- newdoc ${FILESDIR}/example_amanda.conf amanda.conf
- newdoc ${FILESDIR}/example_disklist-2.5.1_p3-r1 disklist
- newdoc ${FILESDIR}/example_global.conf global.conf
+ newdoc "${FILESDIR}"/example_amanda.conf amanda.conf
+ newdoc "${FILESDIR}"/example_disklist-2.5.1_p3-r1 disklist
+ newdoc "${FILESDIR}"/example_global.conf global.conf
docinto example2
- newdoc ${S}/example/amanda.conf amanda.conf
- newdoc ${S}/example/disklist disklist
+ newdoc "${S}"/example/amanda.conf amanda.conf
+ newdoc "${S}"/example/disklist disklist
# Compress it all
prepalldocs
@@ -289,19 +291,19 @@ src_install() {
insinto /etc/amanda
einfo "Installing .amandahosts File for ${AMANDA_USER_NAME} user"
- cat ${FILESDIR}/amanda-amandahosts-client-2.5.1_p3-r1 >>${D}/etc/amanda/amandahosts
+ cat "${FILESDIR}"/amanda-amandahosts-client-2.5.1_p3-r1 >>"${D}"/etc/amanda/amandahosts
use minimal \
- || cat ${FILESDIR}/amanda-amandahosts-server2.5.1_p3-r1 >>${D}/etc/amanda/amandahosts
+ || cat "${FILESDIR}"/amanda-amandahosts-server2.5.1_p3-r1 >>"${D}"/etc/amanda/amandahosts
dosym /etc/amanda/amandahosts ${AMANDA_USER_HOMEDIR}/.amandahosts
insinto ${AMANDA_USER_HOMEDIR}
einfo "Installing .profile for ${AMANDA_USER_NAME} user"
- newins ${MYFILESDIR}/amanda-profile .profile
+ newins "${MYFILESDIR}"/amanda-profile .profile
einfo "Installing Sample Daily Cron Job for Amanda"
CRONDIR=/etc/cron.daily/
exeinto ${CRONDIR}
- newexe ${MYFILESDIR}/amanda-cron amanda
+ newexe "${MYFILESDIR}"/amanda-cron amanda
# Not excetuable by default
fperms 644 ${CRONDIR}/amanda
@@ -321,32 +323,32 @@ src_install() {
# DevFS
einfo "Installing DevFS config file"
insinto /etc/devfs.d
- newins ${MYFILESDIR}/amanda-devfs amanda
+ newins "${MYFILESDIR}"/amanda-devfs amanda
# Env.d
einfo "Installing environment config file"
- doenvd ${MYFILESDIR}/${ENVDFILE}
+ doenvd "${MYFILESDIR}"/${ENVDFILE}
# Installing Amanda Xinetd Services Definition
einfo "Installing xinetd service file"
insinto /etc/xinetd.d
- newins ${MYFILESDIR}/amanda-xinetd-2.5.1_p3-r1 amanda
+ newins "${MYFILESDIR}"/amanda-xinetd-2.5.1_p3-r1 amanda
}
pkg_postinst() {
- local aux="${ROOT}/${TMPINSTENVFILE}"
+ local aux="${ROOT}"/${TMPINSTENVFILE}
[ ! -f "${aux}" ] && die "Variable setting file (${aux}) should exist!"
source "${aux}"
rm "${aux}"
- rmdir ${ROOT}/${MYINSTTMPDIR} 2>/dev/null # ignore error
+ rmdir "${ROOT}"/${MYINSTTMPDIR} 2>/dev/null # ignore error
local i
for i in amandates dumpdates; do
einfo "Creating inital Amanda file (${i})"
- touch ${ROOT}/etc/${i}
- chown ${AMANDA_USER_NAME}:${AMANDA_GROUP_NAME} ${ROOT}/etc/${i}
- chmod 600 ${ROOT}/etc/${i}
+ touch "${ROOT}"/etc/${i}
+ chown ${AMANDA_USER_NAME}:${AMANDA_GROUP_NAME} "${ROOT}"/etc/${i}
+ chmod 600 "${ROOT}"/etc/${i}
done
# If USE=minimal, give out a warning, if AMANDA_SERVER is not set to