summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2005-09-29 21:15:21 +0000
committerBryan Østergaard <kloeri@gentoo.org>2005-09-29 21:15:21 +0000
commit4078ee9830bc86eec7b593970b2716189bfa6c04 (patch)
treea44aa0c1178c559aa7774eb19b7b7d6a33b5ee86 /app-backup/rsnapshot/rsnapshot-1.2.1-r1.ebuild
parent0.9.6-r3 stable on sh. (diff)
downloadgentoo-2-4078ee9830bc86eec7b593970b2716189bfa6c04.tar.gz
gentoo-2-4078ee9830bc86eec7b593970b2716189bfa6c04.tar.bz2
gentoo-2-4078ee9830bc86eec7b593970b2716189bfa6c04.zip
Also install examples, patch by Felipe Massia Pereira.
(Portage version: 2.0.52-r1)
Diffstat (limited to 'app-backup/rsnapshot/rsnapshot-1.2.1-r1.ebuild')
-rw-r--r--app-backup/rsnapshot/rsnapshot-1.2.1-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-backup/rsnapshot/rsnapshot-1.2.1-r1.ebuild b/app-backup/rsnapshot/rsnapshot-1.2.1-r1.ebuild
new file mode 100644
index 000000000000..1e855d06e684
--- /dev/null
+++ b/app-backup/rsnapshot/rsnapshot-1.2.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/rsnapshot/rsnapshot-1.2.1-r1.ebuild,v 1.1 2005/09/29 21:15:21 kloeri Exp $
+
+inherit eutils
+
+DESCRIPTION="rsnapshot is a filesystem backup utility based on rsync."
+HOMEPAGE="http://www.rsnapshot.org"
+SRC_URI="http://www.rsnapshot.org/downloads/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5.8.2
+ >=sys-apps/util-linux-2.12-r4
+ >=sys-apps/coreutils-5.0.91-r4
+ >=net-misc/openssh-3.7.1_p2-r1
+ >=net-misc/rsync-2.6.0"
+
+src_compile() {
+ econf \
+ --prefix=/usr \
+ --sysconfdir=/etc || die
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+
+ dodoc INSTALL README AUTHORS TODO
+ docinto utils
+ dodoc utils/{README,rsnaptar,*.sh}
+}
+
+pkg_postinst() {
+ einfo
+ einfo "The configuration file: /etc/rsnapshot.conf.default "
+ einfo " has been installed. "
+ einfo "This is a template. "
+ einfo "Copy, or move, the above file to: /etc/rsnapshot.conf "
+ einfo "Note that upgrading will update the template, not real config. "
+ einfo
+}