summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2014-12-01 16:28:47 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2014-12-01 16:28:47 +0000
commitaa3837f05e040c3692137fe0ac55bff08619302f (patch)
tree31b53d91edf61f3059a973cd43e224f708c84b4d /app-backup
parentversion bump (bug #531208) (diff)
downloadgentoo-2-aa3837f05e040c3692137fe0ac55bff08619302f.tar.gz
gentoo-2-aa3837f05e040c3692137fe0ac55bff08619302f.tar.bz2
gentoo-2-aa3837f05e040c3692137fe0ac55bff08619302f.zip
Add initial version of the burp package. Import ebuilds from the aidecoe's
overlay [1]. Add various versions at once: 1.3.48 is the latest stable version, 1.4.26 is the latest stable candidate and 1.3.8 is an old version for people who use burp on Debian and want to have the same version. Thanks for contribution to (in order by first name): - Aurelien Reynaud <aurelien@wattapower.net> - Jared B. <nitro@legroom.net> - Jeroen Roovers <jer@gentoo.org> Thanks to perfinion for review. [1] https://github.com/aidecoe/aidecoe-overlay (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key F0134531E1DBFAB5)
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/burp/ChangeLog27
-rw-r--r--app-backup/burp/burp-1.3.48.ebuild104
-rw-r--r--app-backup/burp/burp-1.3.8.ebuild99
-rw-r--r--app-backup/burp/burp-1.4.26.ebuild104
-rw-r--r--app-backup/burp/files/1.3.48-bedup-conf-path.patch33
-rw-r--r--app-backup/burp/files/1.3.48-tinfo.patch22
-rw-r--r--app-backup/burp/files/1.3.8-bedup-conf-path.patch33
-rw-r--r--app-backup/burp/files/1.4.26-bedup-conf-path.patch33
-rw-r--r--app-backup/burp/files/1.4.26-tinfo.patch22
-rw-r--r--app-backup/burp/files/burp.initd35
-rw-r--r--app-backup/burp/metadata.xml14
11 files changed, 526 insertions, 0 deletions
diff --git a/app-backup/burp/ChangeLog b/app-backup/burp/ChangeLog
new file mode 100644
index 000000000000..26d58f1f2304
--- /dev/null
+++ b/app-backup/burp/ChangeLog
@@ -0,0 +1,27 @@
+# ChangeLog for app-backup/burp
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/burp/ChangeLog,v 1.1 2014/12/01 16:28:47 aidecoe Exp $
+
+*burp-1.4.26 (01 Dec 2014)
+*burp-1.3.48 (01 Dec 2014)
+*burp-1.3.8 (01 Dec 2014)
+
+ 01 Dec 2014; Amadeusz Żołnowski <aidecoe@gentoo.org> +burp-1.3.8.ebuild,
+ +burp-1.3.48.ebuild, +burp-1.4.26.ebuild, +files/1.3.8-bedup-conf-path.patch,
+ +files/1.3.48-bedup-conf-path.patch, +files/1.3.48-tinfo.patch,
+ +files/1.4.26-bedup-conf-path.patch, +files/1.4.26-tinfo.patch,
+ +files/burp.initd, +metadata.xml:
+ Add initial version of the burp package. Import ebuilds from the aidecoe's
+ overlay [1]. Add various versions at once: 1.3.48 is the latest stable
+ version, 1.4.26 is the latest stable candidate and 1.3.8 is an old version
+ for people who use burp on Debian and want to have the same version.
+
+ Thanks for contribution to (in order by first name):
+ - Aurelien Reynaud <aurelien@wattapower.net>
+ - Jared B. <nitro@legroom.net>
+ - Jeroen Roovers <jer@gentoo.org>
+
+ Thanks to perfinion for review.
+
+ [1] https://github.com/aidecoe/aidecoe-overlay
+
diff --git a/app-backup/burp/burp-1.3.48.ebuild b/app-backup/burp/burp-1.3.48.ebuild
new file mode 100644
index 000000000000..c53ff2415979
--- /dev/null
+++ b/app-backup/burp/burp-1.3.48.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/burp/burp-1.3.48.ebuild,v 1.1 2014/12/01 16:28:47 aidecoe Exp $
+
+EAPI=5
+
+inherit autotools eutils user
+
+DESCRIPTION="Network backup and restore client and server for Unix and Windows"
+HOMEPAGE="http://burp.grke.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="acl afs ipv6 nls ssl tcpd xattr"
+
+DEPEND="
+ dev-libs/uthash
+ sys-libs/libcap
+ net-libs/librsync
+ sys-libs/ncurses
+ sys-libs/zlib
+ acl? ( sys-apps/acl )
+ afs? ( net-fs/openafs )
+ nls? ( sys-devel/gettext )
+ ssl? ( dev-libs/openssl )
+ tcpd? ( sys-apps/tcp-wrappers )
+ xattr? ( sys-apps/attr )
+ "
+RDEPEND="${DEPEND}
+ virtual/logger
+ "
+
+DOCS=( CONTRIBUTORS DONATIONS UPGRADING )
+PATCHES=(
+ "${FILESDIR}/${PV}-bedup-conf-path.patch"
+ "${FILESDIR}/${PV}-tinfo.patch"
+ )
+S="${WORKDIR}/burp"
+
+pkg_setup() {
+ enewgroup "${PN}"
+ enewuser "${PN}" -1 "" "" "${PN}"
+}
+
+src_prepare() {
+ epatch "${PATCHES[@]}"
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --sbindir=/usr/sbin
+ --sysconfdir=/etc/burp
+ --enable-largefile
+ $(use_with ssl openssl)
+ $(use_enable acl)
+ $(use_enable afs)
+ $(use_enable ipv6)
+ $(use_enable nls)
+ $(use_enable xattr)
+ $(use_with tcpd tcp-wrappers)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ fowners root:burp /etc/burp /var/spool/burp
+ fperms 0775 /etc/burp /var/spool/burp
+ fowners root:burp /etc/burp/clientconfdir
+ fperms 0750 /etc/burp/clientconfdir
+ fowners root:burp /etc/burp/burp-server.conf
+ fperms 0640 /etc/burp/burp-server.conf
+
+ if use ssl; then
+ # The server will create this directory if it doesn't exist, but the
+ # client won't. It must be writable by both.
+ dodir /etc/burp/CA
+ fowners root:burp /etc/burp/CA
+ fperms 0775 /etc/burp/CA
+ fi
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ dodoc docs/*
+
+ sed -e 's|^# user=graham|user = burp|' \
+ -e 's|^# group=nogroup|group = burp|' \
+ -e 's|^pidfile = .*|lockfile = /run/lock/burp/server.lock|' \
+ -i "${D}"/etc/burp/burp-server.conf || die
+}
+
+pkg_postinst() {
+ if use ssl && [ ! -e /etc/burp/CA/index.txt ]; then
+ elog "At first run burp server will generate DH parameters and SSL"
+ elog "certificates. You should adjust configuration before."
+ elog "Server configuration is located at"
+ elog ""
+ elog " /etc/burp/burp-server.conf"
+ elog ""
+ fi
+}
diff --git a/app-backup/burp/burp-1.3.8.ebuild b/app-backup/burp/burp-1.3.8.ebuild
new file mode 100644
index 000000000000..0947dc074e8d
--- /dev/null
+++ b/app-backup/burp/burp-1.3.8.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/burp/burp-1.3.8.ebuild,v 1.1 2014/12/01 16:28:47 aidecoe Exp $
+
+EAPI=5
+
+inherit eutils user
+
+DESCRIPTION="Network backup and restore client and server for Unix and Windows"
+HOMEPAGE="http://burp.grke.org/"
+SRC_URI="http://burp.grke.org/downloads/${P}/${P}.tar.bz2"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="acl afs nls ssl tcpd xattr"
+
+DEPEND="
+ dev-libs/uthash
+ sys-libs/libcap
+ net-libs/librsync
+ sys-libs/ncurses
+ sys-libs/zlib
+ acl? ( sys-apps/acl )
+ afs? ( net-fs/openafs )
+ nls? ( sys-devel/gettext )
+ ssl? ( dev-libs/openssl )
+ tcpd? ( sys-apps/tcp-wrappers )
+ xattr? ( sys-apps/attr )
+ "
+RDEPEND="${DEPEND}
+ virtual/logger
+ "
+
+DOCS=( CONTRIBUTORS DONATIONS UPGRADING )
+PATCHES=( "${FILESDIR}/${PV}-bedup-conf-path.patch" )
+S="${WORKDIR}/burp"
+
+pkg_setup() {
+ enewgroup "${PN}"
+ enewuser "${PN}" -1 "" "" "${PN}"
+}
+
+src_prepare() {
+ epatch "${PATCHES[@]}"
+}
+
+src_configure() {
+ local myeconfargs=(
+ --sbindir=/usr/sbin
+ --sysconfdir=/etc/burp
+ --enable-largefile
+ $(use_with ssl openssl)
+ $(use_enable acl)
+ $(use_enable afs)
+ $(use_enable nls)
+ $(use_enable xattr)
+ $(use_with tcpd tcp-wrappers)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ fowners root:burp /etc/burp /var/spool/burp
+ fperms 0775 /etc/burp /var/spool/burp
+ fowners root:burp /etc/burp/clientconfdir
+ fperms 0750 /etc/burp/clientconfdir
+ fowners root:burp /etc/burp/burp-server.conf
+ fperms 0640 /etc/burp/burp-server.conf
+
+ if use ssl; then
+ # The server will create this directory if it doesn't exist, but the
+ # client won't. It must be writable by both.
+ dodir /etc/burp/CA
+ fowners root:burp /etc/burp/CA
+ fperms 0775 /etc/burp/CA
+ fi
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ dodoc docs/*
+
+ sed -e 's|^# user=graham|user = burp|' \
+ -e 's|^# group=nogroup|group = burp|' \
+ -e 's|^pidfile = .*|lockfile = /run/lock/burp/server.lock|' \
+ -i "${D}"/etc/burp/burp-server.conf || die
+}
+
+pkg_postinst() {
+ if use ssl && [ ! -e /etc/burp/CA/index.txt ]; then
+ elog "At first run burp server will generate DH parameters and SSL"
+ elog "certificates. You should adjust configuration before."
+ elog "Server configuration is located at"
+ elog ""
+ elog " /etc/burp/burp-server.conf"
+ elog ""
+ fi
+}
diff --git a/app-backup/burp/burp-1.4.26.ebuild b/app-backup/burp/burp-1.4.26.ebuild
new file mode 100644
index 000000000000..91a6c57fcc3e
--- /dev/null
+++ b/app-backup/burp/burp-1.4.26.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/burp/burp-1.4.26.ebuild,v 1.1 2014/12/01 16:28:47 aidecoe Exp $
+
+EAPI=5
+
+inherit autotools eutils user
+
+DESCRIPTION="Network backup and restore client and server for Unix and Windows"
+HOMEPAGE="http://burp.grke.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="acl afs ipv6 nls ssl tcpd xattr"
+
+DEPEND="
+ dev-libs/uthash
+ sys-libs/libcap
+ net-libs/librsync
+ sys-libs/ncurses
+ sys-libs/zlib
+ acl? ( sys-apps/acl )
+ afs? ( net-fs/openafs )
+ nls? ( sys-devel/gettext )
+ ssl? ( dev-libs/openssl )
+ tcpd? ( sys-apps/tcp-wrappers )
+ xattr? ( sys-apps/attr )
+ "
+RDEPEND="${DEPEND}
+ virtual/logger
+ "
+
+DOCS=( CONTRIBUTORS DONATIONS UPGRADING )
+PATCHES=(
+ "${FILESDIR}/${PV}-bedup-conf-path.patch"
+ "${FILESDIR}/${PV}-tinfo.patch"
+ )
+S="${WORKDIR}/burp"
+
+pkg_setup() {
+ enewgroup "${PN}"
+ enewuser "${PN}" -1 "" "" "${PN}"
+}
+
+src_prepare() {
+ epatch "${PATCHES[@]}"
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --sbindir=/usr/sbin
+ --sysconfdir=/etc/burp
+ --enable-largefile
+ $(use_with ssl openssl)
+ $(use_enable acl)
+ $(use_enable afs)
+ $(use_enable ipv6)
+ $(use_enable nls)
+ $(use_enable xattr)
+ $(use_with tcpd tcp-wrappers)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ fowners root:burp /etc/burp /var/spool/burp
+ fperms 0775 /etc/burp /var/spool/burp
+ fowners root:burp /etc/burp/clientconfdir
+ fperms 0750 /etc/burp/clientconfdir
+ fowners root:burp /etc/burp/burp-server.conf
+ fperms 0640 /etc/burp/burp-server.conf
+
+ if use ssl; then
+ # The server will create this directory if it doesn't exist, but the
+ # client won't. It must be writable by both.
+ dodir /etc/burp/CA
+ fowners root:burp /etc/burp/CA
+ fperms 0775 /etc/burp/CA
+ fi
+
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ dodoc docs/*
+
+ sed -e 's|^# user=graham|user = burp|' \
+ -e 's|^# group=nogroup|group = burp|' \
+ -e 's|^pidfile = .*|lockfile = /run/lock/burp/server.lock|' \
+ -i "${D}"/etc/burp/burp-server.conf || die
+}
+
+pkg_postinst() {
+ if use ssl && [ ! -e /etc/burp/CA/index.txt ]; then
+ elog "At first run burp server will generate DH parameters and SSL"
+ elog "certificates. You should adjust configuration before."
+ elog "Server configuration is located at"
+ elog ""
+ elog " /etc/burp/burp-server.conf"
+ elog ""
+ fi
+}
diff --git a/app-backup/burp/files/1.3.48-bedup-conf-path.patch b/app-backup/burp/files/1.3.48-bedup-conf-path.patch
new file mode 100644
index 000000000000..a9bed192d96c
--- /dev/null
+++ b/app-backup/burp/files/1.3.48-bedup-conf-path.patch
@@ -0,0 +1,33 @@
+diff -Naur burp-1.3.48/manpages/bedup.8 burp-1.3.48.new/manpages/bedup.8
+--- burp-1.3.48/manpages/bedup.8 2014-01-27 11:55:47.000000000 +0100
++++ burp-1.3.48.new/manpages/bedup.8 2014-11-22 12:57:20.241299376 +0100
+@@ -16,7 +16,7 @@
+ .SH OPTIONS
+ .TP
+ \fB\-c\fR \fBpath\fR
+-Path to config file (default: /etc/burp/burp.conf).
++Path to config file (default: /etc/burp/burp-server.conf).
+ .TP
+ \fB\-g\fR \fB<list of group names>\fR
+ Only run on the directories of clients that are in one of the groups specified. The list is comma-separated. To put a client in a group, use the 'dedup_group' option in the client configuration file on the server.
+@@ -42,7 +42,7 @@
+ \fB\-V\fR \fB\fR
+ Print version and exit.\fR
+ .TP
+-By default, bedup will read /etc/burp/burp.conf and deduplicate client storage directories using special knowledge of the structure.\fR
++By default, bedup will read /etc/burp/burp-server.conf and deduplicate client storage directories using special knowledge of the structure.\fR
+ .TP
+ With '\-n', this knowledge is turned off and you have to specify the directories to deduplicate on the command line. Running with '\-n' is therefore dangerous if you are deduplicating burp storage directories.
+
+diff -Naur burp-1.3.48/src/bedup.c burp-1.3.48.new/src/bedup.c
+--- burp-1.3.48/src/bedup.c 2014-01-27 11:55:47.000000000 +0100
++++ burp-1.3.48.new/src/bedup.c 2014-11-22 12:57:20.241299376 +0100
+@@ -734,7 +734,7 @@
+ static char *get_config_path(void)
+ {
+ static char path[256]="";
+- snprintf(path, sizeof(path), "%s", SYSCONFDIR "/burp.conf");
++ snprintf(path, sizeof(path), "%s", SYSCONFDIR "/burp-server.conf");
+ return path;
+ }
+
diff --git a/app-backup/burp/files/1.3.48-tinfo.patch b/app-backup/burp/files/1.3.48-tinfo.patch
new file mode 100644
index 000000000000..30b5cb88d6e8
--- /dev/null
+++ b/app-backup/burp/files/1.3.48-tinfo.patch
@@ -0,0 +1,22 @@
+diff -Naur burp-1.3.48/configure.in burp-1.3.48.new/configure.in
+--- burp-1.3.48/configure.in 2014-01-27 11:55:47.000000000 +0100
++++ burp-1.3.48.new/configure.in 2014-11-22 13:01:01.192403673 +0100
+@@ -1203,13 +1203,12 @@
+ fi
+
+ AC_CHECK_HEADERS(ncurses.h)
+-AC_CHECK_LIB(ncurses, curs_set, [NCURSES_LIBS="-lncurses"])
+ have_ncurses=no
+-if test x$NCURSES_LIBS = x-lncurses; then
+- AC_DEFINE(HAVE_NCURSES, 1, [Defined to 1 if libncurses was found])
+- have_ncurses=yes
+-fi
+-AC_SUBST(NCURSES_LIBS)
++AC_CHECK_LIB(ncurses, endwin,
++ [NCURSES_LIBS="-lncurses"; have_ncurses=yes]
++ AC_SEARCH_LIBS(curs_set, tinfo, [NCURSES_LIBS="$NCURSES_LIBS $ac_res"]),
++ AC_DEFINE(HAVE_NCURSES, 1, [Defined to 1 if libncurses was found])
++ AC_SUBST(NCURSES_LIBS))
+
+ dnl
+ dnl Check if we have AFS on this system
diff --git a/app-backup/burp/files/1.3.8-bedup-conf-path.patch b/app-backup/burp/files/1.3.8-bedup-conf-path.patch
new file mode 100644
index 000000000000..a9bed192d96c
--- /dev/null
+++ b/app-backup/burp/files/1.3.8-bedup-conf-path.patch
@@ -0,0 +1,33 @@
+diff -Naur burp-1.3.48/manpages/bedup.8 burp-1.3.48.new/manpages/bedup.8
+--- burp-1.3.48/manpages/bedup.8 2014-01-27 11:55:47.000000000 +0100
++++ burp-1.3.48.new/manpages/bedup.8 2014-11-22 12:57:20.241299376 +0100
+@@ -16,7 +16,7 @@
+ .SH OPTIONS
+ .TP
+ \fB\-c\fR \fBpath\fR
+-Path to config file (default: /etc/burp/burp.conf).
++Path to config file (default: /etc/burp/burp-server.conf).
+ .TP
+ \fB\-g\fR \fB<list of group names>\fR
+ Only run on the directories of clients that are in one of the groups specified. The list is comma-separated. To put a client in a group, use the 'dedup_group' option in the client configuration file on the server.
+@@ -42,7 +42,7 @@
+ \fB\-V\fR \fB\fR
+ Print version and exit.\fR
+ .TP
+-By default, bedup will read /etc/burp/burp.conf and deduplicate client storage directories using special knowledge of the structure.\fR
++By default, bedup will read /etc/burp/burp-server.conf and deduplicate client storage directories using special knowledge of the structure.\fR
+ .TP
+ With '\-n', this knowledge is turned off and you have to specify the directories to deduplicate on the command line. Running with '\-n' is therefore dangerous if you are deduplicating burp storage directories.
+
+diff -Naur burp-1.3.48/src/bedup.c burp-1.3.48.new/src/bedup.c
+--- burp-1.3.48/src/bedup.c 2014-01-27 11:55:47.000000000 +0100
++++ burp-1.3.48.new/src/bedup.c 2014-11-22 12:57:20.241299376 +0100
+@@ -734,7 +734,7 @@
+ static char *get_config_path(void)
+ {
+ static char path[256]="";
+- snprintf(path, sizeof(path), "%s", SYSCONFDIR "/burp.conf");
++ snprintf(path, sizeof(path), "%s", SYSCONFDIR "/burp-server.conf");
+ return path;
+ }
+
diff --git a/app-backup/burp/files/1.4.26-bedup-conf-path.patch b/app-backup/burp/files/1.4.26-bedup-conf-path.patch
new file mode 100644
index 000000000000..30346d466148
--- /dev/null
+++ b/app-backup/burp/files/1.4.26-bedup-conf-path.patch
@@ -0,0 +1,33 @@
+diff -Naur burp/manpages/bedup.8 burp.new/manpages/bedup.8
+--- burp/manpages/bedup.8 2014-10-28 12:45:26.000000000 +0100
++++ burp.new/manpages/bedup.8 2014-11-21 09:49:57.705796144 +0100
+@@ -16,7 +16,7 @@
+ .SH OPTIONS
+ .TP
+ \fB\-c\fR \fBpath\fR
+-Path to config file (default: /etc/burp/burp.conf).
++Path to config file (default: /etc/burp/burp-server.conf).
+ .TP
+ \fB\-g\fR \fB<list of group names>\fR
+ Only run on the directories of clients that are in one of the groups specified. The list is comma-separated. To put a client in a group, use the 'dedup_group' option in the client configuration file on the server.
+@@ -42,7 +42,7 @@
+ \fB\-V\fR \fB\fR
+ Print version and exit.\fR
+ .TP
+-By default, bedup will read /etc/burp/burp.conf and deduplicate client storage directories using special knowledge of the structure.\fR
++By default, bedup will read /etc/burp/burp-server.conf and deduplicate client storage directories using special knowledge of the structure.\fR
+ .TP
+ With '\-n', this knowledge is turned off and you have to specify the directories to deduplicate on the command line. Running with '\-n' is therefore dangerous if you are deduplicating burp storage directories.
+
+diff -Naur burp/src/bedup.c burp.new/src/bedup.c
+--- burp/src/bedup.c 2014-10-28 12:45:56.000000000 +0100
++++ burp.new/src/bedup.c 2014-11-20 21:39:28.728206536 +0100
+@@ -740,7 +740,7 @@
+ static char *get_config_path(void)
+ {
+ static char path[256]="";
+- snprintf(path, sizeof(path), "%s", SYSCONFDIR "/burp.conf");
++ snprintf(path, sizeof(path), "%s", SYSCONFDIR "/burp-server.conf");
+ return path;
+ }
+
diff --git a/app-backup/burp/files/1.4.26-tinfo.patch b/app-backup/burp/files/1.4.26-tinfo.patch
new file mode 100644
index 000000000000..081492261685
--- /dev/null
+++ b/app-backup/burp/files/1.4.26-tinfo.patch
@@ -0,0 +1,22 @@
+diff -Naur burp/configure.ac burp-new/configure.ac
+--- burp/configure.ac 2014-10-28 12:45:56.000000000 +0100
++++ burp-new/configure.ac 2014-11-10 17:40:50.996955441 +0100
+@@ -1203,13 +1203,12 @@
+ fi
+
+ AC_CHECK_HEADERS(ncurses.h)
+-AC_CHECK_LIB(ncurses, curs_set, [NCURSES_LIBS="-lncurses"])
+ have_ncurses=no
+-if test x$NCURSES_LIBS = x-lncurses; then
+- AC_DEFINE(HAVE_NCURSES, 1, [Defined to 1 if libncurses was found])
+- have_ncurses=yes
+-fi
+-AC_SUBST(NCURSES_LIBS)
++AC_CHECK_LIB(ncurses, endwin,
++ [NCURSES_LIBS="-lncurses"; have_ncurses=yes]
++ AC_SEARCH_LIBS(curs_set, tinfo, [NCURSES_LIBS="$NCURSES_LIBS $ac_res"]),
++ AC_DEFINE(HAVE_NCURSES, 1, [Defined to 1 if libncurses was found])
++ AC_SUBST(NCURSES_LIBS))
+
+ dnl
+ dnl Check if we have AFS on this system
diff --git a/app-backup/burp/files/burp.initd b/app-backup/burp/files/burp.initd
new file mode 100644
index 000000000000..d145cd6ae54a
--- /dev/null
+++ b/app-backup/burp/files/burp.initd
@@ -0,0 +1,35 @@
+#!/sbin/runscript
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/burp/files/burp.initd,v 1.1 2014/12/01 16:28:47 aidecoe Exp $
+
+PIDFILE=/run/burp-server.pid
+
+depend() {
+ need localmount
+ after bootmisc
+ use net
+}
+
+start() {
+ ebegin "Starting burp server"
+ checkpath -o burp:burp -m 0775 -d /run/lock/burp
+ checkpath -o root:burp -m 0775 -d /etc/burp
+ checkpath -o root:burp -m 0775 -d /etc/burp/CA
+ checkpath -o root:burp -m 0750 -d /etc/burp/clientconfdir
+ checkpath -o root:burp -m 0640 -f /etc/burp/burp-server.conf
+ start-stop-daemon --start \
+ --pidfile "$PIDFILE" \
+ --make-pidfile \
+ --background \
+ --wait 500 \
+ --exec /usr/sbin/burp -- -c /etc/burp/burp-server.conf -F
+ eend $? "Failed to start burp server"
+}
+
+stop() {
+ ebegin "Stopping burp server"
+ start-stop-daemon --stop \
+ --pidfile "$PIDFILE"
+ eend $? "Failed to stop burp server"
+}
diff --git a/app-backup/burp/metadata.xml b/app-backup/burp/metadata.xml
new file mode 100644
index 000000000000..fefff58c2808
--- /dev/null
+++ b/app-backup/burp/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>aidecoe@gentoo.org</email>
+ <name>Amadeusz Żołnowski</name>
+ </maintainer>
+ <longdescription lang="en">
+ Burp is a network backup and restore program. It uses librsync in order
+ to save network traffic and to save on the amount of space that is used
+ by each backup. It also uses VSS (Volume Shadow Copy Service) to make
+ snapshots when backing up Windows computers.
+ </longdescription>
+</pkgmetadata>