summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-06-25 20:52:21 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-06-25 20:52:21 +0000
commit7debca8b7ec7d8f31ca862d3c5090636edb8a70c (patch)
tree7ad1e18dec22595deb567eb2311294c2a028c19d /app-benchmarks/bonnie++/bonnie++-1.03.ebuild
parentMoved app-misc/bonnie++ to app-benchmarks/bonnie++ (diff)
downloadgentoo-2-7debca8b7ec7d8f31ca862d3c5090636edb8a70c.tar.gz
gentoo-2-7debca8b7ec7d8f31ca862d3c5090636edb8a70c.tar.bz2
gentoo-2-7debca8b7ec7d8f31ca862d3c5090636edb8a70c.zip
Moved app-misc/bonnie++ to app-benchmarks/bonnie++
Diffstat (limited to 'app-benchmarks/bonnie++/bonnie++-1.03.ebuild')
-rw-r--r--app-benchmarks/bonnie++/bonnie++-1.03.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-benchmarks/bonnie++/bonnie++-1.03.ebuild b/app-benchmarks/bonnie++/bonnie++-1.03.ebuild
new file mode 100644
index 000000000000..7e19d4e7a24f
--- /dev/null
+++ b/app-benchmarks/bonnie++/bonnie++-1.03.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bonnie++/bonnie++-1.03.ebuild,v 1.1 2003/06/25 20:51:56 mholzer Exp $
+
+DESCRIPTION="Hard drive bottleneck testing benchmark suite."
+SRC_URI="http://www.coker.com.au/bonnie++/${P}.tgz"
+HOMEPAGE="http://www.coker.com.au/bonnie++/"
+
+SLOT="0"
+LICENSE="GPL-2"
+# I think this should work on other than x86 platforms (by sandymac)
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+IUSE=""
+DEPEND="virtual/glibc"
+
+src_compile() {
+ local myconf=""
+ [ "$DEBUG" == "true" ] && myconf="--with-debug --disable-stripping"
+
+ econf ${myconf}
+ emake || die "emake failed"
+ emake zcav || die "emake zcav failed" # see #9073
+}
+
+src_install() {
+ dosbin bonnie++ zcav
+ dobin bon_csv2html bon_csv2txt
+ doman bon_csv2html.1 bon_csv2txt.1 bonnie++.8 zcav.8
+ dohtml readme.html
+ dodoc changelog.txt copyright.txt credits.txt
+}