summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-11-03 21:55:37 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-11-03 21:55:37 +0000
commit5c73ece76f35f2ddf916f0f3fa9bbdb596eca4b0 (patch)
tree03988fc38982eb53a1997e181136933be1f57410 /app-benchmarks/siege/siege-2.64-r1.ebuild
parentAdd some sedfu to escape certain things in the siege.config script that get i... (diff)
downloadgentoo-2-5c73ece76f35f2ddf916f0f3fa9bbdb596eca4b0.tar.gz
gentoo-2-5c73ece76f35f2ddf916f0f3fa9bbdb596eca4b0.tar.bz2
gentoo-2-5c73ece76f35f2ddf916f0f3fa9bbdb596eca4b0.zip
err forgot to bump revisions.
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'app-benchmarks/siege/siege-2.64-r1.ebuild')
-rw-r--r--app-benchmarks/siege/siege-2.64-r1.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/app-benchmarks/siege/siege-2.64-r1.ebuild b/app-benchmarks/siege/siege-2.64-r1.ebuild
new file mode 100644
index 000000000000..490579ffd83e
--- /dev/null
+++ b/app-benchmarks/siege/siege-2.64-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/siege-2.64-r1.ebuild,v 1.1 2005/11/03 21:55:37 ka0ttic Exp $
+
+inherit eutils bash-completion
+
+DESCRIPTION="A HTTP regression testing and benchmarking utility"
+HOMEPAGE="http://www.joedog.org/siege/"
+SRC_URI="ftp://sid.joedog.org/pub/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~mips ~ppc ~x86"
+SLOT="0"
+IUSE="debug ssl"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6d )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${PN}-2.60-gentoo.diff
+
+ # use of \b causes the T in "Transactions" to be displayed
+ # on the last column of the previous line.
+ sed -i 's/\\b\(Transactions:\)/\1/' src/main.c || \
+ die "sed src/main.c failed"
+
+ automake || die "automake failed"
+}
+
+src_compile() {
+ local myconf
+ use ssl && myconf="--with-ssl=/usr" || myconf="--without-ssl"
+
+ econf ${myconf} \
+ $(use_with debug debugging) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ # bug 111057 - siege.config utility uses ${} which gets
+ # interpreted by bash sending the contents to stderr
+ # instead of ${HOME}/.siegerc
+ sed -i -e 's|\${}|\\${}|' -e 's|\$(HOME)|\\$(HOME)|' \
+ ${D}/usr/bin/siege.config
+
+ dodoc AUTHORS ChangeLog INSTALL MACHINES README* KNOWNBUGS \
+ siegerc-example urls.txt || die "dodoc failed"
+ dobashcompletion ${FILESDIR}/${PN}.bash-completion
+
+ for x in $(find ${D}/usr/bin -name '*.pl') ; do mv "${x}" "${x%.*}" ; done
+}
+
+pkg_postinst() {
+ echo
+ einfo "An example ~/.siegerc file has been installed as"
+ einfo "/usr/share/doc/${PF}/siegerc-example.gz"
+ bash-completion_pkg_postinst
+}