summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-06-29 10:00:28 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-06-29 10:00:28 +0000
commit4cbe59a31056f01176cccfc21fbcdf08a7563b3f (patch)
tree89257dd91617f28f8890b424e2cf8ee5350b4eb6 /app-benchmarks
parentAdd missing die: || "..." -> || die "..." (diff)
downloadgentoo-2-4cbe59a31056f01176cccfc21fbcdf08a7563b3f.tar.gz
gentoo-2-4cbe59a31056f01176cccfc21fbcdf08a7563b3f.tar.bz2
gentoo-2-4cbe59a31056f01176cccfc21fbcdf08a7563b3f.zip
Fix for gcc-4.3, drop old. Bug #226383.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25.8 i686)
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/bashmark/ChangeLog7
-rw-r--r--app-benchmarks/bashmark/bashmark-0.6.1.ebuild17
-rw-r--r--app-benchmarks/bashmark/bashmark-0.6.2.ebuild5
-rw-r--r--app-benchmarks/bashmark/files/bashmark-0.6.2-gcc43.patch48
4 files changed, 57 insertions, 20 deletions
diff --git a/app-benchmarks/bashmark/ChangeLog b/app-benchmarks/bashmark/ChangeLog
index d229d1574a14..1cda9795ddf2 100644
--- a/app-benchmarks/bashmark/ChangeLog
+++ b/app-benchmarks/bashmark/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-benchmarks/bashmark
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bashmark/ChangeLog,v 1.11 2008/01/05 16:01:49 rich0 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bashmark/ChangeLog,v 1.12 2008/06/29 10:00:27 loki_val Exp $
+
+ 29 Jun 2008; Peter Alfredsen <loki_val@gentoo.org>
+ +files/bashmark-0.6.2-gcc43.patch, -bashmark-0.6.1.ebuild,
+ bashmark-0.6.2.ebuild:
+ Fix for gcc-4.3, drop old. Bug #226383.
05 Jan 2008; Richard Freeman <rich0@gentoo.org> bashmark-0.6.2.ebuild:
amd64 stable - bug #204317
diff --git a/app-benchmarks/bashmark/bashmark-0.6.1.ebuild b/app-benchmarks/bashmark/bashmark-0.6.1.ebuild
deleted file mode 100644
index f785ffd4e592..000000000000
--- a/app-benchmarks/bashmark/bashmark-0.6.1.ebuild
+++ /dev/null
@@ -1,17 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bashmark/bashmark-0.6.1.ebuild,v 1.2 2005/06/12 18:33:22 genstef Exp $
-
-DESCRIPTION="Geno's cross platform benchmarking suite"
-HOMEPAGE="http://bashmark.coders-net.de"
-
-SRC_URI="http://bashmark.coders-net.de/download/src/${P}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE=""
-
-src_install() {
- dobin bashmark
- dodoc ChangeLog
-}
diff --git a/app-benchmarks/bashmark/bashmark-0.6.2.ebuild b/app-benchmarks/bashmark/bashmark-0.6.2.ebuild
index d2392e2b5558..58902dd3353c 100644
--- a/app-benchmarks/bashmark/bashmark-0.6.2.ebuild
+++ b/app-benchmarks/bashmark/bashmark-0.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bashmark/bashmark-0.6.2.ebuild,v 1.4 2008/01/05 16:01:49 rich0 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/bashmark/bashmark-0.6.2.ebuild,v 1.5 2008/06/29 10:00:27 loki_val Exp $
inherit eutils
@@ -16,7 +16,8 @@ IUSE=""
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/bashmark-0.6.2-as-needed.patch
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+ epatch "${FILESDIR}"/${P}-gcc43.patch
}
src_install() {
diff --git a/app-benchmarks/bashmark/files/bashmark-0.6.2-gcc43.patch b/app-benchmarks/bashmark/files/bashmark-0.6.2-gcc43.patch
new file mode 100644
index 000000000000..625abdab397b
--- /dev/null
+++ b/app-benchmarks/bashmark/files/bashmark-0.6.2-gcc43.patch
@@ -0,0 +1,48 @@
+diff -NrU5 bashmark-0.6.2.orig/Benchmark.cpp bashmark-0.6.2/Benchmark.cpp
+--- bashmark-0.6.2.orig/Benchmark.cpp 2008-06-29 11:53:07.000000000 +0200
++++ bashmark-0.6.2/Benchmark.cpp 2008-06-29 11:54:02.000000000 +0200
+@@ -15,11 +15,11 @@
+ * *
+ * You should have received a copy of the GNU General Public License *
+ * along with this software; if not, write to the Free Software *
+ * Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA. *
+ ***************************************************************************/
+-#include <string>
++#include <cstring>
+ #include "Benchmark.hpp"
+ #include "Stopwatch.hpp"
+ #include "Main.hpp"
+
+
+diff -NrU5 bashmark-0.6.2.orig/main.cpp bashmark-0.6.2/main.cpp
+--- bashmark-0.6.2.orig/main.cpp 2008-06-29 11:53:07.000000000 +0200
++++ bashmark-0.6.2/main.cpp 2008-06-29 11:56:40.000000000 +0200
+@@ -17,10 +17,11 @@
+ * along with this software; if not, write to the Free Software *
+ * Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA. *
+ ***************************************************************************/
+
+ #include <sstream>
++#include <cstring>
+ using std::stringstream;
+
+
+ #include "Output.hpp"
+ #include "Sysinfo.hpp"
+diff -NrU5 bashmark-0.6.2.orig/Sysinfo.cpp bashmark-0.6.2/Sysinfo.cpp
+--- bashmark-0.6.2.orig/Sysinfo.cpp 2008-06-29 11:53:07.000000000 +0200
++++ bashmark-0.6.2/Sysinfo.cpp 2008-06-29 11:55:58.000000000 +0200
+@@ -15,11 +15,12 @@
+ * *
+ * You should have received a copy of the GNU General Public License *
+ * along with this software; if not, write to the Free Software *
+ * Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA. *
+ ***************************************************************************/
+-
++
++#include <cstring>
+ #include "Sysinfo.hpp"
+
+ using Geno::Sysinfo;
+ using Geno::Cpu_Info;
+