summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2011-02-23 00:20:30 +0000
committerSebastian Pipping <sping@gentoo.org>2011-02-23 00:20:30 +0000
commit53106993284a6d2cf1de5cb8f4a9f92484b6c0f2 (patch)
tree4c71a5580760bfecf90cc722a4d9c61773a60abb /app-crypt/bcwipe
parentVersion bump; upstream merged my patch and made a new release. Also drop .la ... (diff)
downloadgentoo-2-53106993284a6d2cf1de5cb8f4a9f92484b6c0f2.tar.gz
gentoo-2-53106993284a6d2cf1de5cb8f4a9f92484b6c0f2.tar.bz2
gentoo-2-53106993284a6d2cf1de5cb8f4a9f92484b6c0f2.zip
app-crypt/bcwipe: Bump to 1.9.8
(Portage version: 2.1.9.40/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt/bcwipe')
-rw-r--r--app-crypt/bcwipe/ChangeLog8
-rw-r--r--app-crypt/bcwipe/bcwipe-1.9.8.ebuild49
-rw-r--r--app-crypt/bcwipe/files/bcwipe-1.9.8-fix-flags.patch11
3 files changed, 67 insertions, 1 deletions
diff --git a/app-crypt/bcwipe/ChangeLog b/app-crypt/bcwipe/ChangeLog
index ca013084b2f9..c7c91bbeadec 100644
--- a/app-crypt/bcwipe/ChangeLog
+++ b/app-crypt/bcwipe/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/bcwipe
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/bcwipe/ChangeLog,v 1.49 2011/02/12 18:34:40 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/bcwipe/ChangeLog,v 1.50 2011/02/23 00:20:30 sping Exp $
+
+*bcwipe-1.9.8 (23 Feb 2011)
+
+ 23 Feb 2011; Sebastian Pipping <sping@gentoo.org> +bcwipe-1.9.8.ebuild,
+ +files/bcwipe-1.9.8-fix-flags.patch:
+ Bump to 1.9.8, looks trivial
12 Feb 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
-files/bcwipe-1.9.1-fix_warnings.patch, -bcwipe-1.9.3.ebuild,
diff --git a/app-crypt/bcwipe/bcwipe-1.9.8.ebuild b/app-crypt/bcwipe/bcwipe-1.9.8.ebuild
new file mode 100644
index 000000000000..4bebfcc1f8da
--- /dev/null
+++ b/app-crypt/bcwipe/bcwipe-1.9.8.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/bcwipe/bcwipe-1.9.8.ebuild,v 1.1 2011/02/23 00:20:30 sping Exp $
+
+EAPI="3"
+
+inherit eutils versionator
+
+MY_PV="$(replace_version_separator 2 -)"
+
+DESCRIPTION="Secure file removal utility"
+HOMEPAGE="http://www.jetico.com/"
+SRC_URI="http://www.jetico.com/linux/BCWipe-${MY_PV}.tar.gz
+ doc? ( http://www.jetico.com/linux/BCWipe.doc.tgz )"
+
+LICENSE="bestcrypt"
+SLOT="0"
+IUSE="doc"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.9.7-fix_warnings.patch \
+ "${FILESDIR}"/${P}-fix-flags.patch
+}
+
+src_test() {
+ echo "abc123" >> testfile
+ ./bcwipe -f testfile || die "bcwipe test failed"
+ [[ -f testfile ]] && die "test file still exists. bcwipe should have deleted it"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ if use doc ; then
+ dohtml -r ../bcwipe-help || die "dohtml failed"
+ fi
+}
+
+pkg_postinst() {
+ ewarn "The BestCrypt drivers are not free - Please purchace a license from "
+ ewarn "http://www.jetico.com/"
+ ewarn "full details /usr/share/doc/${PF}/html/bcwipe-help/wu_licen.htm"
+}
diff --git a/app-crypt/bcwipe/files/bcwipe-1.9.8-fix-flags.patch b/app-crypt/bcwipe/files/bcwipe-1.9.8-fix-flags.patch
new file mode 100644
index 000000000000..ac91518e0270
--- /dev/null
+++ b/app-crypt/bcwipe/files/bcwipe-1.9.8-fix-flags.patch
@@ -0,0 +1,11 @@
+--- Makefile.in 2011-02-23 01:07:29.841894634 +0100
++++ Makefile.in 2011-02-23 01:07:46.626793943 +0100
+@@ -174,7 +174,7 @@
+ bcwipe_SOURCES = wipe.c wipe.h options.c options.h schemes.c schemes.h sha1.c sha1.h sha1random.c sha1random.h log.c log.h standard.h rand.h rand.c prng.c
+ man_MANS = bcwipe.1
+ EXTRA_DIST = $(man_MANS) bcwipe.spec.in osxpkg.sh.in
+-AM_CFLAGS = -g -D_LARGE_FILES -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
++AM_CFLAGS = -D_LARGE_FILES -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64
+ all: config.h
+ $(MAKE) $(AM_MAKEFLAGS) all-am
+